poj1655 Balancing Act(树形dp)

Balancing Act

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11176   Accepted: 4702

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node
from T.

For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these
trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers
that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

POJ Monthly--2004.05.15 IOI 2003 sample task

题意:给定一颗n个节点的树,求删除一个节点后所剩的所有子树中节点数最多的节点最少。(表达不是很好,其实就和poj3107一样的)

分析:和poj3107一样的,就只要改下输入输出就可以了,poj3107

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 40010

struct node
{
    int v;
    node *next;
}tree[MAXN], *head[MAXN];
int n,pre,dp[MAXN];
int ans,num,tot;

void init()
{
    ans = INF;
    pre = 1;
    CL(dp, 0);
    CL(head, NULL);
}

void add(int x, int y)
{
    tree[pre].v = y;
    tree[pre].next = head[x]; head[x] = &tree[pre++];
    tree[pre].v = x;
    tree[pre].next = head[y]; head[y] = &tree[pre++];
}

void dfs(int son, int father)
{
    node *p = head[son];
    dp[son] = 1;
    while(p != NULL)
    {
        if(p->v != father)
        {
            dfs(p->v, son);
            dp[son] += dp[p->v];
        }
        p = p->next;
    }
}

void dp_tree(int son, int father)
{
    int maxx = 0;
    node *p = head[son];
    while(p != NULL)
    {
        if(p->v != father)
        {
            dp_tree(p->v, son);
            maxx = max(maxx, dp[p->v]);
        }
        p = p->next;
    }
    maxx = max(maxx, n-dp[son]);
    if(maxx < ans)//对比poj3107,也就改下这里,只把最小的保存下来就行了
    {
        ans = maxx;
        num = son;
    }
    else if(maxx == ans)
    {
        if(num > son) num = son;
    }
}

int main()
{
    int T,a,b;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        init();
        for(int i=1; i<n; i++)
        {
            scanf("%d%d",&a,&b);
            add(a, b);
        }
        dfs(1, 0);
        dp_tree(1, 0);
        printf("%d %d\n",num, ans);
    }
    return 0;
}
时间: 2024-10-18 11:47:16

poj1655 Balancing Act(树形dp)的相关文章

POJ 1655 Balancing Act (树形dp 树的重心)

Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10596   Accepted: 4398 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or m

poj1655 Balancing Act 【树形DP(很弱)】

都不知道怎么分类了. 大概要求一个树中以某个结点为根的子树结点个数,还有儿子结点中以儿子结点为根的子树结点个数的最大值,用递归得到n[i],以i为根节点的子树结点个数 #include <cstdio> #include <cstdlib> #include <iostream> #include <algorithm> #include <vector> #include <cstring> #include <cmath&g

poj1655(dfs,树形dp)

方法:就记节点1为树的根,两次dfs,第一次求出每个节点的所有子孙再加上它自己的节点总数num[i].第二次就算出每个节点的balance值bal[i],算的时候就比较节点i它所有子节点的num值(删掉它之后以每个它的子节点为根形成一棵新树)还有n-num[i]的值(删掉i之后它的父节点及其相关节点也形成一棵新树),最大的就是bal[i]. 注意:WA了几次是因为没有考虑边界情况(n==2),dfs写的太不熟练了,代码能力有待提高啊! #include<iostream> #include&l

poj1655 Balancing Act (dp? dfs?)

Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14247   Accepted: 6026 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or m

poj1655 Balancing Act(找树的重心)

Balancing Act POJ - 1655 题意:给定一棵树,求树的重心的编号以及重心删除后得到的最大子树的节点个数size,如果size相同就选取编号最小的. /* 找树的重心可以用树形dp或者dfs,这里我用的dfs 基本方法就是随便设定一个根节点,然后找出这个节点的子树大小(包括这个节点),然后总点数减去子树的大小就是向父亲节点走去的点数,使这几部分的最大值最小 */ #include<iostream> #include<cstdio> #include<alg

poj1655 Balancing Act 求树的重心

http://poj.org/problem?id=1655 Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9072   Accepted: 3765 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a fo

POJ1655——Balancing Act

Balancing Act Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9143   Accepted: 3797 Description Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or mo

POJ1655 Balancing Act(树的重心)

题目链接 Balancing Act 就是求一棵树的重心,然后统计答案. 1 #include <bits/stdc++.h> 2 3 using namespace std; 4 5 #define REP(i,n) for(int i(0); i < (n); ++i) 6 #define for_edge(i,x) for(int i = H[x]; i; i = X[i]) 7 8 const int INF = 1 << 30; 9 const int N = 10

POJ1655 Balancing Act(树的重心)

题意: 给你一棵树,求树的重心 如果有多个就输出序号最小的 思路: 树的重心就是以它为根的所有子树中节点最多的节点数最小 树形dp轻松可以解决 /* *********************************************** Author :devil ************************************************ */ #include <cstdio> #include <cstring> #include <iost