POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!【文本】

Excuses, Excuses!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4701 Accepted: 1602

Description

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data. Line 1 of each set will contain exactly two integers. The first number (1 <= K <= 20) defines the number of keywords to be used in the search. The second number (1 <= E <= 20) defines the number of excuses in the set to be searched. Lines 2 through K+1 each contain exactly one keyword. Lines K+2 through K+1+E each contain exactly one excuse. All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (1 <= L <= 20) and will occupy columns 1 through L in the input line. All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [".,!?] not including the square brackets and will not exceed 70 characters in length. Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list. The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords. If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword "occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string "Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order. After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!

Source

South Central USA 1996

Regionals 1996 >> North America - South Central USA

问题链接POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!
问题简述:(略)
问题分析
????文本处理题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses! */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>

using namespace std;

const int K = 20;
const int E = 20;
const int L = 20;
const int L2 = 70;
char key[K][L + 1], excuse[E][L2 + 1], t[L2 + 1];
int sum[K];

int main()
{
    int k, e, caseno = 0;
    while(~scanf("%d%d", &k, &e)) {
        for(int i = 0; i < k; i++)
            scanf("%s", key[i]);
        getchar();      // 吃掉最后的换行,为读入行做准备

        memset(sum, 0, sizeof(sum));
        int maxsum = 0;
        for(int i = 0; i < e; i++) {
            gets(excuse[i]);
            for(int j = 0; excuse[i][j]; j ++) {
                int cnt = 0;
                while(isalpha(excuse[i][j]))
                    t[cnt++] = tolower(excuse[i][j++]);
                t[cnt] = '\0';
                if(cnt) {
                    for(int l = 0; l < k; l++)
                        if(strcmp(t, key[l]) == 0) {
                            sum[i]++;
                            break;
                        }
                }
            }
            maxsum = max(maxsum, sum[i]);
        }
        printf("Excuse Set #%d\n", ++caseno);
        for(int i = 0; i < e; i++)
            if(sum[i] == maxsum)
                printf("%s\n", excuse[i]);
        printf("\n");
    }

    return 0;
}

原文地址:https://www.cnblogs.com/tigerisland45/p/10386727.html

时间: 2024-08-05 04:40:51

POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!【文本】的相关文章

【HDOJ】1606 Excuses, Excuses!

简单字符串. 1 #include <cstdio> 2 #include <cstring> 3 4 #define MAXLEN 105 5 #define MAXN 25 6 7 char keys[MAXN][MAXN]; 8 char lines[MAXN][MAXLEN]; 9 int nums[MAXN]; 10 11 int main() { 12 int case_n = 0; 13 int n, m, max; 14 int i, j, k, v; 15 cha

UVA之409 - Excuses, Excuses!

 Excuses, Excuses!  Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write

UVA (POJ 1598)Excuses, Excuses!

Excuses, Excuses! Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Description  Excuses, Excuses!  Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid ser

Excuses, Excuses! (map , string )

Excuses, Excuses! Problem Description Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has as

Excuses, Excuses! UVA 409

#include <stdio.h> #include <string.h> #include <ctype.h> int get_word(int); void convert_word(); int str_cmp(); char key[100][100];//保存关键词 char word[100];//保存从excuse中提取出来的词 char exc[100][100];//保存excuses int cnt[100];//记录每个excuse中keywor

UVA 409 Excuses, Excuses!

题目大意:给定几个keywords,再给几个excuses,要求从中找出keywords最多的excuse.如果有几个excuse一样多,就都输出来.其中要求出现的keyword是有条件的: If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword ``occurs" in an excuse if and only if it ex

Problem B: Excuses, Excuses!

Description Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a progr

UVA 409 Excuses, Excuses! (字符处理)

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will

ZOJ 1315【Excuses, Excuses!】------2015年2月9日

一:题目大意 输入数据m,n,其中m是代表关键字的个数(每个关键字是一个字符串(但无空格)),n表示接口的数目,每一个借口由可有空格的字符串组成.现在需要对所有的接口进行扫描,找出含有关键字最多的借口并输出(若有多个都输出且不需要注意顺序). 二:题目分析 本题算法难度并不大,但关键是处理字符串的技巧.详细解释见具体代码. 三:AC代码 #include<iostream> #include<string> #include<vector> #include<al