POJ-3468A Simple Problem with Integers,线段数区间更新查询,代码打了无数次还是会出错~~

A Simple Problem with Integers

Time Limit: 5000MS   Memory Limit: 131072K
              
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is
to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

这个题无非就是更新某个区间然后查询,思路甚至比其它的线段树要简单,但写起来却每次都出错;

思路很简单,如果每次更新都遍历到叶节点,毫无疑问会超时,既然是区间更新,我们可以先将要增加的值存在包含本区间的父亲区间里,下次往子节点操作时再进行类似的操作,也就是加上父亲节点储存的要增加的值,看代码+注释:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int  N=100000+10;
int n,m,s[N];
struct node
{
    int l,r;
    long long n,add;//注意数据范围;
} a[N<<2];
void build(int l,int r,int k)//构建就没啥好讲的;
{
    a[k].l=l,a[k].r=r,a[k].add=0;
    if(l==r)
    {
        a[k].n=s[l];
        return ;
    }
    int mid=(l+r)/2;
    build(l,mid,2*k);
    build(mid+1,r,2*k+1);
    a[k].n=a[k*2].n+a[k*2+1].n;
}
void update(int l,int r,int c,int k)
{
    if(l<=a[k].l&&a[k].r<=r)
    {
        a[k].n+=(a[k].r-a[k].l+1)*c;//满足条件的话,这个区间每个元素都要加上c;
        a[k].add+=c;将增加的值储存起来,下次更新操作时再往子节点更新;
        return ;
    }
    if(a[k].add)//如果父亲节点增加值还在,那么子节点也要进行更新操作;
    {
        a[k*2].add+=a[k].add;
        a[k*2+1].add+=a[k].add;
        a[k*2].n+=(a[k*2].r-a[k*2].l+1)*a[k].add;
        a[k*2+1].n+=(a[k*2+1].r-a[k*2+1].l+1)*a[k].add;
        a[k].add=0;
    }
    int mid=(a[k].l+a[k].r)/2;
    if(l<=mid) update(l,r,c,2*k);
    if(r>mid) update(l,r,c,2*k+1);
    a[k].n=a[k*2].n+a[k*2+1].n;回溯;
}
long long query(int l,int r,int k)
{
    if(a[k].l==l&&a[k].r==r)
        return a[k].n;
    if(a[k].add)
    {
        a[k*2].add+=a[k].add;
        a[k*2+1].add+=a[k].add;
        a[k*2].n+=(a[k*2].r-a[k*2].l+1)*a[k].add;
        a[k*2+1].n+=(a[k*2+1].r-a[k*2+1].l+1)*a[k].add;
        a[k].add=0;
    }
    int mid=(a[k].l+a[k].r)/2;
    if(l>mid) return query(l,r,2*k+1);
    if(r<=mid) return query(l,r,2*k);
    return query(l,mid,2*k)+query(mid+1,r,2*k+1);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(a,0,sizeof(a));
        for(int i=1; i<=n; i++)
            scanf("%d",&s[i]);
        build(1,n,1);
        while(m--)
        {
            int a,b,c;
            getchar();
            char o=getchar();
            if(o=='Q')
            {
                scanf("%d%d",&a,&b);
                printf("%I64d\n",query(a,b,1));
            }
            else
            {
                scanf("%d%d%d",&a,&b,&c);
                update(a,b,c,1);
            }
        }
    }
    return 0;
}

其实写出来发现也没什么改变,只不过关键在于更新和查询的时候往子节点所进行的操作;

时间: 2024-10-16 15:43:48

POJ-3468A Simple Problem with Integers,线段数区间更新查询,代码打了无数次还是会出错~~的相关文章

POJ 3468-A Simple Problem with Integers(线段树:成段更新,区间求和)

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 62228   Accepted: 19058 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of

POJ - 3468A Simple Problem with Integers (线段树区间更新,区间查询和)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval. Input The firs

POJ 3468 A Simple Problem with Integers(线段树区间更新)

题目地址:POJ 3468 打了个篮球回来果然神经有点冲动..无脑的狂交了8次WA..居然是更新的时候把r-l写成了l-r... 这题就是区间更新裸题.区间更新就是加一个lazy标记,延迟标记,只有向下查询的时候才将lazy标记向下更新.其他的均按线段树的来就行. 代码如下: #include <iostream> #include <cstdio> #include <cstring> #include <math.h> #include <stac

【POJ】3468 A Simple Problem with Integers ——线段树 成段更新 懒惰标记

A Simple Problem with Integers Time Limit:5000MS   Memory Limit:131072K Case Time Limit:2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each

POJ A Simple Problem with Integers 【线段树,区间更新】

题意:你有N个整数,A1,A2,-,一个.你需要处理两种类型的操作.一种类型的操作是添加了一些给定的数字,每个数字在一个给定的时间间隔.另一种是在给定的时间间隔要求数量的总和. 难点:主要是lazy标记,不好弄懂, 其实lazy标记就是当前改变的值不全部更新,等到用的时候再更新,这样就节省了好多时间. 题目链接:http://poj.org/problem?id=3468 代码: #include<stdio.h> #include<string.h> #define MAXN 1

HDU4267 A Simple Problem with Integers 线段树/树状数组

HDU4267 A Simple Problem with Integers  线段树/树状数组 2012长春网络赛A题 Problem Description Let A1, A2, ... , AN be N elements. You need to deal with two kinds of operations. One type of operation is to add a given number to a few numbers in a given interval. T

POJ3468_A Simple Problem with Integers(线段树/成段更新)

解题报告 题意: 略 思路: 线段树成段更新,区间求和. #include <iostream> #include <cstring> #include <cstdio> #define LL long long #define int_now int l,int r,int root using namespace std; LL sum[500000],lazy[500000]; void push_up(int root,int l,int r) { sum[ro

POJ3468__A Simple Problem with Integers (线段树)

本文出自blog.csdn.net/svitter --我大C++的指针岂是尔等能够简单领悟! 题意 给N个节点,标号A1~An,然后有Q个操作,操作分为Q i j,查询i,j间的区间和.C i j k,i到j个数字,每个数字增加k,并且输出. 输入输出分析 给N,Q,然后跟操作.注意判断Q,C使用scanf("%s"). 测试数据: Sample Input 10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4 Samp

poj 3468 A Simple Problem with Integers 线段树第一次 + 讲解

A Simple Problem with Integers Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of

POJ 3468 A Simple Problem with Integers (线段树区域更新)

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 62431   Accepted: 19141 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of