poj1442 Black Box【优先队列,定义两个队列】

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1

N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2
#include <cstdio>
#include <queue>
using namespace std;
int main()
{
    int a[30005],i,j,n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    	priority_queue <int , vector <int> , less<int> > p; //大的先
        priority_queue <int , vector <int> , greater<int> >q;//小的先
        int cut=0,x,c=0,t;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }

        for(i=0; i<m; i++)
        {
            scanf("%d",&x);
            while(c<x)
            {
                q.push(a[c]);
                c++;
            }
            while(!p.empty()&&p.top()>q.top())  //保证第几小的数在q队列或p队列的顶部,然后计较一下两个的大小
            {
                t=p.top();
                p.pop();
                p.push(q.top());
                q.pop();
                q.push(t);
            }
            printf("%d\n",q.top());
            p.push(q.top());
            q.pop();
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-05 13:15:53

poj1442 Black Box【优先队列,定义两个队列】的相关文章

UVA - 501 Black Box (优先队列或vector)

Description  Black Box  Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions).

poj1442 Black Box 栈和优先队列

题意:有n个数,按顺序加入,求加入前Gi个数时第i个最小的数是多少 思路:这里需要用到STL里的优先队列priority_queue,建一个大堆和一个小堆,若想在一个无序的序列里找第n个小的数,可以先把一个序列的n-1个数放入大堆(即假设这n-1个数是该序列里最小的),然后向小堆里push数,若小堆头元素<大堆头元素(即最小的元素比最大的元素大,说明大堆里的数还不是最小的),则交换两个数.难点:这里如果只用一个小堆的话会超时:另外每输入的一个m数,要查询的最小的数正好是第i++个,即这里每输出一

POJ 1442 Black Box(优先队列)

题目地址:POJ 1442 这题是用了两个优先队列,其中一个是较大优先,另一个是较小优先.让较大优先的队列保持k个.每次输出较大优先队列的队头. 每次取出一个数之后,都要先进行判断,如果这个数比较大优先的队列的队头要小,就让它加入这个队列,队列头移到较小优先的队列中.然后当较大优先的数不足k个的时候,就让较小优先的队列的队头移到较大优先的队头中. 代码如下: #include <iostream> #include <cstdio> #include <string>

使用两个队列实现一个栈

首先,我们得了解队列和栈的基本原理. 队列是一个"先进先出"的一个结构.队列的定义是在队尾插入,在队头删除,这就要求要用一种在尾部插入容易的,在头部删除容易的结构,你一定会想到单链表,对,库的实现就是用一个链表实现的. 栈,相信大家都不会陌生,函数栈帧等的实现,它是一种"先进后出"的结构.栈的插入删除都是在尾部进行的. 所以要用队列实现一个栈,要解决的问题就是在删除时要删除最后插入的那个元素.   我们先来模拟一下出栈和入栈的情况: (1)入栈:Q1:1,2,3,4

两个队列+k叉哈夫曼树 HDU 5884

1 // 两个队列+k叉哈夫曼树 HDU 5884 2 // camp题解: 3 // 题意:nn个有序序列的归并排序.每次可以选择不超过kk个序列进行合并,合并代价为这些序列的长度和.总的合并代价不能超过TT, 问kk最小是多少. 4 // . 5 // 题解:首先二分一下这个kk.然后在给定kk的情况下,这个代价其实就是kk叉的哈夫曼树问题.因此直接套用哈夫曼树的堆做法即可.复杂度O(nlog^2n) 6 // ?,这样优化一下读入是可以卡过去的. 7 // 然后主代码手表示,利用合并的单调

C++算法之 两个队列实现一个栈

题目:用两个队列实现一个栈 算法思路: 现有两个队列q1与q2,入栈:如果q1与q2都为空,那么我们选择q1入栈也就是入队列,比如q1入栈 1 2 3 4 :现在要出栈,后进先出那么4要出栈.但是q1是一个 队列,先进先出,那么 1 2 3出队列 q2 1 2 3 入队列,q1中此时剩余4,把4出对列达到出栈的效果.  这个时候如果我们又加入一个元素5,那么我们应该把5放到 q1还是q2,因为现在q2中有 1 2 3,把5放到q1不方便统计,所以要把5放入到q2:如果5放到了q1,等下编写出栈的

编程题目: 两个队列实现栈(Python)

感觉两个队列实现栈 比 两个栈实现队列 麻烦 1.栈为空:当两个队列都为空的时候,栈为空 2.入栈操作:当队列2为空的时候,将元素入队到队列1:当队列1位空的时候,将元素入队到队列2: 如果队列1 和 队列2 都为空的时候,那就选择入队到队列1. 3.出队操作:当两个队列都为空的时候,引发错误"栈为空": 当队列2位空的时候,如果队列1中只有一个元素,则直接将队列1中的元素出队: 如果队列1不止一个元素的时候,就将队列1的元素出队然后入队到队列2,知道队列1中只有一个元素,然后将队列1

用两个队列模拟实现一个栈的过程

栈具有"后进先出"的特点,即某个元素最后进入栈,却最先出栈:队列具有"先进先出"的特点,即元素从队尾依次进队列,依次从队头出队列:现在用两个队列模拟实现一个栈的过程,详细过程请看下面这张本人制作的gif图: 实现代码: #include <iostream> using namespace std; #include <queue> template <typename T> class Stack { public: void

用两个队列实现一个栈

前面说了用两个栈实现一个队列的算法,现在在写一个反过来的算法: 1.算法描述: 栈的特点就是先进后出,而队列的特点就是先进先出,基于两者的特点,有了此算法: 先看一张图:都喜欢图,图也能直接表达题的意思和本人的意思: 图中已经说的很清楚了,多余的方法暂且不说,按以上的图和思路,我给出以下代码:供自己参考: /* *设有两个队列A和B,栈的push操作,直接push到A的队尾就行了. *栈的pop操作时,将A中的队列依次取出放到B中,取到最后一个时, *最后一个不要放到B中,直接删掉,再将B中的值