Stockbroker Grapevine (poj 1125 floyd + 枚举)


Language:
Default

Stockbroker Grapevine

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27445   Accepted: 15211

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours
in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are,
and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring
to the contact (e.g. a ‘1‘ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001

题意:在一个有向图中选一个起点,能从这个起点到达所有其他点,还要保证起点到其他点距离中的最大值最小。

思路:先用floyd求出所有两点之间的距离,然后枚举起点,看以这个为起点能不能到达所有点且最大值最小。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 111
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int mp[MAXN][MAXN];
int n;

void floyd()  //folyd求出所有点之间的最短路
{
    int i,j,k;
    for (k=1;k<=n;k++)
        for (i=1;i<=n;i++)
            for (j=1;j<=n;j++)
            {
                if (i==k||j==k)
                    continue;
                mp[i][j]=min(mp[i][j],mp[i][k]+mp[k][j]);
            }
}

int main()
{
    int i,j,m,t,e;
    while (scanf("%d",&n)&&n)
    {
        memset(mp,INF,sizeof(mp));
        for (i=1;i<=n;i++)
        {
            scanf("%d",&m);
            if (m>0)
            {
                for (j=1;j<=m;j++)
                {
                    scanf("%d%d",&e,&t);
                    mp[i][e]=t;
                }
            }
        }
        floyd();
        int mi=INF;
        int p;
        int flag=0;
        for (i=1;i<=n;i++)//枚举1~n作为起点
        {
            int ma=-INF;
            for (j=1;j<=n;j++)//判断以i作为起点能不能从i走到其他所有点
                if (i!=j)
                {
                    if (mp[i][j]==INF)
                        break;
                    ma=max(ma,mp[i][j]);//找出以i为起点的情况下最远的点,记录下长度
                }
            if (j==n+1)
                flag=1;
            else
                continue;
            if (mi>ma)//选出最小的最长时间
            {
                mi=ma;
                p=i;
            }
        }
        if (flag)
            printf("%d %d\n",p,mi);
        else
            printf("disjoint\n");
    }
    return 0;
}

/*
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
*/
时间: 2024-08-28 12:09:15

Stockbroker Grapevine (poj 1125 floyd + 枚举)的相关文章

Stockbroker Grapevine POJ 1125 Floyd

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 37069   Accepted: 20612 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

Stockbroker Grapevine - poj 1125 (Floyd算法)

Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 30454   Accepted: 16659 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give

POJ - 1125 Stockbroker Grapevine (动态规划理解floyd)

题目大意:有一个,想要在最短的时间內将一个谣言散发给所有人,但是他只能将这个谣言告诉给一个人,然后通过这个人传播出去.问,他应该告诉哪个人,让所有人都听到这个谣言的最短时间是多少 解题思路:这题很容易想到用floyd求出每个点之间的最短路. 做这题时,已经很久没做最短路的了,所以一时写不出floyd.发现自己太依赖模版了,所以在这里想写一下自己对floyd的理解(借鉴了这里写链接内容)好让自己下次不看模版也能想出来 设dp[i][j]为i到j的最短路,因为floyd有三成for,写起来的时候也知

poj 1161 Floyd+枚举

题意是: 给出n个点,围成m个区域.从区域到另一个区域间需穿过至少一条边(若两区域相邻)——边连接着两点. 给出这么一幅图,并给出一些点,问从这些点到同一个区域的穿过边数最小值. 解题思路如下: 将区域按1~m编号,d[i][j]表示第 i 个区域到第 j 个区域的最短距离,跑一遍Floye算法O(m^3)后,枚举选择的区域,找出其中穿过边数最小值即可. 建图:题目对于每个区域的描述方式为以顺时针方向给出围成区域的点.由此可知区域由哪些边组成.易知,每条边能且只能令两个区域相邻,则用二维数组记录

POJ 1125 Floyd

题意: 有n个传递消息者,每个都有nn个亲信,他们可以把消息传递给他们的亲信,所 花时间为b. 问把最初的消息传递给谁可以在最短的时间内把消息传递给所有人. 思路: Floyd算出任意两点之间的最短路,然后取每行最大值最小的矩阵作为首先传递出消息的人,将最大值作为把消息传递给所有人最短的时间. #include<stdio.h> #include<string.h> const int inf=99999999; int pho[105][105]; int main() { in

poj1178 floyd+枚举

http://poj.org/problem?id=1178 Description Centuries ago, King Arthur and the Knights of the Round Table used to meet every year on New Year's Day to celebrate their fellowship. In remembrance of these events, we consider a board game for one player,

POJ 1125 Stockbroker Grapevine (Floyd算法)

Floyd算法计算每对顶点之间的最短路径的问题 题目中隐含了一个条件是一个人可以同时将谣言传递给多个人 题目最终的要求是时间最短,那么就要遍历一遍求出每个点作为源点时,最长的最短路径长是多少,再求这些值当中最小的是多少,就是题目所求 #include<bits/stdc++.h> using namespace std; int n,x,p,t; int m[120][120],dist[120][120],Max[120]; void floyd(int n,int m[][120],int

poj 1125 Stockbroker Grapevine -- floyd 全源最短路

Stockbroker Grapevine Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 33164   Accepted: 18259 Description Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst th

【POJ 1125】Stockbroker Grapevine

[POJ 1125]Stockbroker Grapevine 最短路 不过这题数据很水..主要想大牛们试试南阳OJ同题 链接如下: http://acm.nyist.net/JudgeOnline/talking.php?pid=426&page=2 数据增大很多 用到很多东西才能过 (弱没过,,, 这题就是求最短路寻找所有通路中最大权的最小值外加考验英语水平-- Floyd 208K 0MS 1162B #include using namespace std; int dis[111][1