hdu1242 Rescue(BFS)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21701    Accepted Submission(s): 7745

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel‘s friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there‘s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel‘s friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

Author

CHEN, Xue

Source

ZOJ Monthly, October 2003

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1240 1010 1072 1253 1372

Statistic | Submit | Discuss | Note

也可以用DFS做 在这里用的BFS

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
struct node
{
	int cost,x,y;
	friend bool operator<(node a,node b)
	{
		return a.cost>b.cost;
	}
};
int dir[4][2]={0,1,0,-1,1,0,-1,0};
char map[205][205];
int vis[205][205],n,m;
bool limit(int x,int y)
{
	if(map[x][y]!='#'&&x>=0&&x<n&&y>=0&&y<m)
	return true;
	else
	return false;
}
int tonum(int x,int y)
{
	if(map[x][y]=='x')
	return 2;
	else
	return 1;
}
void bfs(int x,int y)
{
	priority_queue<node>s;
	node temp,temp1;
	int flag=0;
	temp.x=x,temp.y=y,temp.cost=0;
	s.push(temp);
	while(!s.empty())
	{
		temp1=temp=s.top();
		s.pop();
		if(map[temp.x][temp.y]=='a')
		{
			flag=1;
			break;
		}
		for(int i=0;i<4;i++)
		{
			temp.x=temp.x+dir[i][0];
			temp.y=temp.y+dir[i][1];
			if(!vis[temp.x][temp.y]&&limit(temp.x,temp.y))
			{
				vis[temp.x][temp.y]=1;
				temp.cost+=tonum(temp.x,temp.y);
				s.push(temp);
			}
			temp=temp1;
		}
	}
	if(flag)
	printf("%d\n",temp.cost);
	else
	printf("Poor ANGEL has to stay in the prison all his life.\n");
	while(!s.empty())
	s.pop();
}
int main()
{
	int st_x,st_y;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		for(int i=0;i<n;i++)
		scanf("%s",map[i]);
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		{
			if(map[i][j]=='r')
			{
				st_x=i,st_y=j;
				break;
			}
		}
		memset(vis,0,sizeof(vis));
		vis[st_x][st_y]=1;
		bfs(st_x,st_y);
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-15 08:57:54

hdu1242 Rescue(BFS)的相关文章

HDU1242 Rescue 【BFS】

Rescue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16314    Accepted Submission(s): 5926 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is

[ACM] hdu 1242 Rescue (BFS+优先队列)

Rescue Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want to save Angel. Their task is:

zoj 1649 Rescue (bfs+队列)

Rescue Time Limit: 2 Seconds      Memory Limit: 65536 KB Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want

HDU1242 (BFS搜索中使用优先队列)

一道用到优先队列的BFS题目 #include <iostream> #include <string> #include <cstdio> #include <cstring> #include <queue> #define N 201 using namespace std; char maze[N][N]; int a,b,anw; bool visit[N][N]; int dir[4][2]={{0,1},{1,0},{-1,0},{

hdu1242 优先队列+bfs

Rescue Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 22034    Accepted Submission(s): 7843 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is d

hdoj 1242 Rescue (BFS)

Rescue http://acm.hdu.edu.cn/showproblem.php?pid=1242 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 18962    Accepted Submission(s): 6771 Problem Description Angel was caught by the MOLIGPY!

poj1649 Rescue(BFS+优先队列)

Rescue Time Limit: 2 Seconds      Memory Limit: 65536 KB Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want

HDU1242 Rescue

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1242 参考博文1:http://blog.csdn.net/iaccepted/article/details/23101875 参考博文2:http://blog.csdn.net/libin56842/article/details/9039351 该题类似于走迷宫,但不完全是,因为在走的过程中会遇到警察,可以选择杀死警察,但要付出相应的代价,时间加1.用走迷宫的算法只是能找到angle到队友最

HDU 1242 Rescue(BFS)

题目链接 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. Angel's friends want to save Angel. Their task is: a