HDU1162 Eddy's picture【Prim】

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7231    Accepted Submission(s): 3656

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends
are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3

1.0 1.0

2.0 2.0

2.0 4.0

Sample Output

3.41

题目大意:给你N个点的坐标,求能使这N个点相连的所有边的最小距离是多少。

思路:先求出每个点和其他点的距离,存到图中,用Prim模板来做。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

struct Node
{
    double x;
    double y;
}A[110];

double G[110][110],low[110];
int vis[110];

void Prim(int N)
{
    memset(vis,0,sizeof(vis));
    int pos = 1;
    vis[pos] = 1;
    double ans = 0;
    for(int i = 1; i <= N; i++)
        if(i != pos)
            low[i] = G[pos][i];

    for(int i = 1; i < N; i++)
    {
        double Min = 0x7ffffff;
        for(int j = 1; j <= N; j++)
        {
            if(!vis[j] && Min > low[j])
            {
                Min = low[j];
                pos = j;
            }
        }
        vis[pos] = 1;
        ans += Min;
        for(int j = 1; j <= N; j++)
        {
            if(!vis[j] && low[j] > G[pos][j])
                low[j] = G[pos][j];
        }
    }
    printf("%.2lf\n",ans);
}

int main()
{
    int N;
    double Dist,x,y;
    while(cin >> N)
    {
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= N; j++)
                G[i][j] = 0x7fffff;
        }
        memset(A,0,sizeof(A));
        for(int i = 1; i <= N; i++)
        {
            cin >> A[i].x >> A[i].y;
        }
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= N; j++)
            {
                x = A[i].x - A[j].x;
                y = A[i].y - A[j].y;
                Dist = sqrt(x*x+y*y);
                G[i][j] = Dist;
            }
        }
        Prim(N);
    }

    return 0;
}

HDU1162 Eddy's picture【Prim】

时间: 2024-10-29 04:28:47

HDU1162 Eddy's picture【Prim】的相关文章

HDU1162 Eddy&#39;s picture 【最小生成树Prim】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6723    Accepted Submission(s): 3391 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

hdoj 1162 Eddy&#39;s picture【最小生成树】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8117    Accepted Submission(s): 4114 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

HDU 1162 Eddy&#39;s picture【最小生成树,Prime算法+Kruskal算法】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9334    Accepted Submission(s): 4711 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

HDOJ 1233 还是畅通工程 【最小生成树】+【prim】

题意:... 策略:最最典型的prim算法. 代码: #include<stdio.h> #include<string.h> #define INF 0x3f3f3f3f #define MAXN 105 int map[MAXN][MAXN], di[MAXN], vis[MAXN]; int n; int prim() { int i, j, min, pos; memset(vis, 0, sizeof(vis)); memset(di, 0, sizeof(di)); p

hdu1162 Eddy&#39;s picture 基础最小生成树

1 #include <cstdio> 2 #include <cmath> 3 #include <cstring> 4 #include <algorithm> 5 #include <string> 6 using namespace std; 7 8 int n, m; 9 int f[510]; 10 11 struct node 12 { 13 int u, v; 14 double w; 15 }map[10010]; 16 17

HDU1233 还是畅通工程【Prim】

还是畅通工程 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 27373    Accepted Submission(s): 12183 Problem Description 某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离.省政府"畅通工程"的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路

POJ2485 Highways【Prim】

Highways Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 23247 Accepted: 10720 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatop

HDU1301 Jungle Roads【Prim】【最小生成树】

Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4591    Accepted Submission(s): 3371 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst o

HDU1301 Jungle Roads【Prim】

Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4554    Accepted Submission(s): 3341 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst o