Tick and Tick

The three hands of the clock are rotating every
second and meeting each other many times everyday. Finally, they get bored of
this and each of them would like to stay away from the other two. A hand is
happy if it is at least D degrees from any of the rest. You are to calculate how
much time in a day that all the hands are happy.

Input

The input contains many test cases. Each of them has
a single line with a real number D between 0 and 120, inclusively. The input is
terminated with a D of -1.

Output

For each D, print in a single line the percentage of
time in a day that all of the hands are happy, accurate up to 3 decimal
places.

Sample Input

0

120

90

-1

Sample Output

100.000

0.000

6.251

#include"iostream"
using namespace std;
inline double max(double a,double b,double c)
{
a=a>b?a:b;
a=a>c?a:c;
return a;
}
inline double min(double a,double b,double c)
{
a=a<b?a:b;
a=a<c?a:c;
return a;
}
int main()
{
double an;
double tsm[1445],tsh[1445],tmh[26];
double s,m,h;
s=3600.00/59;//周期结束点
m=43200.00/719;
h=43200.00/11;
while(cin>>an&&an!=-1)
{
tsm[0]=(10*an)/59;
tsh[0]=(120*an)/719;
tmh[0]=(120*an)/11;
tsm[1]=s-tsm[0];
tsh[1]=m-tsh[0];
tmh[1]=h-tmh[0];
double sum=0;
double x=0,y=0;
int i,j;
for(i=2,j=3;;i+=2,j+=2)
{
tsm[i]=tsm[i-2]+s;
tsm[j]=tsm[j-2]+s;
if(tsm[i]>43200&&tsm[j]>43200)
break;
}
for(i=2,j=3;;i+=2,j+=2)
{
tsh[i]=tsh[i-2]+m;
tsh[j]=tsh[j-2]+m;
if(tsh[i]>43200&&tsh[j]>43200)
break;
}
for(i=2,j=3;;i+=2,j+=2)
{
tmh[i]=tmh[i-2]+h;
tmh[j]=tmh[j-2]+h;
if(tmh[i-2]>43200&&tmh[j]>43200)
break;
}
int a[2],b[2],c[2];
a[0]=b[0]=c[0]=0;
a[1]=b[1]=c[1]=1;
while(x<=43200&&y<=43200)
{
x=max(tsm[a[0]],tsh[b[0]],tmh[c[0]]);
y=min(tsm[a[1]],tsh[b[1]],tmh[c[1]]);
if(x<y)
sum+=(y-x);
if(y==tsm[a[1]])
{
a[0]+=2;
a[1]+=2;
}
if(y==tsh[b[1]])
{
b[0]+=2;
b[1]+=2;
}
if(y==tmh[c[1]])
{
c[0]+=2;
c[1]+=2;
}
}
cout.precision(3);
cout<<fixed<<sum/432<<endl;
}
return 0;
}

Tick and Tick

时间: 2024-11-08 15:41:47

Tick and Tick的相关文章

hdu 1006 Tick and Tick 有技巧的暴力

Tick and Tick Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16707    Accepted Submission(s): 4083 Problem Description The three hands of the clock are rotating every second and meeting each ot

HDU1006 Tick and Tick【计算几何】

Tick and Tick Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10770    Accepted Submission(s): 3008 Problem Description The three hands of the clock are rotating every second and meeting each o

HDU 1006 Tick and Tick 解不等式解法

一开始思考的时候觉得好难的题目,因为感觉很多情况,不知道从何入手. 想通了就不难了. 可以转化为一个利用速度建立不等式,然后解不等式的问题. 建立速度,路程,时间的模型如下: /*************************************************************************** * * * 秒钟的速度s=6°/s,分针是1/10°/s,时针是1/120°/s * * 所以相对速度s_m=59/10°/s,s_h=719/120°/s,m_h=12

hdu 1006 Tick and Tick

Tick and Tick Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 19764    Accepted Submission(s): 5164 Problem Description The three hands of the clock are rotating every second and meeting each ot

HDU 1006 Tick and Tick 时钟指针问题

Tick and Tick Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10194    Accepted Submission(s): 2859 Problem Description The three hands of the clock are rotating every second and meeting each ot

HDU 1006 Tick and Tick(时钟,分钟,秒钟角度问题)

传送门: http://acm.hdu.edu.cn/showproblem.php?pid=1006 Tick and Tick Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 22203    Accepted Submission(s): 5877 Problem Description The three hands of the

1006 Tick and Tick

1006题: Problem Description The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at lea

HDU ACM 1006 Tick and Tick

题意:一个钟的三个指针在不停的转动,他们厌烦了这样,当他们互相的距离角度大于等于D时,他们会很开心,问一天之中他们happy的时间占总时间的百分比. 分析:只要找到某一分钟内,他们happy的时间,然后钟每过12个小时相当于43200秒复原一次.因此总时间就是43200秒,只要求出在这43200的happy时间,即可求出百分比.枚举12*60分钟,看一分钟内有多少秒是happy的时间,一分钟内解三个不等式可得到区间. 步骤: 1.列出指针(h:m:s)与度数(rh:rm:rs)之间的关系: 秒针

HDU1006 Tick and Tick

题目链接:https://vjudge.net/problem/HDU-1006 题目大意: 给定一个\(D\),问时钟上时针.分针.秒针之间的角度差都大于或等于\(D\)的概率是多少. 知识点: 暴力 解题思路: 枚举时与分,对于每一分钟,设秒数为\(s\),由时.分.秒可以推出各针当前的角度.任意两针之间的角度差大于等于\(D\)小于等于\((360-D)\),由这条关系可以推出三条不等式,求出关于\(s\)的三个区间,\(s\)在这一分钟的合法区间即为这三个区间的交集. AC代码: 1 #