POJ3080

Blue Jeans

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12295   Accepted: 5337

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities"
instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

仔细就好,了解了strstr函数。。。

/*
** 作者** 功能:查找最长公共字串
** poj3080
*/
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        int i,j,k;
        char str[12][65],ans[65],sub[65];
        for(i=0;i<n;i++)
            cin>>str[i];

        ans[0]='\0';
        for(i=3;i<=60;i++)//枚举字串长度
        {
            bool fd=false;//是否有公共字串判断
            for(j=0;j<=60-i;j++)//枚举字串起点
            {
                int len=0;//字串长度复制记录

                for(k=j;len<i;k++)
                {
                    sub[len++]=str[0][k];
                }
                sub[len]='\0';//取出字串gai
                bool ffdd=false;//该字串是否满足
                //接下来对比其他串
                for(k=1;k<n;k++)
                {
                    if(!strstr(str[k],sub))
                      {
                          ffdd=true;
                          break;
                      }
                }
                //如果该字串满足,则与ans比较并赋值
                if(!ffdd)
                {
                    if(strlen(ans)<strlen(sub))
                    {
                        strcpy(ans,sub);
                    }else if(strlen(ans)==strlen(sub)&&strcmp(sub,ans)<0)
                    {
                        strcpy(ans,sub);
                    }
                    fd=true;
                }
            }
            if(!fd)
                break;
        }
        if(strlen(ans)!=0)
        {
            cout<<ans<<endl;
        }else{
            cout<<"no significant commonalities"<<endl;
        }
    }
    return 0;
}
时间: 2024-10-24 09:05:56

POJ3080的相关文章

poj3080(Blue Jeans)kmp求多个串公共子串

题意:给出1-10个长度为60的字符串,求出最长的公共子串(长度不能小于3),如果有多个一样长的,输出字典序最短的. 解法:想到kmp时,自己第一反应枚举第一个串的所有子串,在其他所有串中走一遍kmp,复杂度为10*60*60*60,但是发现只需枚举第一个串后缀就可以,每次枚举记录在所有串能走最远中走的最短的那个长度.这样复杂度就成了10*60*60,0ms AC. 代码: /**************************************************** * autho

poj3080解题报告(暴力、最大公共子串)

POJ 3080,题目链接http://poj.org/problem?id=3080 题意: 就是求m个长度为60的字符串的最长连续公共子串,2<=m<=10 规定: 1.最长公共串长度小于3输出no significant commonalities 2.若出现多个等长的最长的子串,则输出字典序最小的串 思路: 1. 求公共最小连续子串,那么先把第一个串长度>=3的所有连续子串找出来,然后由短到长查看所有主串是否有该子串. 2. 如果发现一个公共子串,那么就开始找长度+1的公共子串:

POJ3080——Blue Jeans(暴力+字符串匹配)

Blue Jeans DescriptionThe Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. As an IBM researcher, you hav

POJ3080题解——暴力orKMP

题目链接:http://poj.org/problem?id=3080 The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. As an IBM resea

POJ3080 &amp;&amp; POJ 3450

题意: 给定m个串,让你找出它们的最长公共子串 思路: 先二分串的长度,枚举该长度的串(可以从第一个串里找),看该长度是否合法,(就是用这个长度的所有串去匹配给定的 第 2 - m 个串 为提高效率,用kmp)然后得到一个最大长度,再在该长度下寻找一个字典序最小的解即可 POJ3450代码(3080类似) /************************************************************************* > File Name: poj3450.

poj3080(kmp)

欢迎参加hihoCoder挑战赛14和15,赢取100件Tshirt! Language: Default Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14450   Accepted: 6437 Description The Genographic Project is a research partnership between IBM and The National Geographic

POJ3080 Blue Jeans

Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 16142   Accepted: 7189 Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousa

POJ3080 Blue Jeans 【KMP 暴力水过】

题目描述 求n个字符串的最长公共序列,若长度相同,输出字典序最小的.若长度小于3,输出no significant commonalities Sample Input 3 2 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA 3 GATACCAGATACCAGATACCAGATACCAGATACCAGA

poj3080 Blue Jeans(暴枚+kmp)

Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.  As an IBM researcher, you have been ta