HDOJ 4259 Double Dealing(置换群)

Double Dealing

Time Limit: 50000/20000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1893    Accepted Submission(s): 672

Problem Description

Take a deck of n unique cards. Deal the entire deck out to k players in the usual way: the top card to player 1, the next to player 2, the kth to player k, the k+1st to
player 1, and so on. Then pick up the cards – place player 1′s cards on top, then player 2, and so on, so that player k’s cards are on the bottom. Each player’s cards are in reverse order – the last card that they were dealt is on the top,
and the first on the bottom.

How many times, including the first, must this process be repeated before the deck is back in its original order?

Input

There will be multiple test cases in the input. Each case will consist of a single line with two integers, n and k (1≤n≤800, 1≤k≤800). The input will end with a line with two 0s.

Output

For each test case in the input, print a single integer, indicating the number of deals required to return the deck to its original order. Output each integer on its own line, with no extra spaces, and no blank lines between answers. All possible inputs yield
answers which will fit in a signed 64-bit integer.

Sample Input

1 3
10 3
52 4
0 0

Sample Output

1
4
13

Source

The University of Chicago Invitational
Programming Contest 2012

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  4257 4258 4260 4261 4262

1. n张牌 (1,2,···,n) 按顺序发给k个人,再把牌收回,第1个人的放最上面,后面的依次放下面。继续发牌,收牌,问多少次后恢复原样。

2. 以 n=10,k=3 为例,4次后牌的次序恢复原样,如下:

第一次: 10  7  4   1   8   5   2   9   6   3

第二次: 3   2  1   10  9   8   7   6   5   4

第三次: 4   7  10  3   6   9   2   5   8   1

第四次: 1   2  3    4   5   6   7   8   9   10

3. 经过 1 次操作(发牌+收牌)后,下标变化情况如下:

原次序:1  2  3    4  5  6  7  8  9  10

操作后:4  7  10  3  6  9  2  5  8  1

4. 显然,该操作为一个置换,且为:

5. n 元数码上的任意置换 σ 都可唯一地表示成不相交的循环置换的乘积。

6. lcm(x,y)=xy/gcd(x,y).

7. lcm(x1,x2,···,xn)=lcm(lcm(x1,x2,···,xn-1),xn).

8. 本题所求即为各循环置换的循环节的最小公倍数。以 n=10,k=3 为例,所求为 lcm(4,2,4)=4.

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
__int64 gcd(__int64 a,__int64 b)
{
	int t;
	if(a<b)
	{
		t=a;
		a=b;
		b=t;
	}
	if(b==0)
		return a;
	return gcd(b,a%b);
}
__int64 lcm(__int64 a,__int64 b)
{
	return a/gcd(a,b)*b;
}
int vis[100100],next[100100];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF,n||m)
	{
		int i,j,k=n;
		if(n<=m)
		{
			printf("1\n");
			continue;
		}
		for(i=m;i>=1;i--)
		{
			for(j=i;j<=n;j+=m)
			{
				next[k--]=j;
			}
		}
		__int64 ans=1;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
		{
			if(vis[i])
				continue;
			__int64 temp=next[i],res=1;
			while(temp!=i)
			{
				vis[temp]=1;
				temp=next[temp];
				res++;
			}
			ans=lcm(ans,res);
		}
		printf("%I64d\n",ans);
	}
}
时间: 2024-10-04 17:11:13

HDOJ 4259 Double Dealing(置换群)的相关文章

HDOJ 4259 Double Dealing

找每一位的循环节,求lcm Double Dealing Time Limit: 50000/20000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1806    Accepted Submission(s): 622 Problem Description Take a deck of n unique cards. Deal the entire deck out to

HDU 4259 Double Dealing(置换群啊)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4259 Problem Description Take a deck of n unique cards. Deal the entire deck out to k players in the usual way: the top card to player 1, the next to player 2, the kth to player k, the k+1st to player 1,

HDU 4259 Double Dealing【简单群置换】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4259 题目大意:给出n张卡片以及k个人,现在对卡片进行分堆,然后分发(这样卡片改变了顺序),依次这样问多少次后卡片顺序回到原来一样. 比如给出的10,3. 第一次分堆是这样的 第一人:1,4,7,10 第二人:2,5,8 第三人:3,6,9 其顺序由1 2 3 4 5 6 7 8 9 10 变成了 10 7 4 1 8 5 2 9 6 3 即: 10 3 第一次 10 7 4 1 8 5 2 9 6

hdu 4529 Double Dealing (置换群)

# include <stdio.h> # include <algorithm> # include <string.h> using namespace std; __int64 gcd(__int64 a,__int64 b) { if(b==0) return a; return gcd(b,a%b); } int main() { int n,k,i,j,vis[810],m,num[810],x; __int64 res,cot; while(~scanf(

HDU 4259(Double Dealing-lcm(x1..xn)=lcm(x1,lcm(x2..xn))

Double Dealing Time Limit: 50000/20000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1924    Accepted Submission(s): 679 Problem Description Take a deck of n unique cards. Deal the entire deck out to k players in

JVMS Specification(3)-The class File Format

Subsections 3 The class File Format 3.1 The ClassFile Structure 3.2 The Internal Form of Names 3.2.1 Binary Class and Interface Names 3.2.2 Unqualified Names 3.3 Descriptors and Signatures 3.3.1 Grammar Notation 3.3.2 Field Descriptors 3.3.3 Method D

POJ1721_CARDS【置换群】

CARDS Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 1452 Accepted: 776 Description Alice and Bob have a set of N cards labelled with numbers 1 ... N (so that no two cards have the same label) and a shuffle machine. We assume that N is an

HDOJ 1217 Floyed Template

1 #include <iostream> 2 #include <stdio.h> 3 #include <string.h> 4 #include <cstring> 5 #include<map> 6 using namespace std; 7 8 map<string,int>name; 9 const int INF = 1000000; 10 const int MAXSIZE = 1005; 11 const int

hdu5338(2015多校4)--ZZX and Permutations(置换群)

题目链接:点击打开链接 题目大意:给出一个序列,分成若干个置换群,要求最终的序列的字典序最大. 要求字典序最大,那么从1开始向后遍历,尽量放较大的数 给出序列a1 a2 a3 ,,, ai   an 对于第i个数来说,可能有三种情况,第一种向前找能到达的序列的最大值ak,那么ak到ai就是一个轮换:第二种ai自身,或者是以ai结尾:第三种由i想后找,对于轮换来说,只能在i位置放ai+1,那么ai和ai+1只能构成轮换的一部分:在这三种可以放的值中选出最大值,也就是第i个位置能放的数 注意 1.当