POJ-2689-Prime Distance(筛法)


Language:
Default

Prime Distance

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15777   Accepted: 4194

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors
(it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there
are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.

Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair.
You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

题意:求给定区间内的质数距离最小的一对和质数距离最大的一对。

由于区间过大,不可能直接求出1e9之间的所有质数,但是我们知道 2,147,483,647之间的质数可以用sqrt(2,147,483,647)内的质数筛出来,所以可以先求出sqrt(2,147,483,647)
约5W内的质数, 因为给定区间长度少于1e6,所以直接用5w内质数筛出来区间内质数就可以。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <set>
#include <vector>
#define INF 0x3f3f3f3f
#define LL long long
#define bug cout<<"bug\n"
using namespace std;
#define MAXN 50005
const int M = 1e6+7;
int num_prime;
bool not_prime[MAXN*30];
int prime[MAXN];
long long a,b;
long long prime_2[M];
void get_prime()
{
    long long i,j;
    memset(not_prime,0,sizeof(not_prime));
    num_prime=0;
    not_prime[1]=1;
    for(i=2; i<MAXN; ++i)
        if(!not_prime[i])
        {
            num_prime++;
            prime[num_prime]=i;
            for(j=i*i; j<MAXN; j+=i)
                not_prime[j]=1;
        }
}
void get_primein_ab()
{
    long long i,j,p;
    memset(not_prime,0,sizeof(not_prime));
    for(i=1; i<=num_prime; ++i)
    {
        p=a/prime[i];
        while(p<=1)
            p++;
        for(j=prime[i]*p; j<=b; j+=prime[i])
            if(j>=a)
                not_prime[j-a]=1;
    }
    if(a==1)
        not_prime[0]=1;
}
int main()
{
    get_prime();
    while(scanf("%I64d%I64d",&a,&b)!=EOF)
    {
        long long min=INF,max=-INF;
        long long minl,minr,maxl,maxr;
        get_primein_ab();
        int num_prime2=0;
        for(int i=0; i<=b-a; ++i)
            if(!not_prime[i])
                prime_2[++num_prime2]=i+a;
        if(num_prime2<=1)
            printf("There are no adjacent primes.\n");
        else
        {
            for(int i=1; i<num_prime2; ++i)
            {
                if(prime_2[i+1]-prime_2[i]>max)
                {
                    max=prime_2[i+1]-prime_2[i];
                    maxl=prime_2[i];
                    maxr=prime_2[i+1];
                }
                if(prime_2[i+1]-prime_2[i]<min)
                {
                    min=prime_2[i+1]-prime_2[i];
                    minl=prime_2[i];
                    minr=prime_2[i+1];
                }
            }
            printf("%I64d,%I64d are closest, %I64d,%I64d are most distant.\n",minl,minr,maxl,maxr);
        }
    }
    return 0;
}
时间: 2024-10-13 18:41:05

POJ-2689-Prime Distance(筛法)的相关文章

POJ 2689 - Prime Distance - [筛法求素数]

题目链接:http://poj.org/problem?id=2689 Time Limit: 1000MS Memory Limit: 65536K Description The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousan

poj 2689 Prime Distance 【数论】【筛法求素数】

题目链接:传送门 题目大意: 给你L和R两组数,L和R的范围是2^32,其间隔(即R-L最大为1,000,000.) .让你求出L和R之间素数的最大间隔和最小的间隔. 比如 2 17.之间的最小素数间隔是2 3,最大的素数间隔是11 17. 要是直接进行一个2^32次方筛法然后在判断是会T的. 我们这样来想,筛法求素数的原理是什么: /**vis数组标记为0则说明是素数*/ int vis[10005]; void getPrimevis(int n) { int m=sqrt(n+0.5);

POJ 2689 Prime Distance 素数筛选法应用

题目来源:POJ 2689 Prime Distance 题意:给出一个区间L R 区间内的距离最远和最近的2个素数 并且是相邻的 R-L <= 1000000 但是L和R会很大 思路:一般素数筛选法是拿一个素数 然后它的2倍3倍4倍...都不是 然后这题可以直接从2的L/2倍开始它的L/2+1倍L/2+2倍...都不是素数 首先筛选出一些素数 然后在以这些素数为基础 在L-R上在筛一次因为 R-L <= 1000000 可以左移开一个1百万的数组 #include <cstdio>

数论 - 素数的运用 --- poj 2689 : Prime Distance

Prime Distance Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 12512   Accepted: 3340 Description The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number th

[ACM] POJ 2689 Prime Distance (筛选范围大素数)

Prime Distance Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 12811   Accepted: 3420 Description The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number th

POJ 2689 Prime Distance

Prime Distance Description The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a

[ACM] POJ 2689 Prime Distance (大区间素数筛选)

Prime Distance Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 12811   Accepted: 3420 Description The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number th

POJ 2689 Prime Distance(素数区间筛法--经典题)

大致题意:给定[L,R]区间,找出区间内的每个素数 数据范围 : 1<=L< R<=2,147,483,647) R-L <=1,000,000. R的数值太大,所以不能直接筛[0,R]的,要空间和时间优化,用到区间筛法,另外注意不能用int,因为R和L都是满int的,中间有很多细节处理会爆int的,还要注意1不是素数,所以在区间筛中要特判一下,是个易错的地方 //1160K 16MS C++ 1539B #include<cstdio> #include<ios

poj 2689 Prime Distance(大区间筛素数)

http://poj.org/problem?id=2689 题意:给出一个大区间[L,U],分别求出该区间内连续的相差最小和相差最大的素数对. 因为L<U<=2147483647,直接筛素数是不行的,数组就开不了.但是可以根据素数筛的原理.我们先筛出sqrt(2147483647)以内的素数,然后拿这些素数去筛[L,U]之间的素数,即两次素数筛.但是L,U还是很大,但U-L<=1000000,所以进行区间平移,将[L,U]平移为[0,U-L],就能用数组放得下. #include &l

POJ - 2689 Prime Distance(大区间素数筛选)

Description The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is