Financial Management ZOJ1048(简单计算)

Financial Management

Time Limit: 2 Seconds Memory Limit: 65536 KB

Larry graduated this year and finally has a job. He‘s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what‘s
been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input Format:

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output Format:

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters
in the output.

Sample Input:

100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

1.75

Sample Output:

$1581.42

输入12个月的工资,计算平均工资

#include<bits/stdc++.h>
using namespace std;
const int maxn=100;
int main()
{
    int T;
    double sum=0;
    for(int i=0;i<12;i++){
        double tmp;
        cin>>tmp;
        sum+=tmp;
    }
    printf("$%.2lf\n",sum/12.0);

    return 0;
}
时间: 2024-08-04 08:12:55

Financial Management ZOJ1048(简单计算)的相关文章

UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management

Regionals 2001 >> North America - Mid-Atlantic USA 问题链接:UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management. 题意简述:输入12个数,计算其平均值. 编写程序时,考虑到C++处理输入比较方便,所以使用C++语言编程.然而,输出需要指定格式是还是C语言方便,所以就用函数printf()来处理输出. AC的C语言程序如下: /* UVALive2362 POJ1004 HDU106

UVA11945 Financial Management

问题链接:UVA11945 Financial Management. 题意简述:输入12个数,计算其平均值. 编写程序时,考虑到C++处理输入比较方便,所以使用C++语言编程.然而,输出稍微麻烦一些,对于金额,每3位需要加一个逗号,而C和C++的函数库中,没有相应的解决办法. 程序中专门编写函数output_result()处理输出,使用的是有限状态自动机的工作方式来处理的. 这个问题与UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Manageme

Python中的简单计算

Python中的简单计算 (1)基本的加减乘除 >>> 2 + 2 4 >>> 50 - 5*6 20 >>> (50 - 5*6) / 4 5.0 >>> 8 / 5  1.6 (2)除法总是会返回一个浮点数,想要返回整数,需要用"//"来表示(floor division),另外,可以用"%"进行取余操作 >>> 17 / 3  # classic division ret

HDU 1038[Biker&#39;s Trip Odometer]简单计算

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1038 题目大意:给轮子直径,转数,时间.要求输出走过的距离和时速(mile为单位) 关键思想:纯算 代码如下: #include <iostream> using namespace std; #define pi 3.1415927 int main(){ double d,r,t,l; int cnt=1; while(cin>>d>>r>>t&&a

SDUT OJ 2616 简单计算

简单计算 Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描述 某天,XX 给YY 出了一道题,题目是: 给出n 个十进制的数,找出这n 个数的二进制表示中1 的个数最少的数. 由于YY 的计算能力很差,所以他想让你帮他写个程序来计算出来. 输入 输入的第一行为一个正整数T(1 ≤T≤20),代表测试数据组数. 对于每组测试数据: 输入的第一行为一个正整数n (1 ≤ n ≤105): 第二行为n 个正整数A1.A2.… .An(1

[POJ] Financial Management

Financial Management Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 182193   Accepted: 68783 Description Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has deci

UVA 11945 Financial Management 水题

Financial Management Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 acm.hust.edu.cn/vjudge/problem/visitOriginUrl.action?id=20184 Description Michael graduated of ITESO this year and finally has a job. He's making a lot of money, but somehow never seem

POJ 1004 Financial Management 水

 Financial Management Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 165700   Accepted: 61629 Description Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has d

HDU1064 Financial Management 【water】

Financial Management Time Limit: 400/200 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9188    Accepted Submission(s): 5747 Problem Description Larry graduated this year and finally has a job. He's making a lot of