PAT 甲级 1024 Palindromic Number (25 分)(大数加法,考虑这个数一开始是不是回文串)

1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and Kinstead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题解:

  一开始便直接考虑用大数加法以防万一。第一次提交发现测试点2和测试点3没过,自己分析出了原因,可能在不加之前就已经是回文串,即k=0,还有单个数字也是回文串。

5 100
5
0
131 500
131

  本题考查的是数的相加和逆序,本属于简单题,但是本质考查了大数相加的知识。未注意到大数相加会导致测试点6和测试点8(从0开始)未通过。理由是本题的N的范围是(0,1010],k的范围是(0,100],我们考虑最坏的情况,假设N是一个非常逼近1010的值并且进行了100步操作依然未得到回文值,则简单推测可知计算过程中遇到的最大值是2100*1010,这个值超出了long long int(263-1,约9.2*1018)表示范围,因此需要用char存储数的值。

AC代码:

#include<bits/stdc++.h>
using namespace std;
char a[101];
char b[101];
char c[101];
int n;
int main(){
    cin>>a;
    cin>>n;
    int l=strlen(a);
    for(int i=0;i<l;i++){
        b[i]=a[l-i-1];
    }
    //先检查第0代它本身是不是回文
    int f=1;
    int mid=(l-1)/2;
    for(int j=0;j<=mid;j++){
        if(a[j]!=a[l-j-1]){
            f=0;
            break;
        }
    }
    if(f){
        cout<<a<<endl;
        cout<<0;
    }
    else{//再考虑第1代及以后
        int k=-1;
        for(int i=1;i<=n;i++){
            //加起来得到一个新的值
            int x=0;
            for(int j=0;j<l;j++){
                x=a[j]-‘0‘+b[j]-‘0‘+x;
                c[j]=x%10+‘0‘;
                x=x/10;
            }
            if(x>0){
                c[l++]=x+‘0‘;
            }
            //检查符不符合要求
            mid=(l-1)/2;
            f=1;
            for(int j=0;j<=mid;j++){
                if(c[j]!=c[l-j-1]){
                    f=0;
                    break;
                }
            }
            if(f){//是回文
                k=i;
                break;
            }
            for(int j=0;j<l;j++){//更新
                a[j]=c[j];
                b[j]=c[l-j-1];
            }
        }
        for(int i=l-1;i>=0;i--){//输出结果
            cout<<c[i];
        }
        cout<<endl;
        if(k!=-1){//还没到n代
            cout<<k<<endl;
        }else{
            cout<<n<<endl;
        }
    }
    return 0;
} 

学一下别人简洁得代码:

#include <iostream>
#include <algorithm>
using namespace std;
string add(string a){
    string ans=a;
    reverse(a.begin(),a.end());
    int i=a.length()-1,add=0;
    while(i>=0){
        int tmp=a[i]-‘0‘+ans[i]-‘0‘;
        ans[i]=(add+tmp)%10+‘0‘;
        add=(tmp+add)/10;
        i--;
    }
    if(add) ans.insert(0,"1");
    return ans;
}
int main(){
    string s;
    int k;
    cin>>s>>k;
    string tmp=s;
    reverse(tmp.begin(),tmp.end());
    if(tmp==s) cout<<tmp<<endl<<0;
    else{
        int i=0;
        while(i<k){
            s=add(tmp);
            i++;
            tmp=s;
            reverse(tmp.begin(),tmp.end());
            if(tmp==s) break;
        }
        cout<<s<<endl<<i;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/caiyishuai/p/11360919.html

时间: 2024-10-28 15:57:07

PAT 甲级 1024 Palindromic Number (25 分)(大数加法,考虑这个数一开始是不是回文串)的相关文章

PAT Advanced 1024 Palindromic Number (25分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired with palin

1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired with palin

【PAT甲级】1024 Palindromic Number (25 分)

题意: 输入两个正整数N和K(N<=1e10,k<=100),求K次内N和N的反置相加能否得到一个回文数,输出这个数和最小的操作次数. trick: 1e10的数字相加100次可能达到1e40,所以long long会爆,采用字符数组操作,以及代码注释中遇到的一些小问题. 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using namespace std;char num[107];char s[107];//这里用

PAT 1024. Palindromic Number (25)

1024. Palindromic Number (25) A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic nu

1024 Palindromic Number (25)(25 point(s))

problem A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Non-palindromic numbers can be paired wi

PAT 甲级 1016 Phone Bills (25 分) (结构体排序,模拟题,巧妙算时间,坑点太多,debug了好久)

1016 Phone Bills (25 分)   A long-distance telephone company charges its customers by the following rules: Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connec

PAT 甲级 1028 List Sorting (25 分)(排序,简单题)

1028 List Sorting (25 分)   Excel can sort records according to any column. Now you are supposed to imitate this function. Input Specification: Each input file contains one test case. For each case, the first line contains two integers N (≤) and C, wh

PAT 甲级 1051 Pop Sequence (25 分)(模拟栈,较简单)

1051 Pop Sequence (25 分) Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if

PAT 甲级 1063 Set Similarity (25 分) (新学,set的使用,printf 输出%,要%%)

1063 Set Similarity (25 分)   Given two sets of integers, the similarity of the sets is defined to be /, where N?c?? is the number of distinct common numbers shared by the two sets, and N?t?? is the total number of distinct numbers in the two sets. Yo