hdu 4268 Alice and Bob(贪心+multiset+二分)

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3511    Accepted Submission(s): 1129

Problem Description

Alice and Bob‘s game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob‘s. The card A can cover the card B if the height of A is not smaller than
B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob‘s cards that Alice can cover.

Please pay attention that each card can be used only once and the cards cannot be rotated.

Input

The first line of the input is a number T (T <= 40) which means the number of test cases.

For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and
width of Alice‘s card, then the following N lines means that of Bob‘s.

Output

For each test case, output an answer using one line which contains just one number.

Sample Input

2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4 

Sample Output

1
2

Source

2012 ACM/ICPC Asia Regional Changchun Online

题意:Alice 和 Bob  分别有 n 张牌,每张牌有一个长(h)和一个宽(w),Bob把他的牌依次排一排,Alice用他的牌依次去覆盖,求最多可以 覆盖多少,覆盖的条件是长和宽都要大于等于Bob的牌。

题解:贪心。将A,B的牌先按h从小到大排,再按w从小到大排。要使得覆盖的牌数最大,贪心策略是使A牌中还没用

的最小的牌尽量覆盖B中的牌,且最接近它。把当前小于牌Ai.h的B牌的w全部丢进multiset里面,再二分查找最后一个小于等于Ai.w的数,若存在则ans++,删掉这个数。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <set>
#include <queue>

using namespace std;
const int maxn=1e5+5;
struct T {
    int h;
    int w;
    bool operator < (const T & a) const {
        return h<a.h;
    }
};
void read(T * a,int n) {
    for(int i=0; i<n; i++)
        scanf("%d%d",&a[i].h,&a[i].w);
}
T a[maxn];
T b[maxn];
int ans;
int n;
multiset<int> st;
multiset<int>::iterator p;
int main() {
    int t;
    scanf("%d",&t);
    while(t--) {
        scanf("%d",&n);
        read(a,n);
        read(b,n);
        sort(a,a+n);
        sort(b,b+n);
        st.clear();
        ans=0;
        int j=0;
        for(int i=0; i<n; i++) {
            while(j<n&&b[j].h<=a[i].h)
                st.insert(b[j++].w);
            if(st.empty()) continue;
            p=st.lower_bound(a[i].w);
            if(p==st.end()||*p>a[i].w&&p!=st.begin()) p--;
            if(*p<=a[i].w) {
                ans++;
                st.erase(p);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-10 04:59:12

hdu 4268 Alice and Bob(贪心+multiset+二分)的相关文章

HDU 4268 Alice and Bob(贪心+multiset)

HDU 4268 题意:Alice与Bob在玩卡片游戏,他们每人有n张卡片,若Alice的一张卡片长与宽都不小于Bob的一张卡片,则Bob的卡片就会被盖住,一张卡片只可以使用一次,且不可旋转求Alice最多可以盖住多少张Bob的卡片. 思路:记录两人卡片情况,并按照长度将两人卡片分别降序排序.遍历两人的卡片,将长度小于Alice的卡片长度的Bob卡片的宽度插入multiset中,在multiset中找到小于等于Alice卡片宽度的第一个数,将这个数给消去且答案+1.//贪心法自行发挥即可. co

HDU 4268 Alice and Bob 贪心STL O(nlogn)

B - Alice and Bob Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively.

hdu 4268 Alice and Bob(multiset)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4268 题目大意:就是问你Alice的牌能覆盖Bob牌最多数量.牌不能翻转 思路:首先我们不分种类,把牌按高度排序,然后我们在依次判断牌的种类,如果是Bob的牌,我们就他牌的宽度放入multiset中,如果是Alice的牌就在multiset中找到宽度最大的那一张并删掉. #include<cstdio> #include<iostream> #include<cstring>

HDU 4268 Alice and Bob(贪心+Multiset的应用)

 题意: Alice和Bob有n个长方形,有长度和宽度,一个矩形可以覆盖另一个矩形的条件的是,本身长度大于等于另一个矩形,且宽度大于等于另一个矩形,矩形不可旋转,问你Alice最多能覆盖Bob的几个矩形? 思路:贪心,先按照h将Alice和Bob的矩形排序,对于Alice的每个矩形,如果Bob的矩形的h小于Alice的h,将Bob的w插入到集合中. 然后,在集合中找到不大于Alice矩形d的最大的Bob的d,那么这样做肯定是最优的. #include<cstdio> #include<

hdu 4268 Alice and Bob(multiset|段树)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2901    Accepted Submission(s): 941 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

hdu 4268 Alice and Bob(multiset|线段树)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2901    Accepted Submission(s): 941 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

HDU 4268 Alice and Bob(multiset的使用)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3046    Accepted Submission(s): 995 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

HDU 4268 Alice and Bob(贪心)

Alice and Bob                                                                Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description Alice and Bob's game never ends. Today, they introduce a new game. I

hdu 4268 Alice and Bob

Alice and Bob Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 5   Accepted Submission(s) : 1 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Alice and Bob's game nev