Description
Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive
(HDD) as a gift because you will get married next year.
But you turned on
your computer and the operating system (OS) told you the HDD is about 95MB. The
5MB of space is missing. It is known that the HDD manufacturers have a different
capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks
that is 1024. There are several descriptions of the size of an HDD. They are
byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and
yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte
is 1 “kilo” megabytes.
Now you know the size of a hard disk represented
by manufacturers and you want to calculate the percentage of the “missing part”.
Input
The first line contains an integer T, which indicates the number of test
cases.
For each test case, there is one line contains a string in format
“number[unit]” where number is a positive integer within [1, 1000] and unit is
the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”,
“ZB”, “YB” in short respectively.
Output
For each test case, output one line “Case #x: y”, where x is the case number
(starting from 1) and y is the percentage of the “missing part”. The answer
should be rounded to two digits after the decimal point.
Sample Input
2 100[MB] 1[B]
Sample Output
Case #1: 4.63% Case #2: 0.00%
Hint
#include<stdio.h>
#include<string.h>
int change(char *s){
if(!strcmp(s,"[B]")) return 0;
if(!strcmp(s,"[KB]")) return 1;
if(!strcmp(s,"[MB]")) return 2;
if(!strcmp(s,"[GB]")) return 3;
if(!strcmp(s,"[TB]")) return 4;
if(!strcmp(s,"[PB]")) return 5;
if(!strcmp(s,"[EB]")) return 6;
if(!strcmp(s,"[ZB]")) return 7;
if(!strcmp(s,"[YB]")) return 8;
}
int main(){
int t;
scanf("%d",&t);
int s,count=0;
char str[10];
while(t--){
scanf("%d%s",&s,str);
int c=change(str);
double p=1;
while(c--)
p*=1000.0/1024.0;
p=1-p;
printf("Case #%d: %.2f%%\n",++count,p*100);//printf("%%");输出%
}
return 0;
}