ZOJ1002 FIRE NET

Description:

Suppose that we have a square city with straight streets. A map of a city is a squareboard with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand,a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city aspossible so that no two can destroy each other. A configuration ofblockhouses islegal provided that no two blockhouses are on the samehorizontal row or vertical column
in a map unless there is at least one wallseparating them. In this problem we will consider small square cities (at most 4x4) that contain walls through whichbullets cannot run through.

The following image shows five pictures of the same board. Thefirst picture is the empty board, the second and third pictures show legalconfigurations, and the fourth and fifth pictures show illegal configurations.For this board, the maximum number of blockhouses
in a legal configurationis 5; the second picture shows one way to do it, but there are severalother ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in thecity in a legal configuration.

The input file contains one or more map descriptions, followed bya line containing the number 0 that signals the end of the file. Eachmap description begins with a line containing a positive integernthat is the size of the city;
n will be at most 4. The next nlines each describe one row of the map, with a ‘.‘ indicating anopen space and an uppercase ‘X‘ indicating a wall. There are nospaces in the input file.

For each test case, output one line containing themaximum number of blockhouses that can be placed in the cityin a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

代码:

#include <stdio.h>
#include <stdlib.h>

char city[4][4];
int n;
int max = 0;
int temp = 0;

int test(int x,int y)
{
    int i;
    for(i = y;i < n;i++)
    {
        if(city[x][i] == 'o')
            return 0;
        if(city[x][i] == 'X')
            break;
    }
    for(i = y;i >= 0;i--)
    {
        if(city[x][i] == 'o')
            return 0;
        if(city[x][i] == 'X')
            break;
    }
    for(i = x;i < n;i++)
    {
        if(city[i][y] == 'o')
            return 0;
        if(city[i][y] == 'X')
            break;
    }
    for(i = x;i >= 0;i--)
    {
        if(city[i][y] == 'o')
            return 0;
        if(city[i][y] == 'X')
            break;
    }

    return 1;
}

void DFS()
{
    if(temp > max)
        max = temp;
    int i,j;
    for(i = 0;i < n;i++)
        for(j = 0;j < n;j++)
            {
                if(city[i][j] == '.' && test(i,j))
                {
                    temp++;
                    city[i][j] = 'o';
                    DFS();
                    temp--;
                    city[i][j] = '.';
                }
            }
}

int main()
{
    scanf("%d",&n);
    while(n != 0)
    {
        int i,j;
        max = 0;
        temp = 0;
        char t[6];
        for(i = 0;i < n;i++)
        {
            scanf("%s",t);
            for(j = 0;j < n;j++)
                city[i][j] = t[j];
        }
        DFS();
        printf("%d\n",max);
        scanf("%d",&n);
    }
    return 0;
}
时间: 2024-11-10 04:54:42

ZOJ1002 FIRE NET的相关文章

ZOJ1002 —— 深度优先搜索

ZOJ1002 —— Fire net Time Limit: 2000 ms Memory Limit: 65536 KB Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a sma

FZU 2150 Fire Game(点火游戏)

p.MsoNormal { margin: 0pt; margin-bottom: .0001pt; text-align: justify; font-family: Calibri; font-size: 10.5000pt } h2 { margin-top: 5.0000pt; margin-bottom: 5.0000pt; text-align: left; font-family: 宋体; font-weight: bold; font-size: 18.0000pt } h3 {

ZOJ 3820 Building Fire Stations

Building Fire Stations Time Limit: 5000ms Memory Limit: 131072KB This problem will be judged on ZJU. Original ID: 382064-bit integer IO format: %lld      Java class name: Main Special Judge Marjar University is a beautiful and peaceful place. There a

HDU 1045 - Fire Net (最大独立集)

题意:给你一个正方形棋盘.每个棋子可以直线攻击,除非隔着石头.现在要求所有棋子都不互相攻击,问最多可以放多少个棋子. 这个题可以用搜索来做.每个棋子考虑放与不放两种情况,然后再判断是否能互相攻击来剪枝.最后取可以放置的最大值. 这里我转化成求最大独立集来做. 首先将每个空地编号,对于每个空地,与该位置可以攻击到的空地连边.找最多的空地使得不互相攻击,即求该图的最大独立集.与搜索做法基本一致,但是说法略有不同. 1 #include<iostream> 2 #include<cstring

Fire! 又是图 bfs

Joe works in a maze.  Unfortunately, portions of the maze havecaught on  re, and the owner of the maze neglected to create a  reescape plan. Help Joe escape the maze.Given Joe's location in the maze and which squares of the mazeare on  re, you must d

ACM: FZU 2150 Fire Game - DFS+BFS+枝剪 或者 纯BFS+枝剪

FZU 2150 Fire Game Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this boar

Fire Maze(广度优先搜索)

Fire Maze Time Limit: 1000 MS Memory Limit: 32768 K Total Submit: 53(19 users) Total Accepted: 26(17 users) Rating: Special Judge: No Description After escaping from Figo's chase, Severus falls into a N * M maze designed by Figo. At first, Severus is

(简单) UVA 11624 Fire! ,BFS。

Description Joe works in a maze. Unfortunately, portions of the maze have caught on fire, and the owner of the maze neglected to create a fire escape plan. Help Joe escape the maze. Given Joe's location in the maze and which squares of the maze are o

(简单) FZU 2150 Fire Game ,Floyd。

Problem Description Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstl