A1014. Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry
// hahaha.cpp : 定义控制台应用程序的入口点。
//

#include <stdafx.h>
#include <stdio.h>
#include <iostream>
#include <vector>
#include <queue>
#include <map>
#include <string>
#include <cstdio>
#include <set>
#include <algorithm>
#include <string.h>

using namespace std;

const int maxn=1111;
int n,m,k,query,q;

int cvttime(int h,int m)
    {
    return h*60+m;
    }

struct Window
    {
    int endtime,poptime;
    queue<int> q;
    }window[20];
int ans[maxn],needtime[maxn];

int main()
{
    int index=0;
    scanf("%d%d%d%d",&n,&m,&k,&query);
    for(int i=0;i<k;i++)
        {
        scanf("%d",&needtime[i]);
        }

    for(int i=0;i<n;i++)
        {
        window[i].poptime=window[i].endtime=cvttime(8,0);
        }

    for(int i=0;i<min(n*m,k);i++)//将能入队的先去排队
        {
        window[index%n].q.push(index);
        window[index%n].endtime+=needtime[index];
        if(index<n)window[index].poptime=needtime[index];
        ans[index]=window[index%n].endtime;
        index++;
        }
     for(;index<k;index++)
         {
         int idx=-1,minpop=1<<30;
         for(int i=0;i<n;i++)
             {
             if(window[i].poptime<minpop)
                 {
                 idx=i;
                 minpop=window[i].poptime;
                 }
             }
        Window &w=window[idx];
        w.q.pop();
        w.q.push(index);
        w.endtime+=needtime[index];
        w.poptime+=needtime[w.q.front()];
        ans[index]=w.endtime;
         }

     for(int i=0;i<query;i++)
         {
         scanf("%d",&q);
         if(ans[q-1]-needtime[q-1]>=cvttime(17,0))
             printf("Sorry\n");
         else
             {
             printf("%02d:%02d\n",ans[q-1]/60,ans[q-1]%60);
             }
         }
    return 0;
}
时间: 2024-08-27 23:08:45

A1014. Waiting in Line (30)的相关文章

1014. Waiting in Line (30)——PAT (Advanced Level) Practise

题目信息: 1014. Waiting in Line (30) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rule

PAT 甲级 1014 Waiting in Line (30 分)(queue的使用,模拟题,有个大坑)

1014 Waiting in Line (30 分) Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line

PAT A1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line in front of each window is

1014. Waiting in Line (30)(模拟题)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line in front of each window is

1014. Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line in front of each window is

PAT-1014 Waiting in Line (30 分) 优先队列

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: The space inside the yellow line in front of each window is

PAT甲题题解-1014. Waiting in Line (30)-模拟,优先级队列

题意:n个窗口,每个窗口可以排m人.有k为顾客需要办理业务,给出了每个客户的办理业务时间.银行在8点开始服务,如果窗口都排满了,客户就得在黄线外等候.如果有一个窗口用户服务结束,黄线外的客户就进来一个.如果有多个可选,选窗口id最小的.输出查询客户的服务结束时间. 如果客户在17点(注意是包括的!!!就在这里被坑了,一开始还以为不包括...)或者以后还没开始服务,就输出Sorry如果已经开始了,无论多长都会继续服务的. 思路:建立一个优先级队列,存储在黄线之内的所有客户.对于m*n之前的人,依此

PAT (Advanced Level) 1014. Waiting in Line (30)

简单模拟题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> using namespace std; struct X { int st; int len; int en; }p[1500]; queue<int>Q[2

常规问题解决:File &quot;/usr/bin/yum&quot;, line 30

在执行yum命令时忽然发现出现以下报错: [[email protected] ~]# yum list File "/usr/bin/yum", line 30 except KeyboardInterrupt, e: ^ SyntaxError: invalid syntax 原因: 这是因为yum采用Python作为命令解释器,这可以从/usr/bin/yum文件中第一行#!/usr/bin/python发现.而python版本之间兼容性不太好,使得2.X版本与3.0版本之间存在