PAT Advanced 1076 Forwards on Weibo (30) [图的遍历,BFS,DFS]

题目

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:
M[i] user_list[i]
where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space. Then finally a positive K is given, followed by K UserID’s for query.
Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.
Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

题目分析

用户发一条微博后,其粉丝进行一次转发,其粉丝的粉丝进行一次转发,已知所有人关系网图,求最大转发数,间接粉丝层数<=L

解题思路

思路 01(BFS 最优)

广度优先搜索,定义顶点结构体,在顶点中定义属性level记录该节点访问层级,超过L后停止访问

思路 02 (DFS)

深度优先搜索,使用参数depth递归记录层级,超过L后停止访问

问题:DFS中访问过的节点标记为已访问,会丢失一些路径,样例中假设没有6-3-5-7路径,访问6-3-1-4后,再访问6-3-4-5时,因为4标记已访问,所以这条路径不可访问,节点5将不会被统计

解决办法:用数组记录节点被访问时的层级,若再次被访问时,看当前层级是否小于level数组中之前被访问层级,若小于可以访问

Code

Code 01(BFS 最优)

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=1010;
vector<int> g[maxn]; //粉丝列表
int L;
struct node {
    int v;
    int layer;
//  node () {}
//  node(int _v):v(_v) {}
} ;
int bfs(int v) {
    int cnt=0;
    queue<node> q;
    q.push({v,0});
    int vis[maxn]= {0};
    vis[v]=1;
    while(!q.empty()) {
        node now = q.front();
        q.pop();
        for(int i=0; i<g[now.v].size(); i++) {
            if(now.layer<L&&vis[g[now.v][i]]==0) {
                q.push({g[now.v][i],now.layer+1});
                cnt++;
                vis[g[now.v][i]]=1;
            }
        }
    }
    return cnt;
}
int main(int argc,char * argv[]) {
    int n,m,z,t,y;
    scanf("%d %d",&n,&L);
    for(int i=1; i<=n; i++) {
        scanf("%d",&m);
        for(int j=0; j<m; j++) {
            scanf("%d",&z);
            g[z].push_back(i);
        }
    }
    scanf("%d",&t);//查询次数
    for(int i=0; i<t; i++) {
        scanf("%d",&y);
        printf("%d\n",bfs(y));//广度搜素
    }

    return 0;
}

Code 02(DFS)

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=1010;
vector<int> g[maxn]; //粉丝列表
int L,vis[maxn],level[maxn];
void dfs(int v, int depth) {
    if(depth>L)return;
    vis[v]=1;
    level[v]=depth;
    for(int i=0; i<g[v].size(); i++) {
        if(vis[g[v][i]]!=1||depth+1<level[g[v][i]])
            dfs(g[v][i],depth+1);
    }
}
int main(int argc,char * argv[]) {
    int n,m,z,t,y;
    scanf("%d %d",&n,&L);
    for(int i=1; i<=n; i++) {
        scanf("%d",&m);
        for(int j=0; j<m; j++) {
            scanf("%d",&z);
            g[z].push_back(i);
        }
    }
    scanf("%d",&t);//查询次数
    for(int i=0; i<t; i++) {
        scanf("%d",&y);
        fill(vis,vis+maxn,0);
        int cnt=0;
        dfs(y,0);//深度搜素
        for(int j=1; j<=n; j++) {
            if(vis[j]==1)cnt++;
        }
        printf("%d\n",cnt-1);
    }

    return 0;
}

原文地址:https://www.cnblogs.com/houzm/p/12353420.html

时间: 2024-11-07 13:01:20

PAT Advanced 1076 Forwards on Weibo (30) [图的遍历,BFS,DFS]的相关文章

PAT:1076. Forwards on Weibo (30) AC

#include<cstdio> #include<cstring> #include<queue> #include<vector> using namespace std; const int MAX=1010; bool tag[MAX]; //标记BFS是是否被访问过 struct node { int ID; //编号 int layer; //层号 }; vector<node> Adj[MAX]; //邻接表,每个位置都是一个nod

1076. Forwards on Weibo (30)【树+搜索】——PAT (Advanced Level) Practise

题目信息 1076. Forwards on Weibo (30) 时间限制3000 ms 内存限制65536 kB 代码长度限制16000 B Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with follo

PAT 1076. Forwards on Weibo (30)

题目地址:http://pat.zju.edu.cn/contests/pat-a-practise/1076 此题考查图的遍历操作: 本来我个人觉得可以用dfs的,但是不知何故,有两个case没有过,贴出代码,望指出错误之处: #include <cstdio> #include <map> #include <vector> #include <memory.h> using namespace std; const int NUM=1001; bool

PAT (Advanced Level) 1076. Forwards on Weibo (30)

最短路. 每次询问的点当做起点,然后算一下点到其余点的最短路.然后统计一下最短路小于等于L的点有几个. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm>

1076. Forwards on Weibo (30)

时间限制 3000 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers

模板 图的遍历 bfs+dfs 图的最短路径 Floyed+Dijkstra

广搜 bfs 1 //bfs 2 3 #include<iostream> 4 #include<cstdio> 5 using namespace std; 6 int queue[1001],top=0,end=1; 7 int map[1001][1001]; 8 int vis[1001]; 9 int n,m; 10 void bfs(int p) 11 { 12 queue[end]=p; 13 vis[p]=1; 14 printf("%c -->&q

PAT Advanced 1034 Head of a Gang (30) [图的遍历,BFS,DFS,并查集]

题目 One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls mad

算法导论--图的遍历(DFS与BFS)

转载请注明出处:勿在浮沙筑高台http://blog.csdn.net/luoshixian099/article/details/51897538 图的遍历就是从图中的某个顶点出发,按某种方法对图中的所有顶点访问且仅访问一次.为了保证图中的顶点在遍历过程中仅访问一次,要为每一个顶点设置一个访问标志.通常有两种方法:深度优先搜索(DFS)和广度优先搜索(BFS).这两种算法对有向图与无向图均适用. 以下面无向图为例: 1.深度优先搜索(DFS) 基本步骤: 1.从图中某个顶点v0出发,首先访问v

图的遍历 (dfs与bfs)x

遍历是很多图论算法的基础,所谓图的遍历( graph traversal),也称为搜索( search),就是从图中某个顶点出发,沿着一些边访遍图中所有的顶点,且使每个顶点仅被访问一次.         遍历可以采取两种方法进行:         深度优先搜索( DFS: depth first search):         广度优先搜索( BFS: breadth first search). 对图进行存储与遍历: 输入: 第一行:顶点数n. 第二行:边数m. 以下m行,每行两个顶点编号u