poj 1703 Find them, Catch them(种类并查集和一种巧妙的方法)

Find them, Catch them

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 36176   Accepted: 11090

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.

In the same gang.

题意:是一个城市有两个帮派,A 1 2是询问1和2这两个人是不是一个帮派,D 1 2是这两个人不在一个帮派
	每一次A就输出一次
思路: 带权并查集,加一个数组re[]表示子节点和其父节点的关系,是一个门派就是0。不是就是1
2015,7,27
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define M 100100
int x[M],re[M];
void init()
{
	for(int i=0;i<M;i++){
		x[i]=i;
		re[i]=0;
	}
}
int find(int k)
{
	int temp=x[k];
	if(x[k]==k) return k;
	x[k]=find(x[k]);
	if(re[k]==re[temp])//假设和父节点是同类就存0
		re[k]=0;
	else re[k]=1;
	return x[k];
}
void merge(int a,int b,int fa,int fb)
{
	x[fa]=fb;
	if(re[a]==re[b]) re[fa]=1;
	else re[fb]=0;
}
int main()
{
	int t,n,m,i,a,b,fa,fb;
	char ch;
	scanf("%d",&t);
	while(t--){
		init();
		scanf("%d%d",&n,&m);
		while(m--){
			cin>>ch;
			scanf("%d%d",&a,&b);
			fa=find(a);
			fb=find(b);
			if(ch==‘A‘){
				if(fa!=fb){
					printf("Not sure yet.\n");
					continue;
				}
				if(re[a]==re[b]){
					printf("In the same gang.\n");
					continue;
				}
				else{
					printf("In different gangs.\n");
				}
			}
			else{
				if(fa!=fb)
					merge(a,b,fa,fb);
			}
		}
	}
	return 0;
}
/* 还有一种巧妙方法:大神的解析。是poj食物链那道题的弱化。

可见全部元素个数为2 * N,假设i表示属于帮派A。那么i + N表示属于帮派B。
每次输入两个家伙不在同一帮派的时候。就合并他们分属两个帮派的元素。

*/
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define M 200200
int x[M];
void init()
{
	for(int i=0;i<M;i++)
		x[i]=i;
}
int find(int k)
{
	if(x[k]==k) return k;
	x[k]=find(x[k]);//压缩路径
	return x[k];
}
void merge(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(x[a]!=x[b]) x[fa]=fb;
}
bool same(int a,int b)
{
	return find(a)==find(b);
}
int main()
{
	int t,n,m,i,a,b,fa,fb;
	char ch;
	scanf("%d",&t);
	while(t--){
		init();
		scanf("%d%d",&n,&m);
		while(m--){
			cin>>ch;
			scanf("%d%d",&a,&b);
			if(ch==‘A‘){
				if(same(a,b)){
					printf("In the same gang.\n");
					continue;
				}
				if(same(a,b+n)){
					printf("In different gangs.\n");
				}
				else{
					printf("Not sure yet.\n");
					continue;
				}
			}
			else{
				merge(a,b+n);//a和b一定不在一个门派,就把a和b+n合并
				merge(a+n,b);//同理
			}
		}
	}
	return 0;
}

时间: 2024-08-27 13:28:54

poj 1703 Find them, Catch them(种类并查集和一种巧妙的方法)的相关文章

poj 1703 Find them, Catch them(带权并查集和一种巧妙的方法)

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 36176   Accepted: 11090 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago

POJ - 1703 Find them, Catch them(种类并查集)

题意:N个人,M条关系,A x y表示询问x和y是不是属于同一组,D x y表示x和y是不同组.输出每个询问后的结果. 分析: 1.所有的关系形成一个连通图,如果x和y可达,那两者关系是确定的,否则不能确定. 2.r[tmpy] = r[x] + r[y] + 1;可以更新连通块里祖先的标号. eg: 5 4 D 1 2 D 2 3 D 4 5-----到此为止形成两个连通块,标号如图所示(红笔) D 3 5 第四步,将3和5连边,因为以0为祖先,所以4的标号应当改变,可以发现改变后的r[4]

POJ - 1703 - Find them, Catch them (并查集)

题目传送:Find them, Catch them 思路:用一个关系数组记录当前结点与其父亲的关系,0表示同类,1表示不同类 AC代码: #include <cstdio> #include <cstring> #include <iostream> #include <algorithm> #include <cmath> #include <queue> #include <stack> #include <v

poj 1703 Find them, Catch them 【并查集拓展】

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 32514   Accepted: 10036 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago

POJ 2236 Wireless Network ||POJ 1703 Find them, Catch them 并查集

POJ 2236 Wireless Network http://poj.org/problem?id=2236 题目大意: 给你N台损坏的电脑坐标,这些电脑只能与不超过距离d的电脑通信,但如果x和y均能C通信,则x和y可以通信.现在给出若干个操作, O p 代表修复编号为p的电脑 S p q代表询问p和q是不是能通信. 思路: 并查集即可.. 如果修复了一台电脑,则把与它相连距离不超过d的且修复了的放在一个集合里面. #include<cstdio> #include<cstring&

POJ 1703 Find them, Catch them(数据结构-并查集)

Find them, Catch them Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal b

HDU 1829 &amp;&amp; POJ 2492 A Bug&#39;s Life(种类并查集)

题目地址:HDU 1829     POJ 2492 这个题可以用两种方法做,第一眼看完题是觉得用dfs染色判断二分图.然后又写的刚学的种类并查集.原来并查集可以这样用,真是神奇.. dfs染色代码: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #incl

[poj1703]Find them, Catch them(种类并查集)

题意:食物链的弱化版本 解题关键:种类并查集,注意向量的合成. $rank$为1代表与父亲对立,$rank$为0代表与父亲同类. #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> #include<cstdlib> #include<cmath> using namespace std; typedef long long ll; #de

poj 1703 Find them, Catch them

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 46119   Accepted: 14193 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago