Uva 642 - Word Amalgamation sort qsort

 Word Amalgamation 

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input file contains four parts:

1.
a dictionary, which consists of at least one and at most 100 words, one per line;
2.
a line containing XXXXXX, which signals the end of the dictionary;
3.
one or more scrambled `words‘ that you must unscramble, each on a line by itself; and
4.
another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercaseX‘s.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

sort代码

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
char word[100][7];
char* dic[100];
char* seq[100];
char str[7];

bool compare(char *p1, char *p2)
{
	return strcmp(p1,p2)<0;
}
int main()
{
	int n ;
	for (n = 0; scanf("%s", word[n]) && strcmp(word[n], "XXXXXX") != 0; n++);
	for (int i=0; i < n; i++)
		dic[i] = word[i];
	sort(dic,dic+n,compare);
	for (int i = 0; i < n; i++)
	{
		seq[i] = (char *)malloc(strlen(dic[i])+1);
		strcpy(seq[i],dic[i]);
		sort(seq[i],seq[i]+strlen(seq[i]));
	}
	while (scanf("%s", str) && strcmp(str, "XXXXXX") != 0)
	{
		int found = 0;
		sort(str,str+strlen(str));
		for (int i = 0; i < n;i++)
			if (strcmp(str, seq[i]) == 0)
			{
				found = 1;
				printf("%s\n",dic[i]);
			}
		if (found == 0)
			printf("NOT A VALID WORD\n");
		printf("******\n");
	}
	return 0;
}

  用qsort代码

#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
char word[100][7];
char seq[100][7];
char str[7];
int comp_char(const void * p1, const void * p2)
{
	return *(char *)p1 - *(char *)p2;
}
int compare(const void *p1, const void *p2)
{
	return strcmp((char *)p1, (char *)p2);
}
int main()
{
	int n;
	for (n = 0; scanf("%s", word[n]) && strcmp(word[n], "XXXXXX") != 0; n++);
	qsort(word,n,sizeof(word[0]),compare);
	for (int i = 0; i < n; i++)
	{
		strcpy(seq[i], word[i]);
		qsort(seq[i], strlen(seq[i]),sizeof(char),comp_char);
	}
	while (scanf("%s", str) && strcmp(str, "XXXXXX") != 0)
	{
		int found = 0;
		qsort(str, strlen(str),sizeof(char),comp_char);
		for (int i = 0; i < n; i++)
		if (strcmp(str, seq[i]) == 0)
		{
			found = 1;
			printf("%s\n", word[i]);
		}
		if (found == 0)
			printf("NOT A VALID WORD\n");
		printf("******\n");
	}
	return 0;
}

  qsort可以对2维数组进行排序,因为它可以调换任意大小的内存块的顺序(第三个参数指定),sort只能对一维数组或者容器进行排序,因为对其解引用时必须是一个左值。

  另一个注意点就是cmp函数比较时qsort用“-”,而sort用”>”。

sort函数要求比较函数是strict weak ordering的,否则会出现assertion error: Invalid operator<,而strict weak ordering必须满足三个条件:

1) Strict: pred (X, X) is always false.  X跟X自己比为false

2) Weak: If ! pred (X, Y) && !pred (Y, X), X==Y. 当X<Y和Y<X都不成立时,X等于Y

3)Ordering: If pred (X, Y) && pred (Y, Z), then pred (X, Z). 当X<Y,Y<Z时,X<Z成立,即排序的一个传递性。

时间: 2024-10-13 17:07:25

Uva 642 - Word Amalgamation sort qsort的相关文章

UVa 642 - Word Amalgamation

题目:给你一个单词列表.再给你一些新的单词.输出列表中又一次排列能得到此新单词的词. 分析:字符串.对每一个字符串的字母排序生成新的传f(str).总体排序,用二分来查找就可以. 说明:注意输出要满足字典序,先排序后查找. #include <algorithm> #include <iostream> #include <cstdlib> #include <cstring> #include <cstdio> using namespace

POJ 1318 Word Amalgamation (字符串 STL大水)

Word Amalgamation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 8665   Accepted: 4172 Description In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but

HDU1113 Word Amalgamation

问题链接:HDU1113 Word Amalgamation. 这个问题是一个字典问题,自然用map来实现.问题在于还需要转个弯,不然会掉进陷阱里去的. 查字典问题,通常是单词按照字典顺序存放,然后将要查的单词拆成字母,按单词的字母顺序去查字典.然而要是这样做程序的逻辑就太零碎繁杂了. 于是,把单词中的字符排个顺序作为关键字,来查单词的话就方便了.需要注意的一点,不同的单词有可能具有相同的关键字. 这个程序的关键有容器类map的使用,算法库<algorithm>中函数sort()的使用. AC

hdu1113 Word Amalgamation(超详细解释--map和string的运用)

转载请注明出处:http://blog.csdn.net/u012860063天资 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1113 来吧!!欢迎"热爱编程"的同学报考杭电,期待你加入"杭电ACM集训队"! 7月22-8月21多校联合训练期间,会根据实际负载关闭部分模块,若有不便,请谅解~ Word Amalgamation Time Limit: 2000/1000 MS (Java/Others)    Me

hdu 1113 Word Amalgamation (map)

# include <stdio.h> # include <string> # include <map> # include <iostream> # include <algorithm> using namespace std; int main() { string s,t; int flag; map<string,string>q; while(cin>>s&&s!="XXXXXX&

Word Amalgamation

Problem Description In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four wor

poj 1318 Word Amalgamation

Word Amalgamation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 9968   Accepted: 4774 Description In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but

uva 417 - Word Index(数位dp)

题目连接:uva 417 - Word Index 题目大意:按照题目中的要求,为字符串编号,现在给出字符串,问说编号为多少,注意字符串必须为递增的,否则编号为0. 解题思路:其实就是算说比给定字符串小并且满足递增的串由多少个.dp[i][j]表示第i个位为j满足比给定字符串小并且满足递增的串. dp[i][j]=∑k=0j?1dp[i?1][k]. 注意每次要处理边界的情况,并且最后要加上自身串.并且在处理边界的时候dp[i][0]要被赋值为1,代表前i个为空的情况. #include <cs

UVA 417 - Word Index(数论)

题意:417 - Word Index 题意:每个字符串按题目中那样去映射成一个数字,输入字符串,输出数字 思路:这题还是比较水的,由于一共只有83000多个数字,所以对应一个个数字去映射就可以了,注意字符串进位的情况处理即可 代码: #include <stdio.h> #include <string.h> #include <map> #include <string> using namespace std; char str[10]; map<