zoj 3490 String Successor 字符串 进制

String Successor



Time Limit: 2 Seconds      Memory Limit: 65536 KB



The successor to a string can be calculated by applying the following rules:

  • Ignore the nonalphanumerics unless there are no alphanumerics, in this case, increase the rightmost character in the string.
  • The increment starts from the rightmost alphanumeric.
  • Increase a digit always results in another digit (‘0‘ -> ‘1‘, ‘1‘ -> ‘2‘ ... ‘9‘ -> ‘0‘).
  • Increase a upper case always results in another upper case (‘A‘ -> ‘B‘, ‘B‘ -> ‘C‘ ... ‘Z‘ -> ‘A‘).
  • Increase a lower case always results in another lower case (‘a‘ -> ‘b‘, ‘b‘ -> ‘c‘ ... ‘z‘ -> ‘a‘).
  • If the increment generates a carry, the alphanumeric to the left of it is increased.
  • Add an additional alphanumeric to the left of the leftmost alphanumeric if necessary, the added alphanumeric is always of the same type with the leftmost alphanumeric (‘1‘ for digit, ‘A‘ for upper case and ‘a‘ for lower case).

Input

There are multiple test cases. The first line of input is an integer T ≈ 10000 indicating the number of test cases.

Each test case contains a nonempty string s and an integer 1 ≤ n ≤ 100. The string s consists of no more than 100 characters whose ASCII values range from 33(‘!‘) to 122(‘z‘).

Output

For each test case, output the next n successors to the given string s in separate lines. Output a blank line after each test case.

Sample Input

4
:-( 1
cirno=8 2
X 3
/**********/ 4

Sample Output

:-)

cirno=9
cirnp=0

Y
Z
AA

/**********0
/**********1
/**********2
/**********3

题意:

给一串字符,按规则增加n次。

1.如果有字母数字符号,把最左边的数字或者字母+1, 否者就把最右边的其他符号asc码+1.

2.当字母或者数字到了 9 或者 Z 或者 z 再增加就向左进位,自己变成0,A,a.

3.  如果左边已经没有数字或者字母了,就在最左边的数字或字母左边,紧贴着加一位,字母加A或a,数字加1.

具体看案例就能明白了。

做法:模拟就好了,从右至左,看到数字字母,就加,没进位就结束,有进位就继续向左。

我用c++的string类做的, 我看了下一起比赛的同学代码,如果用c++普遍耗时600ms, 如果用char写,可以快到0ms。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <string>
#include <stack>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <map>
using namespace std;
#define MAXM 1000000
#define MAXN 110
map<string ,int> my;

int is(char ch)
{
	if(ch>='0'&&ch<='9')
		return 1;
	if(ch>='a'&&ch<='z')
		return 2;
	if(ch>='A'&&ch<='Z')
		return 3;
	return 0;
}

int upup(char &ch,int type)
{
	if(type==1)
	{
		if(ch=='9')
		{
			ch='0';
			return 1;//jin
		}
		else
		{
			ch++;
			return 0;
		}
	}
	if(type==2)
	{
		if(ch=='z')
		{
			ch='a';
			return 1;//jin
		}
		else
		{
			ch++;
			return 0;
		}
	}
	if(type==3)
	{
		if(ch=='Z')
		{
			ch='A';
			return 1;//jin
		}
		else
		{
			ch++;
			return 0;
		}
	}
	return 0;
}
void update(string &str)
{
	int i;
	int flag=0;
	int jin=0;
	int id;
	int type;
	for(i=str.size()-1;i>=0;i--)
	{
		if(is(str[i]))
		{
			jin=upup(str[i],is(str[i]));
			flag=1;//you jia guo
			type=is(str[i]);
			id=i;
			if(jin==0)
				break;
		}
	}

	if(flag==0)//从来没有 数字 字母
	{
		str[str.size()-1]++;
	}
	else if(jin==1)
	{
		if(type==1)
			str.insert(id,"1");//insert(id,'1');
		else if(type==2)
			str.insert(id,"a");
		else if(type==3)
			str.insert(id,"A");
	}

	cout<<str<<endl;
}

int main()
{
	int t;
	cin>>t;
	double num[10];
	while(t--)
	{
		string str;
		int n;
		cin>>str;
		cin>>n;

		while(n--)
		{
			update(str);
		}
		printf("\n");
	}
	return 0;
}
时间: 2024-10-10 17:43:59

zoj 3490 String Successor 字符串 进制的相关文章

ZOJ 3490 String Successor(模拟啊 )

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4313 The successor to a string can be calculated by applying the following rules: Ignore the nonalphanumerics unless there are no alphanumerics, in this case, increase the rightmost char

ZOJ 3490 String Successor

简单的模拟题,类似于高精度加法运算.理解题意即可. #include<stdio.h> #include<string.h> #include<math.h> #include<algorithm> using namespace std; const int maxn = 111; char s[maxn]; char ji[maxn]; int gg[maxn]; void RevStr(char *str) { int len; char *ptr;

SHUoj 字符串进制转换

字符串进制转换 发布时间: 2017年7月9日 18:17   最后更新: 2017年7月9日 21:17   时间限制: 1000ms   内存限制: 128M 描述 Claire Redfield在龙之谷游戏的一次任务中获得了一个上了锁的宝箱,上面刻了一串由小写字母构成的字符串A和一个数字m  . 经过Claire长时间研究,他发现密码是和a  ,m  有关的.字符串A相当于一个26进制的数字,a  相当于0  ,b  相当于1  --.z  相当于25  .然后要将这个26进制的数转化成m

SHU 414 - 字符串进制转换

题目链接:http://acmoj.shu.edu.cn/problem/414/ 网上拉了个进制转换模板过来,因为数组开的太小一直WA,难受-- 1 #include<cstdio> 2 #include<cstring> 3 #define MAXN 10000 4 int t[MAXN],A[MAXN],n; 5 char OldData[MAXN],NewData[MAXN]; //转换前.后的数据 6 int olds,news; //转换前.后的进制 7 void tr

POJ1546 &amp; HDU 1335 &amp; ZOJ 1334 Basically Speaking(进制转换)

题目链接: POJ:http://poj.org/problem?id=1546 HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1335 ZOJ:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=334 Description The Really Neato Calculator Company, Inc. has recently hired your team to help

int与String转换,进制转换

进制转换

Java字符串转16 进制工具类Hex.java

原文:Java字符串转16 进制工具类Hex.java 源代码下载地址:http://www.zuidaima.com/share/1550463378410496.htm Java 字符串转 16 进制工具类 Hex.java 实现 16进制 0xfecd .. 和 java 字符串之间的互转换! 如果做开发,通常用户登陆密码都会 mad5(salt + pwd) 然后再将 md 之后的数据 hex 一下. 这个工具类,就是实现此效果的. /* * */ package com.zuidaim

Golang中的[]byte与16进制(String)之间相互转换

[]byte -> String(16进制) 1 src := []byte("Hello") 2 encodedStr := hex.EncodeToString(src) 3 // 注意"Hello"与"encodedStr"不相等,encodedStr是用字符串来表示16进制 String -> []byte 1 test, _ := hex.DecodeString(encodedStr) 2 fmt.Println(byte

【曾经】进制转换器C#

1 using System; 2 using System.Collections.Generic; 3 using System.ComponentModel; 4 using System.Data; 5 using System.Drawing; 6 using System.Linq; 7 using System.Text; 8 using System.Threading.Tasks; 9 using System.Windows.Forms; 10 11 namespace nu