WLS的周期串 |
难度级别:A; 运行时间限制:1000ms; 运行空间限制:51200KB; 代码长度限制:2000000B |
试题描述 |
如果一个字符串可以由某个长度为k的字符串重复多次得到,我们说该串以k为周期。例如,abcabcabcabc以3为周期(注意,它也以6和12为周期)。输入一个长度不超过1000的串输出它的最小周期。 |
输入 |
一个由常用字符组成的字符串 |
输出 |
输入字符串的最小周期 |
输入示例 |
abcabcabcabc |
输出示例 |
3 |
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
int main()
{
char word[100];
scanf("%s", word);
int len = strlen(word);
for(int i = 1; i <= len; ++i){
if (len % i == 0){
int ok = 1;
for(int j = i; j < len; ++j){
if(word[j] != word[j % i]){
ok = 0;
break;
}
}
if (ok){
printf("%d\n", i);
break;
}
}
}
//system("PAUSE");
return 0;
}
时间: 2024-10-09 11:57:29