hdoj 3342 Legal or Not 【拓朴排序】

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/O

hers)

Total Submission(s): 6078    Accepted Submission(s): 2824

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions,
many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too
many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian
is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and
y is x‘s prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

分析:

判断是否能进行拓朴排序。

代码1:
#include<cstdio>
#include<cstring>
#include<cstdlib>
int map[110][110];
int n,m;
int vis[110];

bool topo()
{
   int i,j,m;
   for(i=0;i<n;i++)
   {
      m=n;
      for(j=0;j<n;j++)
      {
        if(vis[j]==0){
        m=j;
        break;
        }
      }
      if(m==n)
      return false;
      vis[m]=-1;
      for(j=0;j<n;j++)
      if(map[m][j]>0)
      vis[j]--;
   }
   return true;
}

int main()
{
    bool flag;
    int a,b;
   while(scanf("%d%d",&n,&m)!=EOF,n||m)
   {
     memset(map,0,sizeof(map));
     memset(vis,0,sizeof(vis));
       for(int i=0;i<m;i++)
       {
         scanf("%d%d",&a,&b);
         if(map[a][b]==0)
         map[a][b]=1,vis[b]++;
       }
       flag=topo();
       if(flag)
       printf("YES\n");
       else
       printf("NO\n");
   }
   //system("pause");
 return 0;
}

代码2:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int n,m;
int vis[110];
struct node{
  int next,to;
};
node pp[110];
int head[110];

bool topo()
{
 int i,j, m,t;
 for(j=0;j<n;j++)
 {
    m=n;
    for(i=0;i<n;i++)
    {
     if(vis[i]==0)
     {
      m=i;
      break;
     }
    }
    if(m==n)
    return false;
    vis[m]=-1;
    for(int k=head[m];k!=-1;k=pp[k].next)
    vis[pp[k].to]--;
 }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF,n||m)
    {
       int a,b;
       bool flag;
       memset(vis,0,sizeof(vis));
       memset(head,-1,sizeof(head));
       for(int i=0;i<m;i++)
       {
        scanf("%d%d",&a,&b);
        pp[i].to=b;
        pp[i].next=head[a];
        head[a]=i;
        vis[b]++;
       }
       flag=topo();
       if(flag)
       printf("YES\n");
       else
       printf("NO\n");
    }
   // system("pause");
 return 0;
}

版权声明:博主情人,外人误碰!!!

时间: 2024-08-04 02:56:00

hdoj 3342 Legal or Not 【拓朴排序】的相关文章

HDOJ 3342 Legal or Not 【拓扑排序】

题意:判断是否成环. 策略:如题. 这道题就是简单的拓扑排序题,但是要注意一点要去重复的数据.我用了两种结构体:链式前向星和邻接矩阵. 代码1:(用链式前向星)(不用增加去重) #include<stdio.h> #include<string.h> #include<queue> #define INF 0x3f3f3f3f #define MAXN 105 struct EdgeNode{ int to; int next; }edges[MAXN]; int he

hdoj 3342 Legal or Not【拓扑排序】

Legal or Not Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5885    Accepted Submission(s): 2726 Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is

[ACM] hdu 3342 Legal or Not (拓扑排序)

Legal or Not Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to excha

HDU 3342 Legal or Not(拓扑排序判环)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3342 题目: Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lc

HDU 3342 Legal or Not(拓扑排序判断成环)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3342 题目大意:n个点,m条有向边,让你判断是否有环. 解题思路:裸题,用dfs版的拓扑排序直接套用即可. 代码: 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 using namespace std; 5 const int N=1e2+5; 6 7 int n,m; 8 int vis[N];

HDU 3342 Legal or Not【拓扑排序】

题意:给出n,m,人的编号为 0到n-1,再给出m个关系,问能不能够进行拓扑排序 #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> using namespace std; int indegree[1005],queue[1005],head[1005]; struct Edge { int to; int next; } edge[1005]; int ma

hdu 3342 Legal or Not (拓扑排序)

重边这样的东西   仅仅能呵呵 就是裸裸的拓扑排序 假设恩可以排出来就YES . else  NO 仅仅须要所有搜一遍就好了 #include <cstdio> #include <cstring> int mapp[101][101]; int d[101]; int n,m; int a,b; int main() { while(scanf("%d%d",&n,&m)!=EOF) { if(n==0)break; memset(d,0,si

hdu 3342 Legal or Not(拓扑排序)

#include<iostream> #include<cstdio> #include<cstring> #include<vector> #include<queue> using namespace std; int mat[200][200]; int ran[200]; int main() { int n,m; int i,j,k; int f,t; while(scanf("%d%d",&n,&m

HDU 1258 确定比赛名次 &amp;&amp;HDU 3342 Legal or Not 【临接表+拓扑排序】

HDU 1258 链接:click here HDU 3342 链接:click here 题意: 确定比赛名次 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14142    Accepted Submission(s): 5667 Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,