(经典map)A - Hardwood Species(7.1.1)(利用STL中自带的排序功能编程的实验范例)(转)

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
America‘s
temperate climates produce forests with hundreds of hardwood species --
trees that share certain biological characteristics. Although oak, maple
and cherry all are types of hardwood trees, for example, they are
different species. Together, all the hardwood species represent 40
percent of the trees in the United States.

On the other hand,
softwoods, or conifers, from the Latin word meaning "cone-bearing," have
needles. Widely available US softwoods include cedar, fir, hemlock,
pine, redwood, spruce and cypress. In a home, the softwoods are used
primarily as structural lumber such as 2x4s and 2x6s, with some limited
decorative applications.

Using satellite imaging technology, the
Department of Natural Resources has compiled an inventory of every tree
standing on a particular day. You are to compute the total fraction of
the tree population represented by each species.

Input

Input
to your program consists of a list of the species of every tree
observed by the satellite; one tree per line. No species name exceeds 30
characters. There are no more than 10,000 species and no more than
1,000,000 trees.

Output

Print
the name of each species represented in the population, in alphabetical
order, followed by the percentage of the population it represents, to 4
decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

其实在map中,map<int,string> personnel;中的int是一个索引项,就是相当于数组中的下标,用来作为查找的标记

在输入新的字符串时,如果是已经存在的字符串则不再开辟新的空间,就会使用原来的空间,但是没有的话就会在开辟一个索引项为当前输入字符串的空间

可以通过map中的size函数来验证(参考网址  )

其他map函数(网址 )

另外在定义时是否可以通过字符数组来索引还有待验证!!!

#include<iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <map>

using namespace std;

typedef map<string ,int >record;
record h;
string s;
int n;
int main()
{
 n=0;
 while(getline(cin,s))      /////默认为文件结束才输出结果
 {
  n++;
  h[s]++;/////////对当前的int数据加1
 }
 record::iterator it ;////////////////定义map(容器)指针
 for(it=h.begin();it!=h.end();it++)/////////////////////从开始到结束对所有数值进行输出注意  h.begin()是第一个,但h.end()不是最后一个,而是在里面已经没有值了
 {
  string name=it->first;///////////////对该变量的第一个即为字符串

int k=it->second;/////////////////////////////输出对应的数据

printf("%s

%.4lf\n",name.c_str(),double(k)*100/double(n)); ///////////这里
name.c_str()是一个转换函数,因为printf不能输出字符串(string)必须将其转换为char组类型的/////////有待验证!!!!!!!!!!!!!!!!!!


 return 0;
}

(经典map)A - Hardwood Species(7.1.1)(利用STL中自带的排序功能编程的实验范例)(转)

时间: 2024-10-10 16:00:12

(经典map)A - Hardwood Species(7.1.1)(利用STL中自带的排序功能编程的实验范例)(转)的相关文章

Hardwood Species

Hardwood Species(7.1.1)(利用STL中自带的排序功能编程的实验范例) Time Limit:10000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and gener

C++ STL中Map的按Key排序和按Value排序

原文  http://blog.csdn.net/iicy266/article/details/11906189 map是用来存放<key, value>键值对的数据结构,可以很方便快速的根据key查到相应的value.假如存储学生和其成绩(假定不存在重名,当然可以对重名加以区分),我们用map来进行存储就是个不错的选择. 我们这样定义,map<string, int>,其中学生姓名用string类型,作为Key:该学生的成绩用int类型,作为value.这样一来,我们可以根据学

C++ STL中Map的按Key排序跟按Value排序(转)

C++ STL中Map的按Key排序和按Value排序 map是用来存放<key, value>键值对的数据结构,可以很方便快速的根据key查到相应的value.假如存储学生和其成绩(假定不存在重名,当然可以对重名加以区 分),我们用map来进行存储就是个不错的选择. 我们这样定义,map<string, int>,其中学生姓名用string类型,作为Key:该学生的成绩用int类型,作为value.这样一来,我们可以根据学生姓名快速的查找到 他的成绩. 但是,我们除了希望能够查询

[ACM] POJ 2418 Hardwood Species (Trie树或map)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17986   Accepted: 7138 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri

[ACM] POJ 2418 Hardwood Species (Trie树或者map)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17986   Accepted: 7138 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri

POJ 2418 Hardwood Species(字典树 || map运用)

题目链接:http://poj.org/problem?id=2418 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. America's temperate climates produce forests with hundreds of hardwood

POJ 2418 Hardwood Species(STL中map的应用)

题目地址:POJ 2418 通过这个题查了大量资料..知道了很多以前不知道的东西.... 在代码中注释说明吧. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #include <ctype.h> #include <queue&

[字典树] poj 2418 Hardwood Species

题目链接: http://poj.org/problem?id=2418 Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17511   Accepted: 6949 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and gene

POJ 之 Hardwood Species

Hardwood Species Time Limit:10000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. America's te