hdu 1162 Eddy's picture 最小生成树入门题 Prim+Kruskal两种算法AC

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7428    Accepted Submission(s): 3770

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41

只需算出一点到其余各点的距离即可。

Prim算法代码:

#include <stdio.h>
#include <math.h>
#include <string.h>
#define MAX 110
#define INF 1000000000

struct Point{
	double x,y;
};
double graph[MAX][MAX] ;
double prim(int n)
{
	bool visited[MAX];
	memset(visited,false,sizeof(visited));
	double lowcost[MAX] ;
	int closest[MAX] ;
	for(int i = 0 ; i < n ; ++i)
	{
		lowcost[i] = graph[0][i] ;
		closest[i] = 0 ;
	}
	lowcost[0] = 0.0 ;
	visited[0] = false ;
	for(int i = 0 ; i < n ; ++i)
	{
		int min = INF , index = 0 ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && lowcost[j]<min)
			{
				index = j ;
				min = lowcost[j] ;
			}
		}
		visited[index] = true ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && lowcost[j]>graph[index][j])
			{
				lowcost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	double sum = 0.0 ;
	for(int i = 1 ; i < n ; ++i)
	{
		sum += lowcost[i] ;
	}
	return sum ;
}

double distance(const Point &a ,const Point &b)
{
	double x = a.x-b.x , y = a.y-b.y ;
	return sqrt(x*x+y*y);
}

int main()
{
	Point p[MAX];
	int n ;
	while(~scanf("%d",&n))
	{
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%lf%lf",&p[i].x,&p[i].y) ;
		}
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j <= i ; ++j)
			{
				graph[i][j] = graph[j][i] = distance(p[i],p[j]) ;
			}
		}
		double sum = prim(n) ;
		printf("%.2lf\n",sum) ;
	}
	return 0 ;
}

Kruskal算法代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define MAX 110
#define INF 1000000000

using namespace std ;

struct Point{
	double x,y;
};

struct Edge{
	int x , y ;
	double w ;
}edge[MAX*MAX];

bool cmp(const Edge &a ,const Edge &b)
{
	return a.w<b.w ;
}
int f[MAX] ;
void init()
{
	for(int i = 0 ; i < MAX ; ++i)
	{
		f[i] = i ;
	}
}
int find(int x)
{
	int r = x ;
	while(r != f[r])
	{
		r = f[r] ;
	}

	int temp ;
	while(x != f[x])
	{
		temp = f[x] ;
		f[x] = r ;
		x = temp ;
	}
	return r;
}
double kruskal(int m ,int n)
{
	sort(edge,edge+m,cmp) ;
	double lowcost[MAX] ;
	int index = 0 ;
	init() ;
	for(int i = 0 ; i < m ; ++i)
	{
		int fx = find(edge[i].x) , fy = find(edge[i].y) ;
		if(fx != fy)
		{
			lowcost[index++] = edge[i].w ;
			f[fx] = fy ;
		}
	}
	double sum = 0 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		sum += lowcost[i] ;
	}
	return sum ;
}

double dis(const Point &a ,const Point &b)
{
	double x = a.x-b.x , y = a.y-b.y ;
	return sqrt(x*x+y*y);
}

int main()
{
	Point p[MAX];
	int n ;
	while(~scanf("%d",&n))
	{
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%lf%lf",&p[i].x,&p[i].y) ;
		}
		int index = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j <= i ; ++j)
			{
				edge[index].x = i , edge[index].y = j ;
				edge[index].w = dis(p[i],p[j]) ;
				index++ ;
			}
		}
		double sum = kruskal(index , n) ;
		printf("%.2lf\n",sum) ;
	}
	return 0 ;
}

与君共勉

hdu 1162 Eddy's picture 最小生成树入门题 Prim+Kruskal两种算法AC

时间: 2024-10-11 12:58:33

hdu 1162 Eddy's picture 最小生成树入门题 Prim+Kruskal两种算法AC的相关文章

hdu 1863 畅通工程 最小生成树模板入门题 prim+kruskal两种算法AC。

畅通工程 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 18866    Accepted Submission(s): 8012 Problem Description 省政府"畅通工程"的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可).经过调查评估,得到的统计表中列出

hdu 1162 Eddy&#39;s picture(最小生成树算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6866    Accepted Submission(s): 3469 Problem Description Eddy begins to like p

HDU 1162 Eddy&#39;s picture (最小生成树)(java版)

Eddy's picture 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 --每天在线,欢迎留言谈论. 题目大意: 给你N个点,求把这N个点连在一起的最短总距离. 思路: 假设每两两点之间都有路径,求最小生成树. AC代码:(Java) 1 import java.util.Scanner; 2 import java.math.*; 3 public class Main { 4 public static final int MAX

hdu 3371 Connect the Cities Prim + Kruskal两种算法分别AC 水过~~~~

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11727    Accepted Submission(s): 3278 Problem Description In 2100, since the sea level rise, most of the cities disappear. Tho

HDU 1162 Eddy&#39;s picture【最小生成树,Prime算法+Kruskal算法】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9334    Accepted Submission(s): 4711 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

hdu 1162 Eddy&#39;s picture(最小生成树)

Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result i

HDU 1162 Eddy&#39;s picture(图论-最小生成树)

题目如下: Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7267    Accepted Submission(s): 3676 Problem Description Eddy begins to like painting pictures recently ,he is sure of himse

HDU 1162 Eddy&#39;s picture (prime算法_裸题)

Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result i

hdu 1162 Eddy&#39;s picture (Kruskal算法,prim算法,最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 [题目大意] 给你n个点的坐标,让你找到联通n个点的一种方法,保证联通的线路最短,典型的最小生成树问题. 方法一 , 通过不断找到最小的边来找到最终结果. Kruskal 算法 #include <iostream> #include <algorithm> #include <cstdio> #include <cmath> using namespac