POJ 1579-Function Run Fun(内存搜索)

Function Run Fun

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16503   Accepted: 8514

Description

We all love recursion! Don‘t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:

1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:

w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
巨水。。
一開始wa了一组数据 (0,21,21)
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <deque>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ?

(y) : (x) )
using namespace std;
int n,m,dp[22][22][22];
int dfs(int x,int y,int z)
{
	if(x<=0||y<=0||z<=0)
		return 1;
	if(x>20||y>20||z>20)
		return dfs(20,20,20);
	if(dp[x][y][z]!=INF)
		return dp[x][y][z];
	dp[x][y][z]=0;
	if(x<y&&y<z)
		dp[x][y][z]+=(dfs(x,y,z-1)+dfs(x,y-1,z-1)-dfs(x,y-1,z));
	else dp[x][y][z]+=(dfs(x-1,y,z)+dfs(x-1,y-1,z)+dfs(x-1,y,z-1)-dfs(x-1,y-1,z-1));
	return dp[x][y][z];
}
int main()
{
	int a,b,c;
    while(scanf("%d%d%d",&a,&b,&c))
	{
		if(a==-1&&b==-1&&c==-1)break;
		memset(dp,INF,sizeof(dp));
		printf("w(%d, %d, %d) = %d\n",a,b,c,dfs(a,b,c));
	}
	return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

时间: 2024-11-06 07:07:27

POJ 1579-Function Run Fun(内存搜索)的相关文章

POJ 1579 Function Run Fun 【记忆化搜索入门】

题目传送门:http://poj.org/problem?id=1579 Function Run Fun Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 20560   Accepted: 10325 Description We all love recursion! Don't we? Consider a three-parameter recursive function w(a, b, c): if a <=

POJ 1579 Function Run Fun 记忆化搜索

Description We all love recursion! Don't we? Consider a three-parameter recursive function w(a, b, c): if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 1 if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: w(20, 20, 20) if a &

POJ 1579 Function Run Fun

这题时简单的dp题,不过我也就能写写这样简单的题了,不过注意一点. 没什么说的,直接按照题目顺序就可以了. #include<cstdio> #include<iostream> #include<cstring> #include<algorithm> #include<stack> #include<queue> #include<cmath> using namespace std; int dp[21][21][2

POJ 1579 Function Run Fun 记忆化递归

典型的记忆化递归问题. 这类问题的记忆主要是利用数组记忆.那么已经计算过的值就能够直接返回.不须要进一步递归了. 注意:下标越界.递归顺序不能错,及时推断是否已经计算过值了,不要多递归. 或者直接使用动态规划法填好表也是能够的. #include <stdio.h> #include <limits.h> const int MAX_N = 21; int W[MAX_N][MAX_N][MAX_N]; int getValue(int a, int b, int c) { if

poj 1579(动态规划初探之记忆化搜索)

Function Run Fun Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17843   Accepted: 9112 Description We all love recursion! Don't we? Consider a three-parameter recursive function w(a, b, c): if a <= 0 or b <= 0 or c <= 0, then w(a, b

HDU 1331 Function Run Fun (基础记忆化搜索)

Function Run Fun Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2602    Accepted Submission(s): 1263 Problem Description We all love recursion! Don't we? Consider a three-parameter recursive f

POJ1579 Function Run Fun

Function Run Fun Time Limit: 1000ms Memory Limit: 10000KB This problem will be judged on PKU. Original ID: 157964-bit integer IO format: %lld      Java class name: Main We all love recursion! Don't we? Consider a three-parameter recursive function w(

hdu1579 Function Run Fun(深搜+记忆化)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1579 Problem Description We all love recursion! Don't we? Consider a three-parameter recursive function w(a, b, c): if a <= 0 or b <= 0 or c <

解题报告——POJ 1579

Description We all love recursion! Don't we? Consider a three-parameter recursive function w(a, b, c): if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 1 if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: w(20, 20, 20) if a &