Cipher

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They
chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in
the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is
repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and
one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

解题思路:

读了半天才看懂题意,题目不难,但要静下心去理解。题目大意是先给一串数字, 再给一串信息,信息中的每个字符与给的数字相对应,而对应的数字表示的是该字符应该出现在第几个位置。根据数字调整好字符的位置后相当于编码一次。然后让你求编码k次后的信息是怎样的。

这题必须要找出循环的节点。字符在编码m次后一定会回到原来的位置,这就是一个循环。记录一个循环中每个点的位置。编码次数会给的很大。如果不用循环来做,是会超时的。

注意:这题每组数据输出之间要空一行。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int n, k, a[205], m[205][205], huan[205]; //m记录一个循环中每个节点,huan记录每个点多久循环一次
    char mes[205], ans[205];
    while(scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        while(scanf("%d", &k) && k)
        {
            gets(mes);
            for(int i = strlen(mes); i <= n; i++)
                mes[i] = ' ';
            memset(huan, 0, sizeof(huan));
            for(int i = 1; i <= n; i++)
            {
                int temp, j;
                temp = a[i];
                j = 1;
                m[i][j] = temp;
                while(a[temp] != a[i])
                {
                    temp = a[temp];
                    m[i][++j] = temp;  // 记录循环中点的位置
                    huan[i]++;  //只要没有回到原来位置,循环长度加1
                }
                huan[i]++;
            }
            for(int i = 1; i <= n; i++)
            {
                int p, q;
                p = k % huan[i];  // 计算循环后的位置
                if(p)
                    q = m[i][p];
                else
                    q = m[i][huan[i]]; //若能整除说明循环到最后一个
                ans[q - 1] = mes[i];
            }
            ans[n] = '\0';
            printf("%s\n", ans);
        }
        printf("\n");  //每组数据之间要空一行
    }
    return 0;
}

Cipher

时间: 2024-07-29 20:43:48

Cipher的相关文章

Cracking The Vigenere Cipher

In order to crack "Vigenere Cipher" under the circumstance that the key length can be only 3, 4 or 5, I used frequency analysis to find possible keys and compared the Euclidean distance of all candidate keys calculated with "Relative freque

poj 2159 D - Ancient Cipher 文件加密

Ancient Cipher Description Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping

Caesars Cipher

让上帝的归上帝,凯撒的归凯撒. 下面我们来介绍风靡全球的凯撒密码Caesar cipher,又叫移位密码. 移位密码也就是密码中的字母会按照指定的数量来做移位. 一个常见的案例就是ROT13密码,字母会移位13个位置.由'A' ? 'N', 'B' ? 'O',以此类推. 写一个ROT13函数,实现输入加密字符串,输出解密字符串. 所有的字母都是大写,不要转化任何非字母形式的字符(例如:空格,标点符号),遇到这些特殊字符,跳过它们. 这是一些对你有帮助的资源: String.charCodeAt

BZOJ 1031: [JSOI2007]字符加密Cipher 后缀数组

1031: [JSOI2007]字符加密Cipher Time Limit: 10 Sec  Memory Limit: 162 MBSubmit: 6014  Solved: 2503[Submit][Status][Discuss] Description 喜欢钻研问题的JS同学,最近又迷上了对加密方法的思考.一天,他突然想出了一种他认为是终极的加密办法 :把需要加密的信息排成一圈,显然,它们有很多种不同的读法.例如下图,可以读作: JSOI07 SOI07J OI07JS I07JSO 0

【BZOJ】【1031】【JSOI2007】字符加密Cipher

后缀数组 当年感觉好神的题现在好像变水了…… 题意其实有点蛋疼……一开始没看懂<_< 将原串复制一遍接在后面,用后缀数组求一下SA,那么SA<n的就是所找到的那n个字符串,然后把它们的第n个字符抠出来就可以了…… 1 /************************************************************** 2 Problem: 1031 3 User: Tunix 4 Language: C++ 5 Result: Accepted 6 Time:7

POJ1026 Cipher 【polya】

This question is not so difficult. First,my thoughts were we should use a lot of code to find out the loop block,but there is no need to do that . you just need to get every new position of char in the string. Algorithm is also easy , just like how d

java对称加密报错:Input length must be multiple of 8 when decrypting with padded cipher

HTTP Status 500 - Request processing failed; nested exception is javax.crypto.IllegalBlockSizeException: Input length must be multiple of 8 when decrypting with padded cipher org.springframework.web.util.NestedServletException: Request processing fai

【BZOJ-1031】字符加密Cipher 后缀数组

1031: [JSOI2007]字符加密Cipher Time Limit: 10 Sec  Memory Limit: 162 MBSubmit: 5504  Solved: 2277[Submit][Status][Discuss] Description 喜欢钻研问题的JS同学,最近又迷上了对加密方法的思考.一天,他突然想出了一种他认为是终极的加密办法 :把需要加密的信息排成一圈,显然,它们有很多种不同的读法.例如下图,可以读作: JSOI07 SOI07J OI07JS I07JSO 0

iOS 与 Java 服务器之间 SSL 握手失败的解决:Cipher Suites

太阳火神的美丽人生 (http://blog.csdn.net/opengl_es) 本文遵循"署名-非商业用途-保持一致"创作公用协议 转载请保留此句:太阳火神的美丽人生 -  本博客专注于 敏捷开发及移动和物联设备研究:iOS.Android.Html5.Arduino.pcDuino,否则,出自本博客的文章拒绝转载或再转载,谢谢合作. 先挖个坑,有机会填,没机会填也属正常,毕竟地球表面也布满了坑,只不过我们叫盆地或高山而已. Cipher Suites :加密套件?也许这么翻译也

uva--1339 - Ancient Cipher(模拟水体系列)

1339 - Ancient Cipher Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The