1089. Insert or Merge (25)【排序】——PAT (Advanced Level) Practise

题目信息

1089. Insert or Merge (25)

时间限制200 ms

内存限制65536 kB

代码长度限制16000 B

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10

3 1 2 8 7 5 9 4 6 0

1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort

1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10

3 1 2 8 7 5 9 4 0 6

1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort

1 2 3 8 4 5 7 9 0 6

解题思路

单步验证排序方式即可

AC代码

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
vector<int> a, b, c;
void merge_sort(vector<int>& a, int b, int e, int step){
    for (int i = b; i < e; i += step + step){
        inplace_merge(a.begin() + i, a.begin() + min(e, i + step), a.begin() + min(e, i + step + step));
    }
}
void insert_sort(vector<int>& a, int b, int e){
    while (b + 1 < e && a[b] <= a[b + 1]) ++b;
    if (++b < e){
        while (b > 0 && a[b] < a[b - 1]) {
            swap(a[b], a[b - 1]);
            --b;
        }
    }
}
int main()
{
    int n;
    scanf("%d", &n);
    c.resize(n);
    b.resize(n);
    for (int i = 0; i < n; ++i){
        scanf("%d", &c[i]);
    }
    for (int i = 0; i < n; ++i){
        scanf("%d", &b[i]);
    }
    a = c;
    bool flag = false;
    for (int i = 0; i < n; ++i){
        if (a == b){
            printf("Insertion Sort\n");
            insert_sort(a, 0, n);
            flag = true;
            break;
        }
        insert_sort(a, 0, n);
    }
    if (!flag){
        a = c;
        printf("Merge Sort\n");
        for (int step = 1; step <= n; step += step){
            merge_sort(a, 0, n, step);
            if (a == b){
                merge_sort(a, 0, n, step + step);
                break;
            }
        }
    }
    printf("%d", a[0]);
    for (int i = 1; i < n; ++i){
        printf(" %d", a[i]);
    }
    printf("\n");
    return 0;
}
时间: 2024-10-20 00:58:15

1089. Insert or Merge (25)【排序】——PAT (Advanced Level) Practise的相关文章

1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

1093. Count PAT&#39;s (25)【计数】——PAT (Advanced Level) Practise

题目信息 1093. Count PAT's (25) 时间限制120 ms 内存限制65536 kB 代码长度限制16000 B The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th c

PAT 1088 1089. Insert or Merge (25)(排序啊)

题目链接:http://www.patest.cn/contests/pat-a-practise/1089 According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input d

PAT (Advanced Level) 1089. Insert or Merge (25)

简单题.模拟一下即可. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<algorithm> using namespace std; const int maxn=200; int a[maxn],b[maxn],

PAT 1089. Insert or Merge (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li

1062. Talent and Virtue (25)【排序】——PAT (Advanced Level) Practise

题目信息 1062. Talent and Virtue (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding i

1029. Median (25)【排序】——PAT (Advanced Level) Practise

题目信息 1029. Median (25) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17}

1098. Insertion or Heap Sort (25)【排序】——PAT (Advanced Level) Practise

题目信息 1098. Insertion or Heap Sort (25) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one el

1066. Root of AVL Tree (25)【AVL树】——PAT (Advanced Level) Practise

题目信息 1066. Root of AVL Tree (25) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more tha