POJ 1573 Robot Motion【是搜索,就不要纠结是DFS还是BFS】

Robot Motion

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12845   Accepted: 6234

Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source

Mid-Central USA 1999

原题链接:http://poj.org/problem?id=1573

题意:有一个N*M的区域,机器人从第一行的第几列进入,该区域全部由‘N‘ , ‘S‘ , ‘W‘ , ‘E‘ ,走到某个区域的时候只能按照该区域指定的方向进行下一步,问你机器人能否走出该片区域,若不能,输入开始绕圈的步数和圈的大小。

DFS还是BFS对于这题有影响吗?

对,有,BFS 0ms!!DFS 16 ms!!!

搜索我是渣渣,看两份到吗的数据,POJ。

BFS AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
struct node
{
    int x,y;
    node(int x=0,int y=0):x(x),y(y) {};
    //装X的写法
};
char a[15][15];
bool vis[15][15];
int step[15][15];
int n,m,s;
void BFS()
{
    queue<node>q;
    memset(vis,false,sizeof(vis));
    step[0][s-1]=0;
    q.push(node(0,s-1));
    int stepp=-1;
    while(!q.empty())
    {
        node now=q.front();
        q.pop();
        stepp++;
        if(now.x<0||now.x>=n||now.y<0||now.y>=m)
        {
            printf("%d step(s) to exit\n",stepp);
            return ;
        }
        if(vis[now.x][now.y])
        {
            printf("%d step(s) before a loop of %d step(s)\n",step[now.x][now.y],stepp-step[now.x][now.y]);
            return ;
        }
        vis[now.x][now.y]=true;
        step[now.x][now.y]=stepp;
        if(a[now.x][now.y]=='S')
        {
            q.push(node(now.x+1,now.y));
        }
        else if(a[now.x][now.y]=='N')
        {
            q.push(node(now.x-1,now.y));
        }
        else if(a[now.x][now.y]=='W')
        {
            q.push(node(now.x,now.y-1));
        }
        else if(a[now.x][now.y]=='E')
        {
            q.push(node(now.x,now.y+1));
        }
    }
}
int main()
{
    while(cin>>n>>m>>s,n,m,s)
    {
        for(int i=0; i<n; i++)
            cin>>a[i];
        BFS();
    }
    return 0;
}

/**
3 3 1
SWW
SSN
EEN
*/

DFS AC代码:15ms

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[15][15];
bool vis[15][15];
int step[15][15];
int n,m,s,stepp;
void DFS(int x,int y,int t)
{
    stepp++;
    if(x<0||x>=n||y<0||y>=m)
    {
        printf("%d step(s) to exit\n",stepp);
        return ;
    }
    if(vis[x][y])
    {
        printf("%d step(s) before a loop of %d step(s)\n",step[x][y],stepp-step[x][y]);
        return ;
    }
    vis[x][y]=true;
    step[x][y]=stepp;
    int xx,yy;
    if(a[x][y]=='S')
    {
        //x+=1;
        xx=x+1;
        yy=y;
    }
    else if(a[x][y]=='N')
    {
        //x-=1
        xx=x-1;
        yy=y;
    }
    else if(a[x][y]=='W')
    {
        //y-=1;
        xx=x;
        yy=y-1;
    }
    else if(a[x][y]=='E')
    {
        //y+=1;
        xx=x;
        yy=y+1;
    }
    DFS(xx,yy,stepp+1);
}
int main()
{
    while(cin>>n>>m>>s,n,m,s)
    {
        for(int i=0; i<n; i++)
            cin>>a[i];
        stepp=-1;
        memset(vis,false,sizeof(vis));
        DFS(0,s-1,0);
    }
    return 0;
}
时间: 2024-10-21 05:31:43

POJ 1573 Robot Motion【是搜索,就不要纠结是DFS还是BFS】的相关文章

POJ 1573 Robot Motion 搜索

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6297    Accepted Submission(s): 2952 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

POJ 1573 Robot Motion(模拟)

题目代号:POJ 1573 题目链接:http://poj.org/problem?id=1573 Language: Default Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 14195   Accepted: 6827 Description A robot has been programmed to follow the instructions in its path. Instr

poj 1573 Robot Motion

Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down the page) E east (to t

69棋牌游戏源码,POJ 1573 Robot Motion模拟

主题:http://pj.org/Debug ID=1573    主要思想:棋盘上充满了N,E,S,W指令.人们按照棋盘的指示从北方的初始列开始移动,直到你下完棋或四处走动.    N意味着向北(向上)移动.    E意味着向东移动(右).    S意味着向南移动(下).    W意味着向西移动(左).    分析:因为棋盘只有10*10,也就是说最多只有100步,所以您可以使用模拟算法.我们声明一个用于记录指令的字符卡映射,以及一个初始值为零的象棋卡,用于记录所走过的路径.国际象棋棋局或发现

1573 Robot Motion

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10219   Accepted: 4977 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in

Poj OpenJudge 百练 1573 Robot Motion

1.Link: http://poj.org/problem?id=1573 http://bailian.openjudge.cn/practice/1573/ 2.Content: Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10856   Accepted: 5260 Description A robot has been programmed to follow the instru

PKU 1573 Robot Motion(简单模拟)

原题大意:原题链接 给出一个矩阵(矩阵中的元素均为方向英文字母),和人的初始位置,问是否能根据这些英文字母走出矩阵.(因为有可能形成环而走不出去) 此题虽然属于水题,但是完全独立完成而且直接1A还是很开心的 注意:对于形成环的情况则从进入环的交点处重新走一遍,记录步数即可 #include<cstdio> #include<cstring> int n,m,p; bool vis[1010][1010]; char str[1010][1010]; bool can(int x,i

POJ 1573 &amp; POJ 2632(两道有趣的Robot)

题目链接:POJ 1573 Robot Motion & POJ 2632 Crashing Robots [题意]题意就不说了,有兴趣从链接点进去看吧,就是机器人各种打扫房间,行驶指令. [思路]2632是一道纯模拟题,只要把题意读懂,就可以用代码模拟过程,只是写起来有点蛋疼,代码力还是欠缺啊.而1573感觉挺新奇的,我用的DFS来模拟,好久没有写DFS,一开始又把dir数组写错了,结果总是得出0. 下面贴代码,先是2632的AC代码: 1 /* 2 ** POJ 2632 Crashing

POJ 1573:Robot Motion

Robot Motion Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10267   Accepted: 5001 Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in