hdu5024Wang Xifeng's Little Plot(思维|搜索)

题目链接:

huangjing

题意:

从图中任何一个点走,最多只能转90度的弯,并且只能转一次弯,求这个最长路。。

思路:

ym的朝鲜选手的代码,真厉害啊,它是每个点的8个方向都走一遍,然后最后遍历全图,去每个点最多转一次弯的最大长度,这个确实有点厉害,相当于枚举拐点。。还有就是方向最好的按顺序来,因为一个直角正好隔两个方向的位,好运算。。

题目

Wang Xifeng‘s Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 362    Accepted Submission(s): 243

Problem Description

《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original
version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao‘s wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved
a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was
the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn‘t want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu‘s room and Baochai‘s room to be
located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai‘s room, and if there was a turn, that turn must be
ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu‘s room and Baochai‘s room. Now you can solve this
big problem and then become a great redist.

Input

The map of Da Guan Yuan is represented by a matrix of characters ‘.‘ and ‘#‘. A ‘.‘ stands for a part of road, and a ‘#‘ stands for other things which one cannot step onto. When standing on a ‘.‘, one can go to adjacent ‘.‘s through 8 directions: north, north-west,
west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.

Output

For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai‘s rooms. A road‘s length is the number of ‘.‘s it includes. It‘s guaranteed that for any test case, the maximum length is at least 2.

Sample Input

3
#.#
##.
..#
3
...
##.
..#
3
...
###
..#
3
...
##.
...
0

Sample Output

3
4
3
5

Source

2014 ACM/ICPC Asia Regional Guangzhou Online

Recommend

hujie   |   We have carefully selected several similar problems for you:  5041 5040 5039 5037 5036

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<cmath>
#include<string>
#include<queue>
#define eps 1e-9
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=100+10;
char mp[maxn][maxn];
int n;

int step[maxn][maxn][8];

int Dx[]={-1,-1,-1,0,1,1,1,0};
int Dy[]={-1,0,1,1,1,0,-1,-1};

bool is_in(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<n&&mp[x][y]!='#')
        return true;
    return false;
}

int main()
{
   int dx,dy,ans;
   while(~scanf("%d",&n),n)
   {
       for(int i=0;i<n;i++)
         scanf("%s",mp[i]);
       memset(step,0,sizeof(step));
       for(int i=0;i<n;i++)
         for(int j=0;j<n;j++)
            for(int k=0;k<8;k++)
               if(is_in(i,j))
         {
             dx=i,dy=j;
             while(is_in(dx,dy))
             {
                 step[dx][dy][k]++;
                 dx+=Dx[k];
                 dy+=Dy[k];
             }
         }
         ans=-1;
         for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
              for(int k=0;k<8;k++)
                 if(is_in(i,j))
         {
             int xx=(k+2)%8;
             ans=max(ans,step[i][j][k]+step[i][j][xx]-1);
             int yy=(k+6)%8;
             ans=max(ans,step[i][j][k]+step[i][j][yy]-1);
         }
         printf("%d\n",ans);
   }
   return 0;
}

hdu5024Wang Xifeng's Little Plot(思维|搜索)

时间: 2024-08-20 01:56:37

hdu5024Wang Xifeng's Little Plot(思维|搜索)的相关文章

HDU5024Wang Xifeng&#39;s Little Plot(记忆化搜索)

HDU5024Wang Xifeng's Little Plot(记忆化搜索) 题目链接 题目大意:给一张地图,#代表不能走的位置,.代表可以走的位置.现在要求找一条最长的路径,并且拐弯最多只能有一个并且还要是90度的. 解题思路:记忆化搜索,dp[x][y][k][d] : x, y 代表坐标,k代表拐了k次90弯,d代表方向.因为这里最多只能转一次弯,而且还必须是90度的,那么就不可能走重复的路了. 代码: #include <cstdio> #include <cstring>

hdu5024-Wang Xifeng&#39;s Little Plot

此题一开始用暴力做,后来发现斜着走的时候其实暴力不太好写,于是改用搜索写了 1 #include <iostream> 2 #include <stdio.h> 3 #include <memory.h> 4 using namespace std; 5 6 char a[110][110]= {0}; 7 int down[110][110]= {0}; 8 int up[110][110]= {0}; 9 10 int cnt[110][110][4]= {0};

HDU 5024 Wang Xifeng&#39;s Little Plot (搜索)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 157    Accepted Submission(s): 105 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

HDU5024 Wang Xifeng&#39;s Little Plot 【记忆化搜索】

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 319    Accepted Submission(s): 214 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

HDU 5024 Wang Xifeng&#39;s Little Plot (枚举 + DFS记忆化搜索)

Wang Xifeng's Little Plot Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 513    Accepted Submission(s): 338 Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>)

HDU 5024 (广州网络赛) Wang Xifeng&#39;s Little Plot 记忆化搜索+枚举

Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin.

2014 ACM/ICPC Asia Regional Guangzhou Online Wang Xifeng&#39;s Little Plot HDU5024

一道好枚举+模拟题目.转换思维视角 这道题是我做的,规模不大N<=100,以为正常DFS搜索,于是傻乎乎的写了起来.各种条件限制模拟过程 但仔细一分析发现对每个点进行全部八个方向的遍历100X100X100^8 .100X100个点,每个点在走的时候8中选择,TLE 于是改为另一个角度: 以符合要求的点为拐弯点,朝两个垂直的方向走,求出最远的距离.这样只要对每个点各个方向的长度知道,组合一下对应的就OK. 避免了每个点深搜. PS:搜索的时候x,y写反了,导致构图出现问题,以后用[dy][dx]

hdu 5024 Wang Xifeng&#39;s Little Plot【暴力dfs,剪枝】

2014年广州网络赛的C题,也是水题.要你在一个地图中找出一条最长的路,这条路要保证最多只能有一个拐角,且只能为90度 我们直接用深搜,枚举每个起点,每个方向进行dfs,再加上剪枝. 但是如果直接写的话,那一定会特别麻烦,再加上方向这一属性也是我们需要考虑的方面,我们将从别的地方到当前点的方向编一个号:往右为0,如下图顺时针顺序编号 (往右下方向为1,往下为2......以此类推) 我们知道了当前点的坐标,来到当前点的方向,以及到目前有没有拐弯,这几个属性之后,就可以记忆化搜索了,用一个四维数组

HDU - 5024 Wang Xifeng&#39;s Little Plot

Problem Description <Dream of the Red Chamber>(also <The Story of the Stone>) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin.