UVA 116 Unidirectional TSP

  Unidirectional TSP

  Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) — finding whether all the cities in a salesperson’s route can be visited exactly once with a specified limit on travel time — is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

  This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

  Given an m×n matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i + 1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated on the right.

  The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited. For example, two slightly different 5×6 matrices are shown below (the only difference is the numbers in the bottom row).

Input

  The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

Input The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by m · n integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive.

Output

  Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Note: Lexicographically means the natural order on sequences induced by the order on their elements.

Sample Input


5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 8 6 4

5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 1 2 3

2 2

9 10

9 10

Sample Output

1 2 3 4 4 5 16 1 2 1 5 4 5 11 1 1 19

题意:有一个m行n列的整数矩阵,从第一列任何一个位置出发每次向右,右上,右下走一格。要求经过的整数值和最小,整个矩阵是环形的,即第一行的上一行是最后一行,最后一行的下一行是第一行。输出滤镜上梅雷的编号,多解时,输出字典序最小的。

思路:类似于数字三角形,需要倒推。具体实现见代码。

吐槽:我好菜,我好菜,我是机房第一菜。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,dis[11][110],f[11][110],net[11][110];
int main(){
    while(scanf("%d%d",&m,&n)!=EOF){
        memset(f,0,sizeof(f));
        memset(dis,0,sizeof(dis));
        memset(net,0,sizeof(net));
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&dis[i][j]);
        int ans=0x7f7f7f7f,first=0;
        for(int j=n;j>=1;j--)
            for(int i=1;i<=m;i++){
                if(j==n)    f[i][j]=dis[i][j];
                else{
                    int rows[3]={i,i-1,i+1}; //直走,向左上,向右下。
                    if(i==1)    rows[1]=m;//如果是第一行,去最后一行
                    if(i==m)    rows[2]=1;//如果走到最后一行,绕回第一行。
                    sort(rows,rows+3);        //排序,找字典序最小。
                    f[i][j]=0x7f7f7f7f;
                    for(int k=0;k<3;k++){
                        if(f[rows[k]][j+1]+dis[i][j]<f[i][j]){
                            f[i][j]=f[rows[k]][j+1]+dis[i][j];
                            net[i][j]=rows[k];//记录路径
                        }
                    }
                }
                if(j==1&&f[i][j]<ans){
                    ans=f[i][j];
                    first=i;
                }
            }
        printf("%d",first);
        for(int i=net[first][1],j=2;j<=n;i=net[i][j],j++)
            printf(" %d",i);
        printf("\n%d\n",ans);
    }
}
时间: 2024-10-10 20:51:07

UVA 116 Unidirectional TSP的相关文章

uva 116 - Unidirectional TSP (动态规划)

第一次做动规题目,以下均为个人理解以及个人方法,状态转移方程以及状态的定义也是根据个人理解,请过路大神指教. 状态:每一列的每一个数[ i ][ j ]都是一个状态: 然后定义状态[ i ][ j ]的指标函数d[ i ][ j ]为从[ i ][ j ]向右出发的可以得到的最小的整数和: 状态转移方程:d[ i ][ j ]=min(d[ i+1 ][ j+1 ][ i-1 ][ j+1 ][ i ][ j+1 ])+a[ i ][ j ]; 其中a[ i ][ j ]为当前位置的数值: 然后

uva 116 Unidirectional TSP【号码塔+打印路径】

主题: uva 116 Unidirectional TSP 意甲冠军:给定一个矩阵,当前格儿童值三个方向回格最小值和当前的和,就第一列的最小值并打印路径(同样则去字典序最小的). 分析:刚開始想错了,从前往后走,这种话没有办法控制字典序最小,用dfs标记了一下超时了. 事实上从后往前走就好了. 以后一定先想清楚顺序.然后dp的时候选择字典序最小的.用father数据记录就可以. AC代码: #include<iostream> #include<cstdio> #include&

uva 116 Unidirectional TSP (DP)

uva 116 Unidirectional TSP Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Sa

uva 116 Unidirectional TSP【数塔+打印路径】

题目: uva 116 Unidirectional TSP 题意:给出一个矩阵,当前的格子值为后面三个方向的格子最小值和当前的和,就第一列的最小值并打印路径(相同则去字典序最小的). 分析:刚开始想错了,从前往后走,这样的话没有办法控制字典序最小,用dfs标记了一下超时了. 其实从后往前走就好了.以后一定先想清楚顺序,然后dp的时候选择字典序最小的,用father数据记录即可. AC代码: #include<iostream> #include<cstdio> #include&

UVA 116 Unidirectional TSP(DP最短路字典序)

Description  Unidirectional TSP  Background Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Travel

uva 116 Unidirectional TSP 单向TSP 问题,经典dP(路径输出注意规划方向)

Unidirectional TSP Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu Submit Status Practice UVA 116 Appoint description: Description Download as PDF Background Problems that require minimum paths through some domain appear in many differ

UVa 116 Unidirectional TSP(DP)

题意  一个n*m的环形矩阵(第一行和最后一行是相邻的)  从第一列任意位置出发  只能往右上,右,右下3个方向走  求走到第m列经过的的最小数字和 基础DP  横着的数塔问题 #include <bits/stdc++.h> #define l(x) d[x][j+1] using namespace std; const int N = 105; int n, m, g[N][N], d[N][N], fol[N][N]; int main() { int n, m, u, b, t, k

UVA - 116 - Unidirectional TSP (简单DP + 打印路径)

题目传送:UVA - 116 思路:可以定义状态为dp[i][j] 为从第i行第j列开始往后走到第n列(总共n列)的最小值(赋初始值为无穷),且状态方程很好推出来:dp[i][j] = a[i][j] + max(dp[i-1][j+1], dp[i][j+1], dp[i+1][j+1]);    最后最优解  ans = max(dp[i][1])(1<=i<=m); 不过这题难点不在这里,而是可能有多组最小值,输出字典序最小的那组: 这里要注意好递推的方向,只能从右往左递推列数,而如果从

uva 116 Unidirectional TSP dp + 打印路径

// uva116 Unidirectional TSP // 这题是在紫书(page 270)上看到的,个人理解就是数塔的升级版 // dp[i][j]表示从(i,j)出发到终点所达到的最大价值 // 所以很明显j是逆序的 // 状态转移方程为 // dp[i][j] = min(dp[i][j],dp[row[k]][j+1]+mp[i][j]) // rows[k]表示三行中的一行i,i-1,i+1,特判一下,排个序 // (因为多解时输出字典序最小的值) // 这题唯一比较难的地方就是打