HDU1027 Ignatius and the Princess II 【next_permutation】【DFS】

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4571    Accepted Submission(s): 2733

Problem Description

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if
you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once
in this problem). So it‘s easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It‘s easy, isn‘t is? Hahahahaha......"

Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub‘s demand. The input is terminated by the end of
file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub‘s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

Author

Ignatius.L

题意:求数列1~n的第m个全排列。

题解:用STL里的next_permutation和DFS都可解,但时间复杂度就相去甚远了。

STL:耗时31ms

#include <cstdio>
#include <algorithm>
using namespace std;

int arr[1002];

int main()
{
    int n, m, i;
    while(scanf("%d%d", &n, &m) != EOF){
        for(i = 0; i < n; ++i)
            arr[i] = i + 1;
        while(--m) next_permutation(arr, arr + n);
        for(i = 0; i < n; ++i)
            if(i != n - 1) printf("%d ", arr[i]);
            else printf("%d\n", arr[i]);
    }
    return 0;
}

DFS:耗时390ms

#include <stdio.h>
#include <string.h>
#define maxn 1002

int vis[maxn], n, m, arr[maxn], count, ok;

void PRINT()
{
    for(int i = 1; i <= n; ++i)
        if(i != n) printf("%d ", arr[i]);
        else printf("%d\n", arr[i]);
}

void DFS(int k)
{
    if(k > n) return;
    for(int i = 1; i <= n; ++i){
        if(!vis[i]){
            vis[i] = 1; arr[k] = i;
            if(k == n && m == ++count){
                PRINT(); ok = 1; return;
            }
            DFS(k + 1); vis[i] = 0;
            if(ok) return;
        }
    }
}

int main()
{
    while(scanf("%d%d", &n, &m) != EOF){
        memset(vis, 0, sizeof(vis));
        ok = count = 0; DFS(1);
    }
    return 0;
}

时间: 2024-08-03 04:46:55

HDU1027 Ignatius and the Princess II 【next_permutation】【DFS】的相关文章

HDU1027 Ignatius and the Princess II【全排列】

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11536 Accepted Submission(s): 6640 Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens

hdu1027 Ignatius and the Princess II 全排列

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1027 Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now

HDOJ 1027 Ignatius and the Princess II - next_permutation函数

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5447    Accepted Submission(s): 3198 Problem Description Now our hero finds the door to the BEelzebub feng5166. He o

ACM-简单题之Ignatius and the Princess II——hdu1027

转载请注明出处:http://blog.csdn.net/lttree Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4436    Accepted Submission(s): 2642 Problem Description Now our hero finds the

HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9458    Accepted Submission(s): 5532 Problem Description Now our hero finds the door to the BEelzebub feng5166. He op

hdoj 1027 Ignatius and the Princess II 【逆康托展开】

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4865    Accepted Submission(s): 2929 Problem Description Now our hero finds the door to the BEelzebub feng5166. He o

ACM-简单的主题Ignatius and the Princess II——hdu1027

转载请注明出处:http://blog.csdn.net/lttree Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4436    Accepted Submission(s): 2642 Problem Description Now our hero finds the

(全排列)Ignatius and the Princess II -- HDU -- 1027

链接: http://acm.hdu.edu.cn/showproblem.php?pid=1027 Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5822    Accepted Submission(s): 3433 Problem Description Now our h

HDU 1027 Ignatius and the Princess II(求第m个全排列)

传送门: http://acm.hdu.edu.cn/showproblem.php?pid=1027 Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10388    Accepted Submission(s): 5978 Problem Description Now our