给定四种水果,分别是苹果(apple)、梨(pear)、桔子(orange)、葡萄(grape),单价分别对应为3.00元/公斤、2.50元/公斤、4.10元/公斤、10.20元/公斤。
首先在屏幕上显示以下菜单:
[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
用户可以输入编号1~4查询对应水果的单价。当连续查询次数超过5次时,程序应自动退出查询;不到5次而用户输入0即退出;输入其他编号,显示价格为0。
输入格式:
输入在一行中给出用户连续输入的若干个编号。
输出格式:
首先在屏幕上显示菜单。然后对应用户的每个输入,在一行中按格式“price = 价格”输出查询结果,其中价格保留两位小数。当用户连续查询次数超过5次、或主动输入0时,程序结束。
输入样例1:
3 -1 0 2
输出样例1:
[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 4.10
price = 0.00
输入样例2:
1 2 3 3 4 4 5 6 7 8
输出样例2:
[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 3.00
price = 2.50
price = 4.10
price = 4.10
price = 10.20
1 # 查询水果价格 2 # Author: cnRick 3 # Time : 2020-3-29 4 exit_count = 0 5 find_index = 0 6 fruits_price = (0,3.00,2.50,4.10,10.20) #分别对应苹果、梨、桔子、葡萄的价格 7 print("[1] apple\n[2] pear\n[3] orange\n[4] grape\n[0] exit") 8 nums = list(map(int,input().split())) 9 while True: 10 thisNum = nums[find_index] 11 find_index += 1 12 if(0 <= thisNum <= 4): 13 if(thisNum == 0): 14 break 15 else: 16 print("price = {:.2f}".format(fruits_price[thisNum])) 17 exit_count += 1 18 else: 19 print("price = 0.00") 20 exit_count += 1 21 if exit_count == 5 or find_index >= len(nums): 22 break 23
原文地址:https://www.cnblogs.com/dreamcoding/p/12591399.html
时间: 2024-10-13 21:07:01