Moving Tables
Time
Limit: 2000/1000 MS (Java/Others) Memory Limit:
65536/32768 K (Java/Others)
Total Submission(s):
18319 Accepted Submission(s):
6268
Problem Description
The famous ACM (Advanced Computer Maker) Company has
rented a floor of a building whose shape is in the following figure.
The floor
has 200 rooms each on the north side and south side along the corridor.
Recently the Company made a plan to reform its system. The reform includes
moving a lot of tables between rooms. Because the corridor is narrow and all
the tables are big, only one table can pass through the corridor. Some plan is
needed to make the moving efficient. The manager figured out the following
plan: Moving a table from a room to another room can be done within 10 minutes.
When moving a table from room i to room j, the part of the corridor between the
front of room i and the front of room j is used. So, during each 10 minutes,
several moving between two rooms not sharing the same part of the corridor will
be done simultaneously. To make it clear the manager illustrated the possible
cases and impossible cases of simultaneous moving.
For
each room, at most one table will be either moved in or moved out. Now, the
manager seeks out a method to minimize the time to move all the tables. Your
job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of
test cases ) (T is given in the first line of the input. Each test case begins
with a line containing an integer N , 1<=N<=200 , that represents the
number of tables to move. Each of the following N lines contains two positive
integers s and t, representing that a table is to move from room number s to
room number t (each room number appears at most once in the N lines). From the
N+3-rd line, the remaining test cases are listed in the same manner as
above.
Output
The output should contain the minimum time in minutes
to complete the moving, one per line.
Sample Input
3 4 10 20 30 40 50
60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
Sample Output
10 20 30
【题目来源】
Asia
2001, Taejon (South Korea)
题目意思很容易理解,这里就不过多说了。
【题目分析】
贪心算法,我看很多人用区间标记的方法写了一百多行,其实根本不用,直接就统计排序就行,不仅好理解,而且代码也很精简。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cnt[200];
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int T,n,a,b,l,r;
scanf("%d",&T);
while(T--)
{
memset(cnt,0,sizeof(cnt));
scanf("%d",&n);
for(int i=0;i<n;++i)
{
scanf("%d%d",&a,&b);
l=min(a,b);
r=max(a,b);
l=(l+1)/2;
r=(r+1)/2;
for(int j=l;j<=r;++j)
cnt[j]++;
}
sort(cnt,cnt+200,cmp);
printf("%d\n",cnt[0]*10);
}
return 0;
}
贪心 --- 巧妙解法