poj 2485 Highways(最小生成树)

题目链接:http://poj.org/problem?id=2485

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:[email protected]

题意:

寻找最小生成树图中最长的路径!

POJ 1258一样的,加个判断条件就可以了!

但是注意这题用memset 初始化visited会WA, 用for循环就不会了!POJ 1258 则不存在这个问题!

代码如下:

#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
#define MAXN 517
//创建m二维数组储存图表,low数组记录每2个点间最小权值,visited数组标记某点是否已访问
int m[MAXN][MAXN], low[MAXN], visited[MAXN];
int n;
int prim( )
{
    int i, j;
    int maxx = 0;
    int pos, minn, result=0;
    // memset(visited,0,sizeof(visited));
    for(i = 1; i <= n; i++)
        visited[i] = 0;
    visited[1] = 1;
    pos = 1;          //从某点开始,分别标记和记录该点
    for(i = 1; i <= n; i++)     //第一次给low数组赋值
    {
        if(i != pos)
            low[i] = m[pos][i];
        else
            low[i] = 0;
    }
    for(i = 1; i < n; i++) //再运行n-1次
    {
        minn = INF;   //找出最小权值并记录位置
        for(j = 1; j <= n; j++)
        {
            if(visited[j]==0 && minn>low[j])
            {
                minn = low[j];
                pos = j;
            }
        }
        // result += minn;   //最小权值累加
        if(minn > maxx)
            maxx = minn;
        visited[pos] = 1;   //标记该点
        for(j = 1; j <= n; j++)   //更新权值
            if(visited[j]==0 && low[j]>m[pos][j])
                low[j] = m[pos][j];
    }
    //return result;
    return maxx;
}
int main()
{
    int i,j,ans;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(m,INF,sizeof(m));   //所有权值初始化为最大
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                scanf("%d",&m[i][j]);
            }
        }
        ans = prim( );
        printf("%d\n",ans);
    }
    return 0;
}

poj 2485 Highways(最小生成树),布布扣,bubuko.com

时间: 2024-10-13 03:05:28

poj 2485 Highways(最小生成树)的相关文章

POJ 2485 Highways 最小生成树 (Kruskal)

Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that i

POJ 2485 Highways(最小生成树+ 输出该最小生成树里的最长的边权)

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 23426   Accepted: 10829 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl

POJ 2485 Highways (最小生成树prim)

题目大意:    有一个岛国,没有高速公路,交通非常困难.政府意识到了这一问题,他们计划建造一些高速公路,这样可以使任何一对城镇都不离开公路系统.所有公路都是沿直线建造并且是双向的.政府想降低花费,所以想找到一种建造方案,能连接所有的城镇,并且公路的总长度最小.注意题目求的是最小生成树最长的那条边. #include <cstdio> #include <cstring> #include <algorithm> #define N 600 #define INF 0x

poj 2485 Highways

链接:poj 2485 题意:输入n个城镇相互之间的距离,输出将n个城镇连通费用最小的方案中修的最长的路的长度 这个也是最小生成树的题,只不过要求的不是最小价值,而是最小生成树中的最大权值,只需要加个判断 比较最小生成树每条边的大小就行 #include<cstdio> #include<algorithm> using namespace std; int f[510],n,m; struct stu { int a,b,c; }t[20100]; int cmp(struct

POJ 2485 Highways &amp;&amp; HDU1102(20/200)

题目链接:Highways 没看题,看了输入输出,就有种似曾相识的感觉,果然和HDU1102 题相似度99%,但是也遇到一坑 cin输入竟然TLE,cin的缓存不至于这么狠吧,题目很水,矩阵已经告诉你了,就敲个模板就是了,5分钟,1A 题意就是打印,最小生成树的最大边权,改了改输入,水过 这个题完了,我的个人POJ计划进度以完成 20/200,这其中主要是图论的题,等下周把POJ计划图论的题目打完,就回头打模拟!我就不信还能比图论难 #include <iostream> #include &

poj 2485(prim最小生成树)

Highways Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways

POJ 2485 Highways (kruskal 最小生成树)

Highways POJ 2485so that it will be possible to drive between any pair of towns without leaving the highway system. Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways ca

poj 2485 Highways (最小生成树)

链接:poj 2485 题意:输入n个城镇相互之间的距离,输出将n个城镇连通费用最小的方案中修的最长的路的长度 这个也是最小生成树的题,仅仅只是要求的不是最小价值,而是最小生成树中的最大权值.仅仅须要加个推断 比較最小生成树每条边的大小即可 kruskal算法 #include<cstdio> #include<algorithm> using namespace std; int f[510],n,m; struct stu { int a,b,c; }t[20100]; int

POJ 2485 Highways【最小生成树最大边,Prime算法】

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 28592   Accepted: 13037 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl