- Oil Deposits 深搜,就是所谓的dfs

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output

0 1 2 2

代码:

#include<iostream>
#include<string.h>
#include<stdlib.h>
#include<stdio.h>
char map[105][105];
int m,n;
using namespace std; 

void DFS(int i,int j)
{
    if(map[i][j]==‘@‘)
    {
        map[i][j]=‘*‘;
        if(i-1>0&&map[i-1][j]==‘@‘)
            DFS(i-1,j);
        if(i+1<=m&&map[i+1][j]==‘@‘)
            DFS(i+1,j);
        if(j-1>0&&map[i][j-1]==‘@‘)
            DFS(i,j-1);
        if(j+1<=n&&map[i][j+1]==‘@‘)
            DFS(i,j+1);
        if(i-1>0&&j-1>0&&map[i-1][j-1]==‘@‘)
            DFS(i-1,j-1);
        if(i-1>0&&j+1<=n&&map[i-1][j+1]==‘@‘)
            DFS(i-1,j+1);
        if(i+1<=m&&j-1>0&&map[i+1][j-1]==‘@‘)
            DFS(i+1,j-1);
        if(i+1<=m&&j+1<=n&&map[i+1][j+1]==‘@‘)
            DFS(i+1,j+1);
    }
} 

int main()
{
    int i,j,count;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        count=0;
        if(m==0)
            break;
        for(i=1;i<=m;++i)
        {
            for(j=1;j<=n;++j)
            {
                cin>>map[i][j];
            }
        }
        for(i=1;i<=m;++i)
        {
            for(j=1;j<=n;++j)
            {
                if(map[i][j]==‘@‘)
                {
                    count++;
                    DFS(i,j);
                }
            }
        }
        cout<<count<<endl;
    }
    return 0;
}
//Oil Deposits
#include <iostream>
#include <stdio.h>
using namespace std;

char map[101][101];
int n, m, sum;

void dfs(int i, int j)
{
    //若该点不可行或越界,返回
    if(map[i][j]!=‘@‘ || i<0 || j<0 || i>=m || j>=n) return;
    else    //否则,标记该点为不可行,再往8个方向深搜
    {
        map[i][j] = ‘!‘;
        dfs(i-1, j-1);
        dfs(i-1, j);
        dfs(i-1, j+1);
        dfs(i, j-1);
        dfs(i, j+1);
        dfs(i+1, j-1);
        dfs(i+1, j);
        dfs(i+1, j+1);
    }
}

int main()
{
    int i, j;
    while(cin>>m>>n)
    {
        if(m==0 || n==0) break;
        sum = 0;
        for(i = 0; i < m; i++)
            for(j = 0; j < n; j++)
                cin>>map[i][j];
        for(i = 0; i < m; i++)
        {
            for(j = 0; j < n; j++)
            {
                if(map[i][j] == ‘@‘)
                {
                    dfs(i, j);
                    sum++;
                }
            }
        }
        cout<<sum<<endl;
    }

    return 0;
}

- Oil Deposits 深搜,就是所谓的dfs,布布扣,bubuko.com

时间: 2024-08-09 22:00:11

- Oil Deposits 深搜,就是所谓的dfs的相关文章

poj1562 Oil Deposits(深搜dfs)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://poj.org/problem?id=1562 ---------------------------------------------------------------------------------------------------------------------------------------------------------- 欢

PKU 1562/HDU 1241 Oil Deposits(原油有多少块区域---BFS,DFS)

Oil Deposits Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region o

HDU_1241 Oil Deposits(DFS深搜)

Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square pl

hdu 1241 Oil Deposits(八方向简单深搜,对新手挺经典)

Oil Deposits Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12461 Accepted Submission(s): 7245 Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground

poj1562 Oil Deposits(简单的深搜)

Oil Deposits Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 14391   Accepted: 7823 Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular r

不撞南墙不回头———深度优先搜索(DFS)Oil Deposits

Oil Deposits Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 23018    Accepted Submission(s): 13272 Problem Description The GeoSurvComp geologic survey company is responsible for detecting under

HDOJ/HDU 1241 Oil Deposits(经典DFS)

Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square pl

UVA572 Oil Deposits【DFS】

Oil Deposits The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It

UVa 572 - Oil Deposits【图DFS】

Oil Deposits The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It