HDU-3714 Error Curves(凸函数求极值)

Error Curves

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6241    Accepted Submission(s): 2341

Problem Description

Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm‘s efficiency, she collects many datasets.
What‘s more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset‘s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

It‘s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function‘s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it‘s too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

题目的意思就是给出多个开口向上的一元二次方程,求出极大值的最小值,抛物线肯定是凸函数,直接三分就行了

#pragma GCC diagnostic error "-std=c++11"
#include<bits/stdc++.h>
#define _ ios_base::sync_whit_stdio(0);cin.tie(0);

using namespace std;
const int N = 10000 + 5;
const int INF = (1<<30);
const double eps = 1e-8;

double a[N], b[N], c[N];
int n;

double fun(double x){
    double res = - INF;
    for(int i = 0; i < n; i++)
        res = max(res, a[i] * x * x + b[i] * x + c[i]);
    return res;
}

double ternary_search(double L, double R){
    double mid1, mid2;
    while(R - L > eps){
        mid1 = (2 * L + R) / 3;
        mid2 = (L + 2 * R) / 3;
        if(fun(mid1) >= fun(mid2)) L = mid1;
        else R = mid2;
    }
    return (L + R) * 0.5;
}

int main(){
    int T;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        for(int i = 0; i < n; i++){
            scanf("%lf %lf %lf", &a[i], &b[i], &c[i]);
        }
        double x = ternary_search(0, 1000);
        printf("%.4f\n", fun(x));
    }
}
时间: 2024-08-02 02:50:36

HDU-3714 Error Curves(凸函数求极值)的相关文章

HDU 3714 Error Curves

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3714 Error Curves Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 4536    Accepted Submission(s): 1721 Problem Description Josephina is a clever g

LA 5009 (HDU 3714) Error Curves (三分)

A - Error Curves Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu SubmitStatusPracticeUVALive 5009 Appoint description: Description Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a

hdu 3714 Error Curves(三分)

Error Curves Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1198    Accepted Submission(s): 460 Problem Description Josephina is a clever girl and addicted to Machine Learning recently. She pa

HDU 3714 Error Curves(3分)

题意  求分段函数的最低点  每个点函数值为n个 a*x^2 + b*x +c (a>=0, |b|<5000, |c|<5000) 函数的最大值 由于a是不小于0的   所以此分段函数的函数图像只可能是类似'V'形的  可以画图观察出来  那么求最小值就可以用三分来解决了 #include <bits/stdc++.h> using namespace std; const int N = 10005; const double eps = 1e-9; int a[N],

三分 HDOJ 3714 Error Curves

题目传送门 1 /* 2 三分:凹(凸)函数求极值 3 */ 4 #include <cstdio> 5 #include <algorithm> 6 #include <cstring> 7 #include <cmath> 8 using namespace std; 9 10 const int MAXN = 1e4 + 10; 11 const int INF = 0x3f3f3f3f; 12 const double EPS = 0.0000000

HDU-4717 The Moving Points(凸函数求极值)

The Moving Points Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2122    Accepted Submission(s): 884 Problem Description There are N points in total. Every point moves in certain direction and

Error Curves HDU - 3714

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm's efficiency, she collects many datas

三分法求凸函数的极值

作者:jostree 转载请注明出处 http://www.cnblogs.com/jostree/p/4397990.html 在机器学习中,求凸函数的极值是一个常见的问题,常见的方法如梯度下降法,牛顿法等,今天我们介绍一种三分法来求一个凸函数的极值问题. 对于如下图的一个凸函数$f(x),x\in [left,right]$,其中lm和rm分别为区间[left,right]的三等分点,我们发现如果f(lm)<f(rm),那么函数值最小的点的横坐标x一定在[left,rm]之间.如果x在[rm

UVA 1476 - Error Curves(三分法)

UVA 1476 1476 - Error Curves 题目链接 题意:给几条下凹二次函数曲线,然后问[0,1000]所有位置中,每个位置的值为曲线中最大值的值,问所有位置的最小值是多少 思路:三分法,由于都是下凹函数,所以所有曲线合并起来,仍然是一个下凹函数,满足单峰,用三分求极值 代码: #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> using na