hdu 1664 Different Digits

Different Digits

Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1138    Accepted Submission(s): 296

Problem Description

Given a positive integer n, your task is to find a positive integer m, which is a multiple of n, and that m contains the least number of different digits when represented in decimal. For example, number 1334 contains three different
digits 1, 3 and 4.

Input

The input consists of no more than 50 test cases. Each test case has only one line, which contains a positive integer n ( 1<=n < 65536). There are no blank lines between cases. A line with a single `0‘ terminates the input.

Output

For each test case, you should output one line, which contains m. If there are several possible results, you should output the smallest one. Do not output blank lines between cases.

Sample Input

7
15
16
101
0

Sample Output

7
555
16
1111

题意:告诉一个数n,求一个他的倍数m,使得m由最少的不同数字组成。

思路:对于任意一个n,都可以找到一个他的倍数,并且这个倍数只有最多2种不同的数字组成。所以,可以分成1种和2种讨论下。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;

struct Node
{
    int mod;
    string ans;
}f,t;

int n;
string ans,tmp;
int num[2];
int vis[70000];

int bfs1()
{
    int flag=0;
    for(int i=1;i<=9;i++)
    {
        f.mod=i%n;
        f.ans="";
        f.ans+=i+'0';

        while(f.ans.size()<n && f.mod!=0)
        {
            f.ans+=i+'0';
            f.mod=(f.mod*10+i)%n;
        }
        if(f.mod==0)
        {
            if(flag==0) {tmp=f.ans;flag=1;}
            else if(f.ans.size()<tmp.size()) tmp=f.ans;
            else if(f.ans.size()==tmp.size() && f.ans<tmp) tmp=f.ans;
        }
    }
    if(flag) {ans=tmp;return 1;}
    else return 0;
}

void bfs2()
{
    memset(vis,0,sizeof vis);
    queue<Node>q;

    for(int i=0;i<2;i++)
    {
        if(num[i]==0) continue;
        f.mod=num[i]%n;
        f.ans="";
        f.ans+=num[i]+'0';
        vis[f.mod]=1;
        q.push(f);
    }

    int flag=0;

    while(!q.empty())
    {
        f=q.front();
        q.pop();

        if(flag)
        {
            if(f.mod==0)
            {
                if(tmp.size()>f.ans.size()) {tmp=f.ans;continue;}
                else if(tmp.size()==f.ans.size() && tmp>f.ans) {tmp=f.ans;continue;}
            }

        }
        else if(f.mod==0)
        {
            flag=1;
            tmp=f.ans;
            continue;
        }

        for(int i=0;i<2;i++)
        {
            t=f;
            t.ans+=num[i]+'0';
            t.mod=(f.mod*10+num[i])%n;
            if(vis[t.mod]) continue;
            vis[t.mod]=1;
            q.push(t);
        }

    }

    if(ans=="") ans=tmp;
    else if(ans.size()>tmp.size()) ans=tmp;
    else if(ans.size()==tmp.size() && ans>tmp) ans=tmp;

}

int main()
{
    while(scanf("%d",&n),n)
    {
        ans="";

        if(bfs1());
        else
        {
            for(int i=0;i<9;i++)
                for(int j=i+1;j<=9;j++)
                {
                    num[0]=i;num[1]=j;
                    bfs2();
                }
        }
        cout<<ans<<endl;
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-10 01:34:46

hdu 1664 Different Digits的相关文章

hdu 1664 Different Digits, spoj 3929 , 同余,bfs

Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 820    Accepted Submission(s): 202 Problem Description Given a positive integer n, your task is to find a positive integer m, which is a multiple

HDU 4333 Revolving Digits 扩展KMP

链接:http://acm.hdu.edu.cn/showproblem.php?pid=4333 题意:给以数字字符串,移动最后若干位到最前边,统计得到的数字有多少比原来大,有多少和原来相同,有多少比原来的小. 思路:拓展KMP中的next数组标记的是子串和母串的公共前缀的长度,要将字符串长度变成原来二倍,这样如果变换后不是完全相同的数字也即公共前缀长度大于等于字符串长度,那么字母串公共前缀的下一位的大小比较就是题目所要求的比较.由于相同的数字串只算一次,则只要统计比较第一个"循环节"

扩展KMP,附上例题(HDU - 4333 Revolving Digits)

给出模板串S和串T,长度分别为Slen和Tlen,在线性时间内,对于每个S[i](0<=i<Slen),求出S[i..Slen-1]与T的 最长公共前缀长度,记为extend[i],extend[i]存放s[i]开始与T的最长公共前缀长度. 例子 a a a a a a a b b b a a a a a c extend 5 4 3 2 1 0 0 0 0 0 HDU - 4333 Revolving Digits Time Limit: 3000/1000 MS (Java/Others)

扩展KMP - HDU 4333 Revolving Digits

Revolving Digits Problem's Link: http://acm.hdu.edu.cn/showproblem.php?pid=4333 Mean: 给你一个字符串,你可以将该字符串的任意长度后缀截取下来然后接到最前面,让你统计所有新串中有多少种字典序小于.等于.大于原串. analyse: KMP的经典题. 首先我们将原串扩展成两倍,算一遍扩展KMP(自匹配),时间复杂度O(n). 这样一来,我们就得到了eKMP[i],eKMP[i]代表s[i...len-1]与s的最长

hdu 4333 Revolving Digits

Revolving Digits http://acm.hdu.edu.cn/showproblem.php?pid=4333 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Problem Description One day Silence is interested in revolving the digits of a positive integer. In th

hdu 1664(数论+同余搜索+记录路径)

Different Digits Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1430    Accepted Submission(s): 392 Problem Description Given a positive integer n, your task is to find a positive integer m, w

【扩展kmp+最小循环节】HDU 4333 Revolving Digits

http://acm.hdu.edu.cn/showproblem.php?pid=4333 [题意] 给定一个数字<=10^100000,每次将该数的第一位放到放到最后一位,求所有组成的不同的数比原数小的个数,相等的个数,大的个数 [思路] 这个数很大,用字符串处理 比较两个字符串的大小,一位一位很耗时,可以求出最长公共前缀,只比较最长公共前缀后一位 每次将数的最后一位放到最后一位,如abcd变成dabc,cdab,bcda,相当于abcdabcd各个后缀的前四位 这样就变成了求abcdabc

字符串(扩展KMP):HDU 4333 Revolving Digits

Revolving Digits Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24729    Accepted Submission(s): 5381 Problem Description One day Silence is interested in revolving the digits of a positive int

HDU - 4333 Revolving Digits(拓展kmp+最小循环节)

1.给一个数字字符串s,可以把它的最后一个字符放到最前面变为另一个数字,直到又变为原来的s.求这个过程中比原来的数字小的.相等的.大的数字各有多少. 例如:字符串123,变换过程:123 -> 312 -> 231 -> 123 因为:312>123, 231>123, 123=123 所以答案是:0 1 2 2.令str1=s,str2=s+s,然后str1作为子串,str2作为主串,进行扩展kmp求出str2[i...len2-1]与str1[0...len1-1]的最长