Bungee Jumping[HDU1155]

Bungee Jumping
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1205 Accepted Submission(s): 528

Problem Description
Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

Unfortunately, he had not had enough time to calculate whether the bungee rope has the right length, so it is not clear at all what is going to happen when he jumps off the bridge. There are three possible scenarios:
The rope is too short (or too strong), and James Bond will never reach the ground.
The rope is too long (or too weak), and James Bond will be going too fast when he touches the ground. Even for a special agent, this can be very dangerous. You may assume that if he collides at a speed of more than 10 m/s, he will not survive the impact.
The rope‘s length and strength are good. James Bond touches the ground at a comfortable speed and can escape.
As his employer, you would like to know whether James Bond survives or whether you should place a job ad for the soon-to-be vacant position in the local newspaper. Your physicists claim that:
The force with which James is pulled towards the earth is
9.81 * w,
where w is his weight in kilograms and 9.81 is the Earth acceleration in meters over squared seconds.
Mr. Bond falls freely until the rope tautens. Then the force with which the bungee rope pulls him back into the sky depends on the current length of the rope and is
k * Δl,
where Δl is the difference between the rope‘s current length and its nominal, unexpanded length, and k is a rope-specific constant.
Given the rope‘s strength k, the nominal length of the rope l in meters, the height of the bridge s in meters, and James Bond‘s body weight w, you have to determine what is going to happen to our hero. For all your calculations, you may assume that James Bond is a point at the end of the rope and the rope has no mass. You may further assume that k, l, s, and w are non-negative and that s < 200.

The input contains several test cases, one test case per line. Each test case consists of four floating-point numbers (k, l, s, and w) that describe the situation. Depending on what is going to happen, your program must print "Stuck in the air.", "Killed by the impact.", or "James Bond survives.". Input is terminated by a line containing four 0s, this line should not be processed.

Sample Input
350 20 30 75
375 20 30 75
400 20 30 75
425 20 30 75
450 20 30 75
400 20 30 50
400 20 30 80
400 20 30 85
0 0 0 0

Sample Output
Killed by the impact.
James Bond survives.
James Bond survives.
James Bond survives.
Stuck in the air.
Stuck in the air.
James Bond survives.
Killed by the impact.

#include<stdio.h>
#include<string.h>
#define g 9.81
int main()
{
    double k,s,l,w;
    double e1,e2,e3;
    while(scanf("%lf%lf%lf%lf",&k,&l,&s,&w)!=-1)
    {
        if(!k&&!l&&!s&&!w)break;
        e1=0.5*w*100;
        e2=w*s*g;
        e3=0.5*k*(s-l)*(s-l);
        if(l>s)
        {
            if(e2>e1)printf("Killed by the impact.\n");
            else printf("James Bond survives.\n");
        }
        else
        {
            if(e2<e3)printf("Stuck in the air.\n");
            else if(e2-e3>e1)printf("Killed by the impact.\n");
            else printf("James Bond survives.\n");
        }
    }
    return 0;
}

时间: 2024-10-05 04:48:42

Bungee Jumping[HDU1155]的相关文章

Bungee Jumping POJ - 2463

Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge,

(简单的物理题)Bungee Jumping

链接: http://acm.hdu.edu.cn/showproblem.php?pid=1155 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 793    Accepted Submission(s): 342 Problem Description Once again, James Bond is fleeing from s

杭电 1155 Bungee Jumping(物理题)

Problem Description Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the

HDU 1155 Bungee Jumping(纯物理题)

Problem Description: Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the

Bungee Jumping hdu 1155(物理)

http://acm.hdu.edu.cn/showproblem.php?pid=1155 题意:给出一个人蹦极的高度,绳子的长度,绳子的弹力系数,以及他自身体重.问你他是停留在空中还是安全落地还是速度过大撞死了(V>10). 分析:一年不学物理,物理真成渣了.不过百度看的解析,公式好熟悉啊... mgh=k*x*x/2+m*v*v/2(x为形变量) #include <iostream> #include <stdio.h> #include <string.h&g

HDU 1155 Bungee Jumping 物理

题目大意:给出k:绳子的劲度系数,l:绳长,s:桥高,w:邦德的质量,g取9.81.绳子弹力=形变量*劲度系数.如果落地速度大于10 则摔死,小于0则飘着空中. 题目思路:根据能量守恒得知:落地的动能=重力势能减少量-绳子弹力做功.如果l>s,则绳子不做功. #include<cstdio> #include<stdio.h> #include<cstdlib> #include<cmath> #include<iostream> #inc

UVa 10868 (物理) Bungee Jumping

题意: 有个人在蹦极,给出悬崖的高度,绳子的长度,弹簧绳的胡克系数 以及 人的质量. 判断人是否能够着地,能的话是否能安全着地.所谓安全着地就是到达地面的速度不超过10m/s. 分析: 学过一点高中物理的就应该能解出来吧,既然是题解还是本着详细具体的原则来写. 首先要求人能下落的最大高度,也就是重力做的功全部转化为弹簧绳的弹性势能. ,解出Δl: 那么人能下落的最大高度就是l + Δl 如果人能落地,还要看绳长l与悬崖高度s的关系 l>=s,则重力做的功全部转换为动能,,解得 l<s,重力做的

HDU 1155 Bungee Jumping

题意:英语水平太次…………读了好久好久好久才读懂OTZ James Bond要逃跑,跑到一个桥边上,要跳到地面,桥边有个有弹性的绳子长度为l,如果他跳下去能到达地面,但速度超过10就会摔死,否则能成功降落,如果不能到达地面则被吊在绳子上(吐槽:为什么不看接近地面就直接跳下去= =).桥的高度为s,人的重力为w × 9.81,绳的弹力为k × Δl. 解法:一个物理题……物理太渣算了好久……首先看绳长是不是比桥的高度长,如果绳更长则这个人一定会接触地,则在他接触地的时候没有弹力的作用,列出式子:1

What can I learn right now in just 10 minutes that could be useful for the rest of my life?

1. Primacy and recency : People most remember the first and last things to occur, and barely the middle. When scheduling an interview, ask what times the employer is interviewing and try to be first or last. 2. If you work in a bar or in customer ser