[poj] Catch That Cow--bfs

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

三个搜索方向 +1, -1, *2  用bfs搜索 数组要开到最大值的2倍 注意剪枝和边界问题

#include <iostream>
#include <stdio.h>
#include <queue>
#include <cstring>
using namespace std;

const int Max = 210000;
int s, e;
struct node
{
    int x, step;
}now, Next;
bool v[210000];
queue<node>q;

int bfs()
{
    now.x = s;
    now.step = 0;
    v[s] = 1;
    q.push(now);
    while (!q.empty()) {
        now = q.front();
        q.pop();
        if (now.x == e)
            return now.step;

        Next.x = now.x*2;
        Next.step = now.step+1;
        if (Next.x >= 0 && Next.x <= Max && !v[Next.x]){
            q.push(Next);
            v[Next.x] = 1;
        }

        Next.x = now.x-1;
        Next.step = now.step+1;
        if (Next.x >= 0 && Next.x <= Max && !v[Next.x]){
            q.push(Next);  //若先检查v[Next.x] 会出现数组越界v[-1]的情况
            v[Next.x] = 1;
        }

        Next.x = now.x+1;
        Next.step = now.step+1;
        if (Next.x >= 0 && Next.x <= Max && !v[Next.x]){
            q.push(Next);
            v[Next.x] = 1;
        }

    }
    return 0;
}

int main()
{
    //freopen("1.txt", "r", stdin);
    cin >> s >> e;
    memset(v, 0, sizeof(v));
    cout << bfs();

    return 0;
}
时间: 2024-10-06 12:44:57

[poj] Catch That Cow--bfs的相关文章

[ACM] hdu 2717 Catch That Cow (BFS)

Catch That Cow Problem Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same

POJ 3278 Catch That Cow(BFS,板子题)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 88732   Accepted: 27795 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

POJ 3275 Catch That Cow(bfs)

Catch That Cow Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number

poj 3278 Catch That Cow (bfs搜索)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 46715   Accepted: 14673 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

poj 3278 catch that cow BFS(基础水)

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 61826   Accepted: 19329 Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,00

HDU 2717 Catch That Cow(bfs)

Catch That Cow Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 10575    Accepted Submission(s): 3303 Problem Description Farmer John has been informed of the location of a fugitive cow and want

Catch That Cow BFS求线性双向最短路径

Catch That Cow Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer

HDU2717 Catch That Cow ( BFS )

Catch That Cow Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a

POJ 3278 Catch That Cow(bfs)

题意:给定n,k两个数,三种操作,加一,减一,乘2,求n到k的最少步数: 思路:广搜求最少步数: #include<cstdio> #include<cstring> #include<algorithm> using namespace std; int n,m; int q[500010]; int num[500010]; int bfs() { int b=0,e=0; q[e++]=n; if(n==m) return 0; while(b<e) { i

POJ 3278 Catch That Cow(BFS基础)

题目大意: 给你两个数字,n和k,对于n有三种变化规则. 1.n->n-1; 2.n->n+1; 3.n->2*n; 使得n==k,问如何需要最少的操作次数. 解题思路: 凡是有关最少操作次数的问题,就归结为bfs来求解,这道题是一个三入口式的bfs... 在搜索的过程中,一定要注意是否有需要剪纸的必要,不然蛮力上的话,必然会导致RE. 代码: # include<cstdio> # include<iostream> # include<algorithm