[并查集] POJ 1611 The Suspects

The Suspects

Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 35206   Accepted: 17097

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

原题大意:对于两个整数N,M,N表示有N个人,M表示被分成了多少组。0号有传染病,和他一组的人都有嫌疑得传染病,对于每组数据,问有多少人有嫌疑。

解题思路:裸的并查集,可以用于练习模板。

#include<stdio.h>
#include<string.h>
int father[30050],n;
void init()
  {
  	 int i;
  	 memset(father,-1,sizeof(father));
  	 for(i=0;i<n;++i) father[i]=i;
  }
int find(int x)
  {
  	 if(x==father[x]) return (x);
  	 else father[x]=find(father[x]);
  	 return (father[x]);
  }
void merge(int x,int y)
  {
  	 if(find(x)!=find(y)) father[find(x)]=find(y);
  }
int main()
  {
  	 int m,i,qnum,x,pre,ans;
  	 while(~scanf("%d%d",&n,&m))
  	   {
  	   	  if(n==0&&m==0) break;
  	   	  init();
  	   	  while(m--)
  	   	    {
  	   	      scanf("%d",&qnum);
  	   	      scanf("%d",&pre);
  	   	      for(i=1;i<qnum;++i)
  	   	        {
  	   	          scanf("%d",&x);
  	   	          merge(x,pre);
				}
			}
		  ans=0;
		  for(i=0;i<n;++i) if(find(i)==find(0)) ++ans;
		  printf("%d\n",ans);
	   }
  	 return 0;
  }

  

时间: 2024-10-11 16:58:00

[并查集] POJ 1611 The Suspects的相关文章

POJ 1611 The Suspects(并查集)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 22296   Accepted: 10842 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ 1611 The Suspects(特别无语的并查集)

很简单的一道题目,开始用的是并查集的分离集合森林做,不知道怎么的特别不稳定,太奇怪了,WA无数次,无奈之下改成一维数组了..sad AC #include <iostream> #include <cstdio> #include <cstdlib> #include <cstring> #include <algorithm> #include <math.h> #define PI acos(-1,0) using namespa

[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 21586   Accepted: 10456 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

poj 1611:The Suspects(并查集,经典题)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 21472   Accepted: 10393 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

Catenyms+欧拉回路/欧拉路+并查集+POJ

Catenyms Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9617   Accepted: 2524 Description A catenym is a pair of words separated by a period such that the last letter of the first word is the same as the last letter of the second. For e

POJ 1611 The Suspects (并查集+数组记录子孙个数 )

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 24134   Accepted: 11787 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ 1611 The Suspects (并查集求数量)

Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In t

poj 1611 The Suspects 【并查集】

The Suspects Time Limit: 1000MS Memory Limit: 20000K Total Submissions: 24570 Accepted: 12033 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To mi

poj 1611 :The Suspects经典的并查集题目

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.   In the Not-Spr