3-4 计算长方形的周长和面积

Time Limit: 1000MS Memory limit: 65536K

题目描写叙述

通过本题的练习能够掌握拷贝构造函数的定义和用法。

设计一个长方形类Rect。计算长方形的周长与面积。

类中有私有数据成员Length(长)、Width(宽),由具有缺省參数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形參为对象的常引用,函数原型为:Rect(const Rect &); 编写主函数,创建Rect对象r1初始化为长、宽数据,利用r1初始化还有一个Rect对象r2。分别输出对象的长和宽、周长和面积。

要求: 创建对象 Rect r1(3.0,2.0),r2(r1);

输入

输入两个实数,中间用一个空格间隔。代表长方形的长和宽

输出

共同拥有6行

分别输出r1的长和宽。
r1的周长;
r1的面积;r2的长和宽。
r2的周长。
r2的面积;注意单词与单词之间用一个空格间隔

演示样例输入

56 32

演示样例输出

the length and width of r1 is:56,32
the perimeter of r1 is:176
the area of r1 is:1792
the length and width of r2 is:56,32
the perimeter of r2 is:176
the area of r2 is:1792

提示

输入
-7.0 -8.0

输出

the length and width of r1 is:0,0

the perimeter of r1 is:0

the area of r1 is:0

the length and width of r2 is:0,0

the perimeter of r2 is:0

the area of r2 is:0

来源

黄晶晶

演示样例程序

#include <iostream>
using namespace std;
class Rect
{
private:
    double len;
    double wid;
public:
    Rect(double x=0,double y=0);
    Rect(const Rect &b);
    const void display()
    {
        cout << "the length and width of r1 is:" << len << ","<< wid << endl;
        cout << "the perimeter of r1 is:" << (len + wid) * 2<<endl;
        cout << "the area of r1 is:" << len * wid << endl;
    }
    const void display1()
    {
        cout << "the length and width of r2 is:" << len << ',' << wid<< endl;
        cout << "the perimeter of r2 is:" << (len + wid) * 2 << endl;
        cout << "the area of r2 is:" << len * wid << endl;
    }
};
Rect::Rect(double x,double y)
{
    len=x;
    wid=y;
}
Rect::Rect(const Rect &b)
{
    len=b.len;
    wid=b.wid;
}
int main()
{
    double x,y;
    cin>>x>>y;
    if(x<0||y<0)
    {
        x=0;
        y=0;

    }
    Rect rect(x,y);
    Rect rect1=rect;
    rect.display();
    rect1.display1();
    return 0;
}



时间: 2024-11-02 23:39:48

3-4 计算长方形的周长和面积的相关文章

创建一个三角形类并且通过成员函数计算三角形的周长和面积《1》

首先定义一个三角形类 class Triangle//三角形类 { public: double getA(void);//得到a的值 double getB(void);//得到b的值 double getC(void);//得到c的值 void setA(double x);//设置a的值 void setB(double y);//设置b的值 void setC(double z);//设置c的值 bool isTriangle(void);//取三边的值 double Perimeter

创建一个三角形类并且使用成员函数计算三角形的周长和面积《2》

首先创建一个三角形类 class Triangle//三角形类 { public: void Setabc(double x, double y, double z);//置三边的值,注意要能成三角形 void Getabc(double *x, double *y, double *z);//取三边的值 double Perimeter(void);//计算三角形的周长 double Area(void);//计算并返回三角形的面积 private: double a, b, c; //三边为

使用JavaBean计算圆的周长与面积

创建名称为"radiusInput.jsp"的页面文件,该页面文件将实现提示用户输入圆半径的功能,主要代码如下: <body> <form id="form1" name="form1" method="post" action="circle.jsp"> 请输入圆的半径: <input name="radius" type="text"

计算三角形的周长以及面积

using System; using System.Collections.Generic; using System.Linq; using System.Text; namespace S { class Program { static void Main() { Program p = new Program(); p.a(); } public void a() { Double[] a=new Double[6]; for (int i = 0; i < 6; i++) { if(

计算圆的周长和面积(VB)

输入半径,计算圆周长和圆面积(保留小数点后两位小数) 进一步要求,为了保证程序运行正确,对输入的半径要进行合法性检查.数据输入结束有两种方法, 分别编事件过程对数据进行检验: 1:按Tab键,检查数据的合法性,利用TextBox1_LostFocus事件. 2:按回车键,当TextBox1_KeyPress事件中的返回参数e.KeyChar的ASC()值为13时表示输入结束. Public Class Form1 Private Sub TextBox1_KeyPress(ByVal sende

sdut 3-4 长方形的周长和面积计算

3-4 长方形的周长和面积计算 Time Limit: 1000MS Memory limit: 65536K 标题叙述性说明 通过本题的练习能够掌握拷贝构造函数的定义和用法: 设计一个长方形类Rect.计算长方形的周长与面积. 类中有私有数据成员Length(长).Width(宽).由具有缺省參数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形參为对象的常引用.函数原型为:Rect(const Rect

PHP图形计算器(计算三角形矩形周长面积)

运用PHP面向对象的知识设计一个图形计算器,同时也运用到了抽象类知识,这个计算器可以计算三角形的周长和面积以及矩形的周长和面积.本图形计算器有4个页面:1.PHP图形计算器主页index.php;    2.形状的抽象类shape.class.php;    3三角形计算类triangle.class.php;    4.矩形计算类rect.class.php. PHP图形计算器代码点击下载:   php图形计算器.zip 代码分别如下: PHP图形计算器主页: 1 2 3 4 5 6 7 8

【DTOJ】1001:长方形周长和面积

DTOJ 1001:长方形周长和面积  解题报告 --由翱翔的逗比w原创 题目信息: 题目描述 已知长方形的长和宽,求长方形的周长和面积? 输入 一行:空格隔开的两个整数,表示长和宽 输出 一行:长方形的周长和面积,中间用空格隔开. 样例输入 3 4 样例输出 14 12 提示 周长为:2*(a+b),面积为:a*b 思路: 定义整型变量a,b并输入,定义整型变量周长c=2*(a+b)和面积s=a*b,输出c和s,注意c和s之间有空格. 我的代码(C++): 1 //DTOJ 1001 2 #i

定义一个长方形类,定义 求周长和面积的方法实例

/* 定义一个长方形类,定义 求周长和面积的方法, 然后定义一个测试了Test2,进行测试. 长方形的类: 成员变量: 长,宽 成员方法: 求周长:(长+宽)*2; 求面积:长*宽 注意: import必须出现在所有的class前面.*/ import java.util.Scanner; class ChangFangXing { //长方形的长 private int length; //长方形的宽 private int width; public ChangFangXing(){} //