(hdu step 7.2.1)The Euler function(欧拉函数模板题——求phi[a]到phi[b]的和)

题目:

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 166 Accepted Submission(s): 96
 

Problem Description

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)


Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).


Output

Output the result of (a)+ (a+1)+....+ (b)


Sample Input

3 100


Sample Output

3042

 

Source

2009 Multi-University Training Contest 1 - Host by TJU


Recommend

gaojie

题目分析:

欧拉函数,简单题。

直接暴力这道题就能过。。。。下面简介一下欧拉函数的一些知识。

1、定义:对于正整数n,φ(n)是小于或等于n的正整数中,与n互质的数的数目。

    比如:φ(8)=4。由于1。3,5,7均和8互质。

2、性质:1)若p是质数。φ(p)= p-1.

   2)若n是质数p的k次幂,φ(n)=(p-1)*p^(k-1)。由于除了p的倍数都与n互质

   3)欧拉函数是积性函数,若m,n互质,φ(mn)= φ(m)φ(n).

  依据这3条性质我们就能够推出一个整数的欧拉函数的公式。由于一个数总能够写成一些质数的乘积的形式。

  E(k)=(p1-1)(p2-1)...(pi-1)*(p1^(a1-1))(p2^(a2-1))...(pi^(ai-1))

    = k*(p1-1)(p2-1)...(pi-1)/(p1*p2*...*pi)

    = k*(1-1/p1)*(1-1/p2)...(1-1/pk)

在程序中利用欧拉函数例如以下性质,能够高速求出欧拉函数的值(a为N的质因素)

  若( N%a ==0&&(N/a)%a ==0)则有:E(N)= E(N/a)*a;

  若( N%a ==0&&(N/a)%a !=0)则有:E(N)= E(N/a)*(a-1);

代码例如以下:

/*
 * a1.cpp
 *
 *  Created on: 2015年3月19日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 3000001;

int phi[maxn];

/**
 * 初始化欧拉数组.
 * phi[8]: 表示从1~8与8互质的元素的个数
 *
 */
void prepare(){
	int i;
	for(i = 1 ; i < maxn ; ++i){
		phi[i] = i;
	}

	int j;
	for(i = 2 ; i < maxn ; ++i){
		if(phi[i] == i){
			for(j = i ; j < maxn ; j += i){
				phi[j] = phi[j]/i*(i-1);
			}
		}
	}
}

int main(){
	prepare();
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF){
		long long ans = 0;
		int i;
		for(i = a ; i <= b ; ++i){//暴力求phi[a]到phi[b]之间的和
			ans += phi[i];
		}

		printf("%lld\n",ans);
	}

	return 0;
}

下面贴一个TLE了的版本号:

TLE的原因非常仅仅管,由于每次算phi[i],它都掉了一次phi()。运算量太大。

/*
 * POJ_2407.cpp
 *
 *  Created on: 2013年11月19日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

typedef long long ll;

const int maxn = 1000015;

bool u[maxn];
ll su[maxn];
ll num;

ll gcd(ll a, ll b) {
	if (b == 0) {
		return a;
	}

	return gcd(b, a % b);
}

void prepare() {//欧拉筛法产生素数表
	ll i, j;
	memset(u, true, sizeof(u));

	for (i = 2; i <= 1000010; ++i) {
		if (u[i]) {
			su[++num] = i;
		}

		for (j = 1; j <= num; ++j) {
			if (i * su[j] > 1000010) {
				break;
			}

			u[i * su[j]] = false;

			if (i % su[j] == 0) {
				break;
			}
		}
	}
}

ll phi(ll x) {//欧拉函数,用于求[1,x)中与x互质的整数的个数
	ll ans = 1;
	int i, j, k;
	for (i = 1; i <= num; ++i) {
		if (x % su[i] == 0) {
			j = 0;
			while (x % su[i] == 0) {
				++j;
				x /= su[i];
			}

			for (k = 1; k < j; ++k) {
				ans = ans * su[i] % 1000000007ll;
			}
			ans = ans * (su[i] - 1) % 1000000007ll;
			if (x == 1) {
				break;
			}
		}
	}

	if (x > 1) {
		ans = ans * (x - 1) % 1000000007ll;
	}

	return ans;
}

int main(){

	prepare();

	long long a;
	long long b;
	while(scanf("%lld%lld",&a,&b)!=EOF){
		long long ans = 0;
		long long i;
		for(i = a ; i <= b ; ++i){
			ans += phi(i);
		}

		printf("%lld\n",ans);
	}

	return 0;
}
时间: 2024-09-29 15:35:45

(hdu step 7.2.1)The Euler function(欧拉函数模板题——求phi[a]到phi[b]的和)的相关文章

hdu2824 The Euler function 筛选法求欧拉函数模板题

//求a , b范围内的所有的欧拉函数 //筛选法求欧拉函数模板题 #include<cstdio> #include<cstring> #include<iostream> using namespace std ; const int maxn = 3000010 ; typedef __int64 ll ; int e[maxn] ; int a ,  b ; void Euler() { int i,j; for (i=1;i<maxn;i++) e[i]

hdu 2824 The Euler function 欧拉函数打表

The Euler function Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are sm

hdu-2824 The Euler function(欧拉函数)

题目链接: The Euler function Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4987    Accepted Submission(s): 2098 Problem Description The Euler function phi is an important kind of function in numb

(hdu step 2.1.6)找新朋友(欧拉函数的简单使用:求与n互质的元素的个数)

题目: 找新朋友 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2788 Accepted Submission(s): 1307   Problem Description 新年快到了,"猪头帮协会"准备搞一个聚会,已经知道现有会员N人,把会员从1到N编号,其中会长的号码是N号,凡是和会长是老朋友的,那么该会员的号码肯定和N有大

HDU 1286 找新朋友(欧拉函数模板)

HDU 1286 找新朋友 题意:中文题. 思路:欧拉函数的纯模板题,没什么好说的,主要是理解欧拉函数的意义. 在数论,对正整数n,欧拉函数是少于或等于n的数中与n互质的数的数目.此函数以其首名研究者欧拉命名,它又称为Euler's totient function.φ函数.欧拉商数等. 例如φ(8)=4,因为1,3,5,7均和8互质.   ----by度娘. #include <stdio.h> int eular(int n){ int ret = 1; for(int i = 2; i*

hdu-5597 GTW likes function(欧拉函数+找规律)

题目链接: GTW likes function Time Limit: 4000/2000 MS (Java/Others)     Memory Limit: 131072/131072 K (Java/Others) Problem Description Now you are given two definitions as follows. f(x)=∑xk=0(−1)k22x−2kCk2x−k+1,f0(x)=f(x),fn(x)=f(fn−1(x))(n≥1) Note that

hdu 3307(欧拉函数+好题)

Description has only two Sentences Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1071    Accepted Submission(s): 323 Problem Description an = X*an-1 + Y and Y mod (X-1) = 0.Your task is to cal

HDU 4983 Goffi and GCD(欧拉函数模板)

Problem Description: Goffi is doing his math homework and he finds an equality on his text book: gcd(n−a,n)×gcd(n−b,n)=n^k. Goffi wants to know the number of (a,b) satisfy the equality, if n and k are given and 1≤a,b≤n. Note: gcd(a,b) means greatest

hdu 1395 2^x mod n = 1(欧拉函数)

2^x mod n = 1 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 18742    Accepted Submission(s): 5860 Problem Description Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1. Inp