POJ 2488:A Knight's Journey

A Knight‘s Journey

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 29241   Accepted: 10027

Description

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

这个道题超级坑,要注意字典数。

int dx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};

int dy[8] = {-1, 1, -2, 2, -2, 2, -1, 1};

它仅仅能按字典序顺序定义。。

还有就是每一轮输出后要加一个换行。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 100 + 5;
int chess[M][M];
int h[M];
int l[M];
int dx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int dy[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int a, b;
int ok;

void dfs(int x, int y, int ans)
{
    h[ans]=x;
    l[ans]=y;
    if(ans==a*b)
    {
        ok=1;
        return ;
    }
    for(int i=0; i<8; i++)
    {
        int tx = x + dx[i];
        int ty = y + dy[i];
        if(tx>=1 && tx<=b && ty>=1 && ty<=a && chess[tx][ty]==0 && ok==0)
        {
            chess[tx][ty] = 1;
            dfs(tx, ty, ans+1);
            chess[tx][ty] = 0;
        }
    }
}
int main()
{
    int n;
    scanf("%d", &n);
    for(int cas=1; cas<=n; cas++)
    {
        ok=0;
        memset(chess, 0, sizeof(chess));
        memset(h, 0, sizeof(h));
        memset(l, 0, sizeof(l));
        scanf("%d%d", &a, &b);
        chess[1][1] = 1;
        dfs(1, 1, 1);
        printf("Scenario #%d:\n", cas);
        if(ok==1)
        {
            for(int i=1; i<=a*b; i++)
                printf("%c%d", h[i]+‘A‘-1, l[i]);
            printf("\n");
        }
        else
            printf("impossible\n");
        printf("\n");
    }

    return 0;
}

POJ 2488:A Knight's Journey

时间: 2024-10-25 14:49:38

POJ 2488:A Knight&#39;s Journey的相关文章

POJ 2488 A Knight&#39;s Journey

A Knight's Journey Time Limit: 1000ms Memory Limit: 65536KB This problem will be judged on PKU. Original ID: 248864-bit integer IO format: %lld      Java class name: Main Background  The knight is getting bored of seeing the same black and white squa

dfs/poj 2488 A Knight&#39;s Journey

1 #include<cstdio> 2 using namespace std; 3 const int b[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}}; 4 int a[30][30],p,q; 5 struct 6 { 7 int x,y; 8 }step[910]; 9 10 bool dfs(int x,int y,int now) 11 { 12 if (now==p*q) return true;

POJ 2488 A Knight&#39;s Journey (DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 30656   Accepted: 10498 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ 2488 A Knight&#39;s Journey _BFS

1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <algorithm> 5 #define CL(x, y) memset(x, y, sizeof(x)) 6 using namespace std; 7 const int MAX = 28; 8 int N, a, b, flag; 9 int chessboard[MAX*MAX], used[MAX]

POJ 2488 -- A Knight&#39;s Journey(骑士游历)

POJ 2488 -- A Knight's Journey(骑士游历) 题意: 给出一个国际棋盘的大小,判断马能否不重复的走过所有格,并记录下其中按字典序排列的第一种路径. 经典的"骑士游历"问题 输入:第一行,整数n,接下来是n行,每一行为p和q,p为行数,q为列数,p用1...p编号,q用A...Q编号 马的走法:每步棋先横走或直走一格,然后再往外斜走一格;或者先斜走一格,最后再往外横走或竖走一格(即走"日"字).可以越子,没有中国象棋中的"蹩马腿&

poj 2488 A Knight&#39;s Journey(dfs+字典序路径输出)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://poj.org/problem?id=2488 ---------------------------------------------------------------------------------------------------------------------------------------------------------- 欢

POJ 2488 A Knight&#39;s Journey 递归回溯题解

简单的递归回溯法,锻炼基本的编程能力. 这类题是对代码能力的要求比对思想的要求高点. 而且要审题,题目要求安lexicographically 顺序输出,不小心递归的顺序就会输出错误了. 棋盘是由数字列或者行,和字母列或者行组成的,故此输出结果要注意. 个人觉得我的递归回溯写法是非常清晰, 工整的,O(∩_∩)O哈哈~ #include <stdio.h> #include <string.h> const int MAX_N = 27; bool board[MAX_N][MAX

poj 2488 A Knight&#39;s Journey (DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 34660   Accepted: 11827 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

搜索 || DFS || POJ 2488 A Knight&#39;s Journey

给一个矩形棋盘,每次走日字,问能否不重复的走完棋盘的每个点,并将路径按字典序输出 *解法:按字典序输出路径,因此方向向量的数组按字典序写顺序,dfs+回溯,注意flag退出递归的判断,并且用pre记录路径 #include <iostream> #include <cstdio> #include <cstring> using namespace std; char a[30][30]; int dx[] = {-2, -2, -1, -1, 1, 1, 2, 2};