C - Highways poj1751最小生成树

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can‘t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3第一次接触不给权值的最小生成树问题,处理方法和原来一样。。题目大意:首先输入有N个城市,然后按照城市顺序输入城市的坐标。最后输出的是需要在哪两个城市之间添加一下路径,这个题目还有个坑就是,输出的结果,对顺序没有要求。就是即便把1  3  输出成了3 1 也无所谓的
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int N= 1E6+10;
int pre[N];
struct stu{
    int a,b;
    int x;
}p[N],pp[N];

bool cmp(stu x1,stu y1){
    if(x1.x!=y1.x)
        return x1.x<y1.x;
    else if(x1.a!=y1.a){
        return x1.a<y1.a;
    }
    return x1.b<y1.b;
} 

int find(int x){
    if(x==pre[x]) return x;
    return pre[x]=find(pre[x]);
}
void join(int x,int y){
    int fx=find(x),fy=find(y);
    if(fx!=fy){
        pre[fx]=fy;
    }
}

int main(){
    int n;
    cin>>n;

    for(int i=1;i<=n;i++){
        pre[i]=i;
    }

    for(int i=1;i<=n;i++){
        scanf("%d%d",&p[i].a,&p[i].b);
    }

    int pos=0;
    for(int i=1;i<n;i++){
        for(int j=i+1;j<=n;j++){
            pp[pos].a=i;//i号城市
            pp[pos].b=j;//j号城市
            pp[pos].x=(p[i].a-p[j].a)*(p[i].a-p[j].a)+(p[i].b-p[j].b)*(p[i].b-p[j].b);//i号城市到j号城市的距离
            pos++;
        }
    }
    sort(pp,pp+pos,cmp);
    int m;
    cin>>m;
    int xx,yy;
    for(int j=1;j<=m;j++) {
        scanf("%d%d",&xx,&yy);
        join(xx,yy);
    }
    for(int i=0;i<pos;i++){
        int fx=find(pp[i].a);
        int fy=find(pp[i].b);
        if(fx!=fy){
            pre[fx]=fy;
            cout<<pp[i].a<<" "<<pp[i].b<<endl;
        }
    }
    return 0;
} 


原文地址:https://www.cnblogs.com/Accepting/p/11310795.html

时间: 2024-10-23 06:38:03

C - Highways poj1751最小生成树的相关文章

Highways POJ-1751 最小生成树 Prim算法

Highways POJ-1751 最小生成树 Prim算法 题意 有一个N个城市M条路的无向图,给你N个城市的坐标,然后现在该无向图已经有M条边了,问你还需要添加总长为多少的边能使得该无向图连通.输出需要添加边的两端点编号即可. 解题思路 这个可以使用最短路里面的Prim算法来实现,对于已经连接的城市,处理方式是令这两个城市之间的距离等于0即可. prim算法可以实现我们具体的路径输出,Kruskal算法暂时还不大会. 代码实现 #include<cstdio> #include<cs

poj 2485 Highways(最小生成树)

题目链接:http://poj.org/problem?id=2485 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're plann

POJ 2485 Highways (求最小生成树中最大的边)

Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that i

POJ 2485:Highways(最小生成树&amp;&amp;prim)

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 21628   Accepted: 9970 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fla

POJ 2485 Highways【最小生成树最大边,Prime算法】

Highways Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 28592   Accepted: 13037 Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Fl

POJ 1751 Highways【最小生成树+输出路径】

Highways Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 12385 Accepted: 3576 Special Judge Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian gover

POJ 1751 Highways (Kruskal 最小生成树)

Highways Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 9654   Accepted: 2725   Special Judge Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian

poj 2485 Highways (最小生成树)

链接:poj 2485 题意:输入n个城镇相互之间的距离,输出将n个城镇连通费用最小的方案中修的最长的路的长度 这个也是最小生成树的题,仅仅只是要求的不是最小价值,而是最小生成树中的最大权值.仅仅须要加个推断 比較最小生成树每条边的大小即可 kruskal算法 #include<cstdio> #include<algorithm> using namespace std; int f[510],n,m; struct stu { int a,b,c; }t[20100]; int

POJ 2485 Highways (prim最小生成树)

对于终于生成的最小生成树中最长边所连接的两点来说 不存在更短的边使得该两点以不论什么方式联通 对于本题来说 最小生成树中的最长边的边长就是使整个图联通的最长边的边长 由此可知仅仅要对给出城市所抽象出的图做一次最小生成树 去树上的最长边就可以 #include<bits/stdc++.h> using namespace std; int T,n,a,dist[1020],m[1020][1020]; void prim() { bool p[1020]; for(int i=2;i<=n