codechef Birthday Candles 题解

Birthday Candles

The chef is preparing a birthday cake for one of his guests,

and his decided to write the age of the guest in candles on the cake.

There are 10 types of candles, one for each of the digits ‘0‘ through ‘9‘.

The chef has forgotten the age of the guest, however, so doesn‘t know whether he has enough candles of the right types.

For example, if the guest were 101 years old, the chef would need two ‘1‘ candles and one ‘0‘ candle.

Given the candles the chef has, your task is to determine the smallest positive integer that cannot be represented with those candles.

Input:

Input will begin with an integer T≤100, the number of test cases.

Each test case consists of a single line with exactly 10 integers, each between 0 and 8, inclusive.

The first integer of each test case represents the number of ‘0‘ candles the chef has,

the second integer represents the number of ‘1‘ candles the chef has, and so on.

Output:

For each test case, output on a single line the smallest positive integer that cannot be expressed with the given candles.

Sample input:

3
2 1 1 4 0 6 3 2 2 2
0 1 1 1 1 1 1 1 1 1
2 2 1 2 1 1 3 1 1 1
 

Sample output:

4
10
22

最小不能凑出来的数字组合。

仔细想想我们是如何使用0到9的一个数字组合出千千万万个数值的。

注意特殊情况: 零缺小的时候

#pragma once
#include <stdio.h>

int BirthdayCandles()
{
	static const int CANDLES = 10;
	int T;
	scanf("%d", &T);
	while (T--)
	{
		int A[CANDLES] = {0}, minCan = (1<<30), minId = 0;
		for (int i = 0; i < CANDLES; i++)
		{
			scanf("%d", &A[i]);
			if (minCan > A[i])
			{
				minCan = A[i];
				minId = i;
			}
		}
		if (0 == minId)
		{
			for (int i = CANDLES - 1; i > 0 ; i--)//注意有数等于0数的时候
			{
				if (minCan >= A[i])
				{
					minCan = A[i];
					minId = i;
				}
			}
			if (0 == minId) putchar(‘1‘);
		}
		while (minCan >= 0)
		{
			putchar(minId + ‘0‘);
			minCan--;
		}
		putchar(‘\n‘);
	}
	return 0;
}

codechef Birthday Candles 题解,布布扣,bubuko.com

时间: 2024-10-21 03:10:06

codechef Birthday Candles 题解的相关文章

Codechef Nuclear Reactors 题解

There are K nuclear reactor chambers labelled from 0 to K-1. Particles are bombarded onto chamber 0. The particles keep collecting in the chamber 0. However if at any time, there are more than N particles in a chamber, a reaction will cause 1 particl

codechef Cleaning Up 题解

After a long and successful day of preparing food for the banquet, it is time to clean up. There is a list of n jobs to do before the kitchen can be closed for the night. These jobs are indexed from 1 to n. Most of the cooks have already left and onl

codechef Permutation Cycles 题解

We consider permutations of the numbers 1,..., N for some N. By permutation we mean a rearrangment of the number 1,...,N. For example 2  4  5  1  7  6  3  8 is a permutation of 1,2,...,8. Of course, 1  2  3  4  5  6  7  8 is also a permutation of 1,2

codechef Turbo Sort 题解

Input t – the number of numbers in list, then t lines follow [t <= 10^6]. Each line contains one integer: N [0 <= N <= 10^6] Output Output given numbers in non decreasing order. Example Input: 5 5 3 6 7 1 Output: 1 3 5 6 7 大数据的排序,输入和输出. 一开始使用了cou

codechef Top Batsmen题解

A cricket team consists of 11 players and some are good at batting, others are good at bowling and some of them are good at both batting and bowling. The batting coach wants to select exactly K players having maximum possible sum of scores. Given the

codechef Cutting Recipes题解

Cutting Recipes The chef has a recipe he wishes to use for his guests, but the recipe will make far more food than he can serve to the guests. The chef therefore would like to make a reduced version of the recipe which has the same ratios of ingredie

codechef Prime Palindromes 题解

给定一个数,求一个新数要大于等于这个数,而这个新数既要是palindromes回文又要是prime素数. 题目很简单,有人都使用取巧的方法保存好结果直接查表. 或者暴力法求解. 这里不使用保存表的方法,也不要用暴力法.- 这些方法都不好. 使用的技巧有: 1 而是使用next palindrome的技巧,只需要O(n),n是数位,可以认为是常数了. 2 判断素数的方法,时间效率是O(sqrt(n)), n是数值大小,如果是重复判断很多数是否是素数是有办法优化的,但是如果是单个素数判断的话,我还想

codechef Recipe Reconstruction 题解

Chef had an interesting dream last night. He dreamed of a new revolutionary chicken recipe. When he woke up today he tried very hard to reconstruct the ingredient list. But, he could only remember certain ingredients. To simplify the problem, the ing

codechef Arranging Cup-cakes题解

Arranging Cup-cakes Our Chef is catering for a big corporate office party and is busy preparing different mouth watering dishes. The host has insisted that he serves his delicious cupcakes for dessert. On the day of the party, the Chef was over-seein