PTA 09-排序2 Insert or Merge (25分)

题目地址

https://pta.patest.cn/pta/test/16/exam/4/question/675

5-13 Insert or Merge   (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 100≤100). Then in the next line, NN integers are given as the initial sequence. The last line contains the partially sorted sequence of the NN numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

没什么好解法,只能一边排一边试

/*
评测结果
时间	结果	得分	题目	编译器	用时(ms)	内存(MB)	用户
2017-07-06 00:40	正在评测	0	5-13	gcc	无	无
测试点结果
测试点	结果	得分/满分	用时(ms)	内存(MB)
测试点1	答案正确	7/7	1	1
测试点2	答案正确	6/6	2	1
测试点3	答案正确	1/1	1	1
测试点4	答案正确	1/1	2	1
测试点5	答案正确	3/3	1	1
测试点6	答案正确	4/4	1	1
测试点7	答案正确	3/3	2	1

用自顶向下递归法做归并被坑了,这题需要自底向上两两合并
*/

#include<stdio.h>
#define MAXN 100
int A[MAXN],B[MAXN],tmp[MAXN];
int gNextTurnToPrint=0;
int gPrinted=0;
int gSortType=0;
void swap(int *a,int *b)
{
	int temp;
	temp=*a;
	*a=*b;
	*b=temp;
}

void CheckMethod(int N)
{
	if(gPrinted)
		return;

	int i;
	if (gNextTurnToPrint==1)
	{
		if(gSortType==0)
			printf("Insertion Sort\n");
		else
			printf("Merge Sort\n");

		for(i=0;i<N;i++)
			{
				printf("%d",A[i]);
				if(i!=N-1)
					printf(" ");
			}
		gNextTurnToPrint=0;
		gPrinted=1;
		return;
	}

	for (i=0;i<N;i++)
	{
		if(A[i]!=B[i])
		return;
	}
	gNextTurnToPrint=1;
}

void InsertionSort(int a[],int left ,int right,int N)
{
	int i,j,temp;
	for(i=left;i<right;i++)
	{
		temp=a[i+1];
		for(j=i+1;j>left;j--)
		{
			if(temp<a[j-1])
				a[j]=a[j-1];
			else break;
		}
		a[j]=temp;
		CheckMethod(N);
	}
}
void Merge(int a[],int tmp[],int left,int leftend,int right,int rightend)
{
	int i,j,k;
	i=left;
	j=right;
	k=left;
	while(i<=leftend && j<=rightend)
	{
		if (a[i]<=a[j])
			tmp[k++]=a[i++];
		else
			tmp[k++]=a[j++];
	}
	while(i<=leftend)
		tmp[k++]=a[i++];
	while(j<=rightend)
		tmp[k++]=a[j++];

	k=left;
	while(k<=rightend)
	{
		a[k]=tmp[k];
		k++;
	}
}

void MergeSort(int a[],int tmp[],int left,int right,int N)
{
	int mid=(left+right)/2;
	if(left<right)
	{
		MergeSort(a,tmp,left,mid,N);
		MergeSort(a,tmp,mid+1,right,N);
		Merge(a,tmp,left,mid,mid+1,right);
	}
	CheckMethod(N);
}

void Merge_pass(int a[],int tmp[],int N)
{
	int i,length=1;
	while(length<N)
	{
		for(i=0;i<N-2*length;i+=2*length)
			Merge(a,tmp,i,i+length-1,i+length,i+2*length-1);
		if(i+length<N)
			Merge(a,tmp,i,i+length-1,i+length,N-1);
		length*=2;
		CheckMethod(N);
	}
}
int main()
{
	int i,N;
	scanf("%d",&N);

	for(i=0;i<N;i++)
	{
		scanf("%d",&A[i]);
		tmp[i]=A[i];
	}

	for(i=0;i<N;i++)
	{
		scanf("%d",&B[i]);
	}

	InsertionSort(A,0,N-1,N);

	if(!gPrinted)
	{
		for(i=0;i<N;i++)
		{
			A[i]=tmp[i];
		}
		gSortType=1;
		Merge_pass(A,tmp,N);
	}

}

  

 
时间: 2024-12-24 20:43:38

PTA 09-排序2 Insert or Merge (25分)的相关文章

1089. Insert or Merge (25)【排序】——PAT (Advanced Level) Practise

题目信息 1089. Insert or Merge (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, find

07-2. Insert or Merge (25)

07-2. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion so

pat1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

[PTA] PAT(A) 1012 The Best Rank (25 分)

目录 Problem Solution Analysis Code Problem portal: 1012 The Best Rank (25 分) Solution Analysis ?一名学生有三门科目,以及计算出的一个平均成绩,每一个成绩都会有一个排名,现在想要让你输出某一个同学最高的排名(四种成绩排名的最高),以及对应的科目 ?如果给定的同学的四种课程排名的名次信息已经存在,那么就很简单,在里面找到最小的名次,以及对应的科目输出即可. ?可以创建四个数组,数组的每个元素存储某一门科目的

PTA乙级 (*1095 解码PAT准考证 (25分))

1095 解码PAT准考证 (25分) https://pintia.cn/problem-sets/994805260223102976/problems/1071786104348536832 题目大意:给出一组学生的准考证号和成绩,准考证号包含了等级(乙甲顶),考场号,日期,和个人编号信息,并有三种查询方式查询一:给出考试等级,找出该等级的考生,按照成绩降序,准考证升序排序查询二:给出考场号,统计该考场的考生数量和总得分查询三:给出考试日期,查询改日期下所有考场的考试人数,按照人数降序,考

[PTA] PAT(A) 1007 Maximum Subsequence Sum (25 分)

目录 Problem Description Input Output Sample Sample Input Sample Output Solution Analysis Code Problem portal: 1007 Maximum Subsequence Sum (25 分) Description Given a sequence of $K$ integers { $N_{1}?$, $N_{2}?$, $...$, $N_{K}$ }. A continuous subsequ

PAT 1088 1089. Insert or Merge (25)(排序啊)

题目链接:http://www.patest.cn/contests/pat-a-practise/1089 According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input d

A1089. Insert or Merge (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li