2015 ACM/ICPC Asia Regional Changchun Online Pro 1008 Elven Postman

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0

Problem Description

Elves
are very peculiar creatures. As we all know, they can live for a very
long time and their magical prowess are not something to be taken
lightly. Also, they live on trees. However, there is something about
them you may not know. Although delivering stuffs through magical
teleportation is extremely convenient (much like emails). They still
sometimes prefer other more “traditional” methods.

So, as a
elven postman, it is crucial to understand how to deliver the mail to
the correct room of the tree. The elven tree always branches into no
more than two paths upon intersection, either in the east direction or
the west. It coincidentally looks awfully like a binary tree we human
computer scientist know. Not only that, when numbering the rooms, they
always number the room number from the east-most position to the west.
For rooms in the east are usually more preferable and more expensive due
to they having the privilege to see the sunrise, which matters a lot in
elven culture.

Anyways, the elves usually wrote down all the
rooms in a sequence at the root of the tree so that the postman may know
how to deliver the mail. The sequence is written as follows, it will go
straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then
go to the next unvisited east-most room, writing down every unvisited
room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

Input

First you are given an integer T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2

4

2 1 4 3

3

1 2 3

6

6 5 4 3 21

1

1

Sample Output

E

WE

EEEEE

序列给出的是dfs序,所以只要计算出每个结点的左右子树的结点数。规定右树代表‘E‘方向。

因为roomId小的优先访问,所有当当前结点roomId为a[u]的时候,只需要知道前面已经访问过的roomId比a[u]更小的有多少个

就知道a[u]的右树中有多少个子节点。这个信息可以用树状数组维护。要知道左树上的结点数量就在dfs的时候再维护一个信息,当前树上结点的总数量tot。

把询问离线,dfs的时候记录路径,到达一个询问的点的时候记录答案。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e3+100;
int n;

int C[maxn];
#define lowbit(x) (x&-x)
int sum(int x)
{
    int ret = 0;
    while(x > 0){
        ret += C[x]; x -= lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x <= n){
        C[x] += d; x += lowbit(x);
    }
}

string ans[maxn];

int qry[maxn];
bool mark[maxn];

int a[maxn];

char path[maxn];

bool vis[maxn];

void dfs(int u = 1,int f = 0,int d = 1,int tot = n)
{
    if(vis[u] || tot <= 0) return;
    vis[u] = true;
    if(mark[a[u]]){
        ans[a[u]].assign(path+1,path+d);
    }
    add(a[u],1);
    if(tot == 1) return;
    int ct = a[u]- sum(a[u])+1;
    int rst = u+ct;

    if(rst>u+1 && u < n) {
        path[d] = ‘E‘;
        dfs(u+1,u,d+1,ct-1);
    }
    if(rst>u && rst<=n){
        path[d] = ‘W‘;
        dfs(rst,u,d+1,tot-ct);
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    int T; scanf("%d",&T);
    a[0] = 0; path[0] = ‘*‘;
    while(T--){
        scanf("%d",&n);
        for(int i = 1; i <= n; i++) scanf("%d",a+i);
        int q;
        scanf("%d",&q);
        memset(C,0,sizeof(C));
        memset(mark,0,sizeof(mark));
        for(int i = 0; i < q; i++){
            scanf("%d",qry+i);
            mark[qry[i]] = true;
        }
        memset(vis,0,sizeof(vis));
        dfs();
        for(int i = 0; i < q; i++){
            printf("%s\n",ans[qry[i]].c_str());
        }
    }
    return 0;
}
时间: 2024-10-08 14:15:37

2015 ACM/ICPC Asia Regional Changchun Online Pro 1008 Elven Postman的相关文章

2015 ACM/ICPC Asia Regional Changchun Online HDU 5444 Elven Postman【二叉排序树的建树和遍历查找】

Elven Postman Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 591    Accepted Submission(s): 329 Problem Description Elves are very peculiar creatures. As we all know, they can live for a very

2015 ACM/ICPC Asia Regional Changchun Online Pro 1002 (拓扑排序+并查集)

Ponds Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 0    Accepted Submission(s): 0 Problem Description Betty owns a lot of ponds, some of them are connected with other ponds by pipes, and th

2015 ACM/ICPC Asia Regional Changchun Online Pro 1005 Travel

Travel Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 46    Accepted Submission(s): 20 Problem Description Jack likes to travel around the world, but he doesn’t like to wait. Now, he is trave

(并查集)Travel -- hdu -- 5441(2015 ACM/ICPC Asia Regional Changchun Online )

http://acm.hdu.edu.cn/showproblem.php?pid=5441 Travel Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 2061    Accepted Submission(s): 711 Problem Description Jack likes to travel around the wo

(线段树 区间查询)The Water Problem -- hdu -- 5443 (2015 ACM/ICPC Asia Regional Changchun Online)

链接: http://acm.hdu.edu.cn/showproblem.php?pid=5443 The Water Problem Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 738    Accepted Submission(s): 591 Problem Description In Land waterless, w

HDU 5438 Ponds (拓扑排序+DFS)2015 ACM/ICPC Asia Regional Changchun Online

[题目链接]:click here~~ [题目大意]: 题意:在一个无向图中有 p 个点, m 条边,每个点有一个值 vi .不断的删去度数小于2的点直到不能删为止.求新图中所有点个数为奇数的连通分量的点值的和. 1<p<10^4,1<m<10^5 [思路]删边考虑类似拓扑排序的写法,不过topsort是循环一遍1到n结点入度为0的结点,然后加入到队列中,这里只要改一下度数小于等于1,最后DFS 判断一下 挫挫的代码: /* * Problem: HDU No.5438 * Run

HDU 5444 Elven Postman (2015 ACM/ICPC Asia Regional Changchun Online)

[题目链接]:click here~~ [题目大意]: HDU 5444 题意:在最初为空的二叉树中不断的插入n个数.对于每个数,从根节点开始判断,如果当前节点为空,就插入当前节点,如果当前节点不为空,则小于当前节点的值,插入右子树,否则插入左子树. 接着q次询问,每次询问一个值在二叉树中从根节点开始的查找路径. 3 直接用二叉树模拟整个插入和询问的过程 代码: /* * Problem: HDU No.5444 * Running time: 0MS * Complier: G++ * Aut

2015 ACM/ICPC Asia Regional Changchun Online HDU - 5441 (离线+并查集)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=5441 题意:给你n,m,k,代表n个城市,m条边,k次查询,每次查询输入一个x,然后让你一个城市对(u,v)满足两点之间每一条边都不超过x,问有多少对 思路:首先我想到的是dfs求出每个查询小于等于他的一个连通块,然后num*(num-1)就是答案,但是时间只有一秒,这个复杂度是5*1e8,超时了(亲身体验了) 然后我们想这个是离线的,我们可不可以由小到大来推,这样前面的贡献到后面就依然能用了,但是我们

hdu 5444 Elven Postman(根据先序遍历和中序遍历求后序遍历)2015 ACM/ICPC Asia Regional Changchun Online

很坑的一道题,读了半天才读懂题,手忙脚乱的写完(套上模板+修改模板),然后RE到死…… 题意: 题面上告诉了我们这是一棵二叉树,然后告诉了我们它的先序遍历,然后,没了……没了! 反复读题,终于在偶然间注意到了这一句——"Not only that, when numbering the rooms, they always number the room number from the east-most position to the west." 它告诉我们,东边的点总是比西边的点