PAT 1001

1001. A+B Format (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

解析:略

code:
#include <iostream>
using namespace std;

int main(){
  int a,b;
  cin>>a>>b;

  int c = a + b;
  if(c < 0){
      cout<<"-";
      c = -c;
  }

  if(c >= 1000000){
      cout<<c/1000000<<","<<(c/1000)%1000<<","<<c%1000;
  }
  else if(c >= 1000){
      cout<<c/1000<<","<<c%1000;
  }
  else{
      cout<<c;
  }

  return 0;
}

原文:http://alvenxuan.iteye.com/blog/1450533

我自己的方法:

#include <iostream>
#include <string>
#include <vector>
using namespace std;

int main(){
    int a,b,c;
    vector<char> cache;
    cin>>a>>b;
    c = a + b;
    if(c < 0)
    {
        cout<<‘-‘;
        c = -c;
    }
    else if(c == 0)
    {
        cout<<c;
        return 0;
    }

    int count = 0;
    while(c!=0){
        count++;
        cache.push_back(c%10 + ‘0‘);

        c /= 10;
        if(c != 0 && count%3 == 0)
        cache.push_back(‘,‘);
    }

    for(int i=cache.size()-1; i>=0; i--){
        cout<<cache[i];
    } 

    return 0;
}
时间: 2024-10-18 13:31:52

PAT 1001的相关文章

PAT 1001. 害死人不偿命的(3n+1)猜想 (15)

题目链接:http://pat.zju.edu.cn/contests/pat-b-practise/1001 卡拉兹(Callatz)猜想: 对任何一个自然数n,如果它是偶数,那么把它砍掉一半:如果它是奇数,那么把(3n+1)砍掉一半.这样一直反复砍下去,最后一定在某一步得到n=1.卡拉兹在1950年的世界数学家大会上公布了这个猜想,传说当时耶鲁大学师生齐动员,拼命想证明这个貌似很傻很天真的命题,结果闹得学生们无心学业,一心只证(3n+1),以至于有人说这是一个阴谋,卡拉兹是在蓄意延缓美国数学

PAT——1001 害死人不偿命的(3n+1)猜想 (15)

对给定的任一不超过1000的正整数n,简单地数一下,需要多少步(砍几下)才能得到n=1? 输入格式:每个测试输入包含1个测试用例,即给出自然数n的值. 输出格式:输出从n计算到1需要的步数. 输入样例: 3 输出样例: 5 import java.util.Scanner; public class Main{ public static void main(String[] args){ int i = 0; Scanner s = new Scanner(System.in); int a

PAT 1001. 害死人不偿命的(3n+1)猜想

1001. 害死人不偿命的(3n+1)猜想 (15) 卡拉兹(Callatz)猜想: 对任何一个自然数n,如果它是偶数,那么把它砍掉一半:如果它是奇数,那么把(3n+1)砍掉一半.这样一直反复砍下去,最后一定在某一步得到n=1.卡拉兹在1950年的世界数学家大会上公布了这个猜想,传说当时耶鲁大学师生齐动员,拼命想证明这个貌似很傻很天真的命题,结果闹得学生们无心学业,一心只证(3n+1),以至于有人说这是一个阴谋,卡拉兹是在蓄意延缓美国数学界教学与科研的进展-- 我们今天的题目不是证明卡拉兹猜想,

PAT 1001. A+B Format(水题)

#include<cstdio> #include<cstring> using namespace std; char s[10]; int main() { int a,b; while(scanf("%d%d",&a,&b)==2) { memset(s,0,sizeof(s)); a=a+b; if(a==0) { printf("0\n"); continue; } int aa=a; b=0; if(a<0)

PAT 1001. A+B Format

#include<stdio.h> int a, b; int sum; int main(){ while (scanf("%d %d", &a, &b)!=EOF){ sum = a + b; if (sum < 1000&&sum>-1000)printf("%d\n", sum); else{ int sum1 = sum % 1000; int sum2 = sum / 1000; int sum3

PAT 1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits). Input Each input file contains one test case. Each case contains a pair of integer

PAT——1001. 害死人不偿命的(3n+1)猜想

卡拉兹(Callatz)猜想: 对任何一个自然数n,如果它是偶数,那么把它砍掉一半:如果它是奇数,那么把(3n+1)砍掉一半.这样一直反复砍下去,最后一定在某一步得到n=1.卡拉兹在1950年的世界数学家大会上公布了这个猜想,传说当时耶鲁大学师生齐动员,拼命想证明这个貌似很傻很天真的命题,结果闹得学生们无心学业,一心只证(3n+1),以至于有人说这是一个阴谋,卡拉兹是在蓄意延缓美国数学界教学与科研的进展-- 我们今天的题目不是证明卡拉兹猜想,而是对给定的任一不超过1000的正整数n,简单地数一下

newcoder PAT 1001 Rational Sum (20)

#include<iostream> #include<stdio.h> #include<cstring> #include<algorithm> using namespace std; int gcd(int a,int b) { return b == 0 ? a: gcd(b,a%b); } int s[105]; int x[105]; int main() { int n; cin >> n; for(int i = 0;i <

PAT甲级考试题库1001 A+B Format 代码实现及相关知识学习

准备参加九年九月份的PAT甲级证书考试,对网站上的题目进行总结分析: 1001题 A+B Format (20 分) Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits). 计算a+b的值并以一定格式输出其和sum(数字需要