PAT 甲级 1019 General Palindromic Number

https://pintia.cn/problem-sets/994805342720868352/problems/994805487143337984

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits a~i~ as the sum of (a~i~b^i^) for i from 0 to k. Here, as usual, 0 <= a~i~ < b for all i and a~k~ is non-zero. Then N is palindromic if and only if a~i~ = a~k-i~ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 10^9^ is the decimal number and 2 <= b <= 10^9^ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "a~k~ a~k-1~ ... a~0~". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题解: char 能存 300左右 ; int -2^31, 2^31 - 1 ; long long 存不到20位 (-2^63, 2^63 - 1), 所以不能用 char

代码:

#include <bits/stdc++.h>
using namespace std;

int num[1111], out[1111];

int main() {
    int n, d;
    scanf("%d%d", &n, &d);
    if(n == 0) {
        printf("Yes\n0\n");
        return 0;
    }

    int cnt = 0;
    while(n != 0) {
        num[cnt ++] = n % d;
        n /= d;
    }

    for(int i = 0; i < cnt; i ++) {
        out[i] = num[i];
    }
    for(int i = 0; i <= cnt / 2 - 1; i ++)
        swap(num[i], num[cnt - 1 - i]);
    //cout<<num<<endl;
    //cout<<out<<endl;

    int flag = 1;
    for(int i = 0; i < cnt; i ++) {
        if(out[i] != num[i]) flag = 0;
    }
    if(flag) {
        printf("Yes\n");
        for(int i = cnt - 1; i >= 0; i --) {
            printf("%d", num[i]);
            printf("%s", i != 0 ? " " : "\n");
        }
    }
    else {
        printf("No\n");
        for(int i = cnt - 1; i >= 0; i --) {
            printf("%d", out[i]);
            printf("%s", i != 0 ? " " : "\n");
        }
    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/zlrrrr/p/9427817.html

时间: 2024-10-13 11:17:22

PAT 甲级 1019 General Palindromic Number的相关文章

PAT 甲级 1019 General Palindromic Number (进制转换,vector运用,一开始2个测试点没过)

1019 General Palindromic Number (20 分)   A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Althoug

PAT甲级——A1019 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons

PAT Advanced 1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons

PAT:1019. General Palindromic Number (20) AC

#include<stdio.h> #include<stdlib.h> int main() { int n,jin; scanf("%d%d",&n,&jin); if(0==n) //特判0的时候,就是回文数 { printf("Yes\n0"); return 0; } int arr[50],i=0; while(n!=0) { arr[i++]=n%jin; n/=jin; } int tag=0; for(int

PAT 1019 General Palindromic Number[简单]

1019 General Palindromic Number (20)(20 分) A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Altho

1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons

1019. General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons

1019 General Palindromic Number (20)(20 point(s))

problem A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most of

PAT (Advanced Level) 1019. General Palindromic Number (20)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<queue> #include<vector> using namespace std; int s[10000],tot; int n,b; bool check() { for(int i=0; i<=tot